summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-03-23 08:23:48 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-03-23 08:23:48 +0000
commit3ef5179a36704188c8dfadcdfad7c63ddd143bcd (patch)
tree9982fd33d436851275982b8fbf62879ab026c2e6 /net-libs
parentFix slot-deps on gnome libs, remove old (diff)
downloadgentoo-2-3ef5179a36704188c8dfadcdfad7c63ddd143bcd.tar.gz
gentoo-2-3ef5179a36704188c8dfadcdfad7c63ddd143bcd.tar.bz2
gentoo-2-3ef5179a36704188c8dfadcdfad7c63ddd143bcd.zip
Version bump. Fix automagicness. Non-maintainer commit.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/telepathy-qt4/ChangeLog9
-rw-r--r--net-libs/telepathy-qt4/files/0.5.12_automagicness.patch169
-rw-r--r--net-libs/telepathy-qt4/metadata.xml10
-rw-r--r--net-libs/telepathy-qt4/telepathy-qt4-0.5.12.ebuild51
4 files changed, 233 insertions, 6 deletions
diff --git a/net-libs/telepathy-qt4/ChangeLog b/net-libs/telepathy-qt4/ChangeLog
index 8519c41828c8..aa234e9792c1 100644
--- a/net-libs/telepathy-qt4/ChangeLog
+++ b/net-libs/telepathy-qt4/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/telepathy-qt4
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt4/ChangeLog,v 1.5 2011/03/04 12:56:42 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt4/ChangeLog,v 1.6 2011/03/23 08:23:47 scarabeus Exp $
+
+*telepathy-qt4-0.5.12 (23 Mar 2011)
+
+ 23 Mar 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/0.5.12_automagicness.patch, +telepathy-qt4-0.5.12.ebuild,
+ metadata.xml:
+ Version bump. Fix automagicness. Non-maintainer commit.
*telepathy-qt4-0.5.8 (04 Mar 2011)
diff --git a/net-libs/telepathy-qt4/files/0.5.12_automagicness.patch b/net-libs/telepathy-qt4/files/0.5.12_automagicness.patch
new file mode 100644
index 000000000000..e4f0f11a3e64
--- /dev/null
+++ b/net-libs/telepathy-qt4/files/0.5.12_automagicness.patch
@@ -0,0 +1,169 @@
+diff -urN telepathy-qt4-0.5.12.old/CMakeLists.txt telepathy-qt4-0.5.12/CMakeLists.txt
+--- telepathy-qt4-0.5.12.old/CMakeLists.txt 2011-03-23 08:51:03.000000000 +0100
++++ telepathy-qt4-0.5.12/CMakeLists.txt 2011-03-23 09:02:55.000000000 +0100
+@@ -85,6 +85,11 @@
+ include(Doxygen)
+ include(MacroLogFeature)
+
++# options
++option(WITH_Glib "Enable building with glib features" ON)
++option(WITH_Farsight "Enable building with farsight features" ON)
++option(ENABLE_DEBUG_OUTPUT "Compile support for printing debug output to stderr" ON)
++
+ # external dependencies
+
+ # Required dependencies
+@@ -98,10 +103,9 @@
+
+ add_definitions(-DQT_NO_CAST_FROM_ASCII)
+
+-set(ENABLE_DEBUG_OUTPUT ON CACHE BOOL "If activated, compiles support for printing debug output to stderr")
+-if (ENABLE_DEBUG_OUTPUT)
++if(ENABLE_DEBUG_OUTPUT)
+ add_definitions(-DENABLE_DEBUG)
+-endif (ENABLE_DEBUG_OUTPUT)
++endif(ENABLE_DEBUG_OUTPUT)
+
+ # Check for Qt4 Glib support
+ include(CheckCXXSourceCompiles)
+@@ -109,21 +113,6 @@
+ set(CMAKE_REQUIRED_DEFINITIONS "")
+ set(CMAKE_REQUIRED_FLAGS "")
+
+-CHECK_CXX_SOURCE_COMPILES("
+-#include <QtCore/QtGlobal>
+-int main()
+-{
+-#if defined(QT_NO_GLIB)
+-#error \"Qt was compiled with Glib disabled\"
+-#endif
+-return 0;
+-}"
+-QT4_GLIB_SUPPORT)
+-macro_log_feature(QT4_GLIB_SUPPORT "Qt4 Glib Support"
+- "QtCore library using Glib's main event loop"
+- "http://qt.nokia.com/" FALSE ""
+- "Needed, together with Telepathy-Glib, to build most of the unit tests")
+-
+ # Check for operator== in QDBusVariant
+ SET(CMAKE_REQUIRED_LIBRARIES ${QT_QTCORE_LIBRARY} ${QT_QTDBUS_LIBRARY})
+ CHECK_CXX_SOURCE_COMPILES("
+@@ -172,50 +161,76 @@
+
+ # Find GLib2, GObject, DBus and LibXml2
+ # Those are needed for the insane include dir dependency hell
+-find_package(GLIB2)
+-find_package(GObject)
+-find_package(DBus)
+-find_package(DBusGLib)
+-find_package(LibXml2)
+-
+-# Find tp-farsight
+-set(TELEPATHY_FARSIGHT_MIN_VERSION "0.0.4")
+-find_package(TelepathyFarsight)
+-macro_log_feature(TELEPATHYFARSIGHT_FOUND "Telepathy-Farsight"
+- "A Framework for dealing with audio/video conferencing protocols"
+- "http://farsight.freedesktop.org/wiki/" FALSE "0.0.4"
+- "Needed, together with GStreamer, to build telepathy-qt4-farsight and some additional examples")
+-
+-# Find GStreamer
+-find_package(GStreamer)
+-macro_log_feature(GSTREAMER_FOUND "GStreamer"
+- "An open source multimedia framework"
+- "Needed, together with Tp-Farsight, to build telepathy-qt4-farsight and some additional examples"
+- "http://www.gstreamer.net/" FALSE)
+-
+-# Build TelepathyQt4-Farsight only if GStreamer, TelepathyFarsight and all of their dependencies were found
+-if (TELEPATHYFARSIGHT_FOUND AND GSTREAMER_FOUND AND GLIB2_FOUND AND GOBJECT_FOUND AND DBUS_FOUND AND LIBXML2_FOUND)
+- set (FARSIGHT_COMPONENTS_FOUND 1)
+-else (TELEPATHYFARSIGHT_FOUND AND GSTREAMER_FOUND AND GLIB2_FOUND AND GOBJECT_FOUND AND DBUS_FOUND AND LIBXML2_FOUND)
+- set (FARSIGHT_COMPONENTS_FOUND 0)
+-endif (TELEPATHYFARSIGHT_FOUND AND GSTREAMER_FOUND AND GLIB2_FOUND AND GOBJECT_FOUND AND DBUS_FOUND AND LIBXML2_FOUND)
++if(WITH_Farsight)
++ find_package(GLIB2 REQUIRED)
++ find_package(GObject REQUIRED)
++ find_package(DBus REQUIRED)
++ find_package(DBusGLib REQUIRED)
++ find_package(LibXml2 REQUIRED)
++
++ # Find tp-farsight
++ set(TELEPATHY_FARSIGHT_MIN_VERSION "0.0.4")
++ find_package(TelepathyFarsight REQUIRED)
++ macro_log_feature(TELEPATHYFARSIGHT_FOUND "Telepathy-Farsight"
++ "A Framework for dealing with audio/video conferencing protocols"
++ "http://farsight.freedesktop.org/wiki/" FALSE "0.0.4"
++ "Needed, together with GStreamer, to build telepathy-qt4-farsight and some additional examples")
++
++ # Find GStreamer
++ find_package(GStreamer REQUIRED)
++ macro_log_feature(GSTREAMER_FOUND "GStreamer"
++ "An open source multimedia framework"
++ "Needed, together with Tp-Farsight, to build telepathy-qt4-farsight and some additional examples"
++ "http://www.gstreamer.net/" FALSE)
++
++ # Build TelepathyQt4-Farsight only if GStreamer, TelepathyFarsight and all of their dependencies were found
++ if (TELEPATHYFARSIGHT_FOUND AND GSTREAMER_FOUND AND GLIB2_FOUND AND GOBJECT_FOUND AND DBUS_FOUND AND LIBXML2_FOUND)
++ set (FARSIGHT_COMPONENTS_FOUND 1)
++ else (TELEPATHYFARSIGHT_FOUND AND GSTREAMER_FOUND AND GLIB2_FOUND AND GOBJECT_FOUND AND DBUS_FOUND AND LIBXML2_FOUND)
++ set (FARSIGHT_COMPONENTS_FOUND 0)
++ endif (TELEPATHYFARSIGHT_FOUND AND GSTREAMER_FOUND AND GLIB2_FOUND AND GOBJECT_FOUND AND DBUS_FOUND AND LIBXML2_FOUND)
++else(WITH_Farsight)
++ set(FARSIGHT_COMPONENTS_FOUND 0)
++endif(WITH_Farsight)
+
+ # Find telepathy-glib
+-set(TELEPATHY_GLIB_MIN_VERSION 0.13.10)
+-find_package(TelepathyGlib)
+-macro_log_feature(TELEPATHYGLIB_FOUND "Telepathy-glib"
+- "Glib bindings for Telepathy"
+- "http://telepathy.freedesktop.org/" FALSE "0.13.0"
+- "Needed, together with Qt Glib integration, to build most of the unit tests")
+-
+-find_program(GLIB_GENMARSHAL glib-genmarshal)
+-
+-# Enable glib-based tests only if Qt4 has GLib support and Telepathy-glib was found
+-if(QT4_GLIB_SUPPORT AND TELEPATHYGLIB_FOUND AND GLIB2_FOUND AND DBUS_FOUND)
+- set(ENABLE_TP_GLIB_TESTS 1)
+-else(QT4_GLIB_SUPPORT AND TELEPATHYGLIB_FOUND AND GLIB2_FOUND AND DBUS_FOUND)
+- set(ENABLE_TP_GLIB_TESTS 0)
+-endif(QT4_GLIB_SUPPORT AND TELEPATHYGLIB_FOUND AND GLIB2_FOUND AND DBUS_FOUND)
++if(WITH_Glib)
++ CHECK_CXX_SOURCE_COMPILES("
++ #include <QtCore/QtGlobal>
++ int main()
++ {
++ #if defined(QT_NO_GLIB)
++ #error \"Qt was compiled with Glib disabled\"
++ #endif
++ return 0;
++ }"
++ QT4_GLIB_SUPPORT)
++ macro_log_feature(QT4_GLIB_SUPPORT "Qt4 Glib Support"
++ "QtCore library using Glib's main event loop"
++ "http://qt.nokia.com/" FALSE ""
++ "Needed, together with Telepathy-Glib, to build most of the unit tests")
++
++ find_package(GLIB2 REQUIRED)
++ find_package(DBus REQUIRED)
++
++ set(TELEPATHY_GLIB_MIN_VERSION 0.13.10)
++ find_package(TelepathyGlib REQUIRED)
++ macro_log_feature(TELEPATHYGLIB_FOUND "Telepathy-glib"
++ "Glib bindings for Telepathy"
++ "http://telepathy.freedesktop.org/" FALSE "0.13.0"
++ "Needed, together with Qt Glib integration, to build most of the unit tests")
++
++ find_program(GLIB_GENMARSHAL glib-genmarshal)
++ # Enable glib-based tests only if Qt4 has GLib support and Telepathy-glib was found
++ if(QT4_GLIB_SUPPORT AND TELEPATHYGLIB_FOUND AND GLIB2_FOUND AND DBUS_FOUND)
++ set(ENABLE_TP_GLIB_TESTS 1)
++ else(QT4_GLIB_SUPPORT AND TELEPATHYGLIB_FOUND AND GLIB2_FOUND AND DBUS_FOUND)
++ set(ENABLE_TP_GLIB_TESTS 0)
++ endif(QT4_GLIB_SUPPORT AND TELEPATHYGLIB_FOUND AND GLIB2_FOUND AND DBUS_FOUND)
++else(WITH_Glib)
++ set(ENABLE_TP_GLIB_TESTS 0)
++endif(WITH_Glib)
++
+
+ # Add the source subdirectories
+ add_subdirectory(TelepathyQt4)
diff --git a/net-libs/telepathy-qt4/metadata.xml b/net-libs/telepathy-qt4/metadata.xml
index e823d44ced33..25afcbce2d8c 100644
--- a/net-libs/telepathy-qt4/metadata.xml
+++ b/net-libs/telepathy-qt4/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>qt</herd>
- <use>
- <flag name='glib'>Enable support for various telepathy/glib related
- packages</flag>
- </use>
+ <herd>qt</herd>
+ <use>
+ <flag name='glib'>Enable support for various telepathy/glib related packages</flag>
+ <flag name='farsight'>Enable support for farsight connection manager</flag>
+ </use>
</pkgmetadata>
diff --git a/net-libs/telepathy-qt4/telepathy-qt4-0.5.12.ebuild b/net-libs/telepathy-qt4/telepathy-qt4-0.5.12.ebuild
new file mode 100644
index 000000000000..64486d163882
--- /dev/null
+++ b/net-libs/telepathy-qt4/telepathy-qt4-0.5.12.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt4/telepathy-qt4-0.5.12.ebuild,v 1.1 2011/03/23 08:23:47 scarabeus Exp $
+
+PYTHON_DEPEND="2"
+
+EAPI=3
+inherit python base cmake-utils
+
+DESCRIPTION="Qt4 bindings for the Telepathy D-Bus protocol"
+HOMEPAGE="http://telepathy.freedesktop.org/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug glib farsight"
+
+RDEPEND="
+ x11-libs/qt-core:4[glib?]
+ x11-libs/qt-dbus:4
+ dev-python/dbus-python
+ farsight? (
+ dev-libs/dbus-glib
+ dev-libs/libxml2
+ media-libs/gstreamer
+ net-libs/telepathy-glib
+ net-libs/telepathy-farsight
+ )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PV}_automagicness.patch"
+)
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable debug DEBUG_OUTPUT)
+ $(cmake-utils_use_with glib)
+ $(cmake-utils_use_with farsight)
+ )
+ cmake-utils_src_configure
+}