summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-12-17 00:23:08 +0000
committerMike Frysinger <vapier@gentoo.org>2013-12-17 00:23:08 +0000
commit5d52502599d71d0114b3ae538c761226d3ed78eb (patch)
treebdbd94b92f004c500d59a01548cd018ea09ced93 /net-libs
parentOption --without-compress-info is no longer available in upstream configure. ... (diff)
downloadgentoo-2-5d52502599d71d0114b3ae538c761226d3ed78eb.tar.gz
gentoo-2-5d52502599d71d0114b3ae538c761226d3ed78eb.tar.bz2
gentoo-2-5d52502599d71d0114b3ae538c761226d3ed78eb.zip
Version bump #489006 by michal.halenka.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnfsidmap/ChangeLog10
-rw-r--r--net-libs/libnfsidmap/files/libnfsidmap-0.19-getgrouplist.patch3
-rw-r--r--net-libs/libnfsidmap/libnfsidmap-0.25.ebuild45
3 files changed, 55 insertions, 3 deletions
diff --git a/net-libs/libnfsidmap/ChangeLog b/net-libs/libnfsidmap/ChangeLog
index dab88a1601d8..88b956ebeff6 100644
--- a/net-libs/libnfsidmap/ChangeLog
+++ b/net-libs/libnfsidmap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libnfsidmap
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfsidmap/ChangeLog,v 1.41 2012/05/21 19:13:27 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfsidmap/ChangeLog,v 1.42 2013/12/17 00:23:08 vapier Exp $
+
+*libnfsidmap-0.25 (17 Dec 2013)
+
+ 17 Dec 2013; Mike Frysinger <vapier@gentoo.org> +libnfsidmap-0.25.ebuild,
+ files/libnfsidmap-0.19-getgrouplist.patch:
+ Version bump #489006 by michal.halenka.
21 May 2012; Kacper Kowalik <xarthisius@gentoo.org>
libnfsidmap-0.21-r1.ebuild, libnfsidmap-0.23-r1.ebuild,
diff --git a/net-libs/libnfsidmap/files/libnfsidmap-0.19-getgrouplist.patch b/net-libs/libnfsidmap/files/libnfsidmap-0.19-getgrouplist.patch
index c8cfeb9fd14b..15196fbfe404 100644
--- a/net-libs/libnfsidmap/files/libnfsidmap-0.19-getgrouplist.patch
+++ b/net-libs/libnfsidmap/files/libnfsidmap-0.19-getgrouplist.patch
@@ -24,7 +24,7 @@ http://bugs.gentoo.org/169909
*
--- libnfsidmap-0.19/getgrouplist.c
+++ libnfsidmap-0.19/getgrouplist.c
-@@ -0,0 +1,85 @@
+@@ -0,0 +1,86 @@
+/*
+ * getgrouplist.c
+ *
@@ -59,6 +59,7 @@ http://bugs.gentoo.org/169909
+ * SUCH DAMAGE.
+ */
+
++#include "config.h"
+#include <sys/types.h>
+#include <grp.h>
+#include <string.h>
diff --git a/net-libs/libnfsidmap/libnfsidmap-0.25.ebuild b/net-libs/libnfsidmap/libnfsidmap-0.25.ebuild
new file mode 100644
index 000000000000..869851bd4634
--- /dev/null
+++ b/net-libs/libnfsidmap/libnfsidmap-0.25.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfsidmap/libnfsidmap-0.25.ebuild,v 1.1 2013/12/17 00:23:08 vapier Exp $
+
+EAPI="4"
+
+inherit autotools eutils multilib
+
+DESCRIPTION="NFSv4 ID <-> name mapping library"
+HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux/"
+SRC_URI="http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ldap static-libs"
+
+DEPEND="ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ !<net-fs/nfs-utils-1.2.2
+ !net-fs/idmapd"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.19-getgrouplist.patch #169909
+ epatch "${FILESDIR}"/${PN}-0.21-headers.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable ldap)
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ doins idmapd.conf
+
+ # remove useless files
+ rm -f "${D}"/usr/$(get_libdir)/libnfsidmap/*.{a,la}
+ use static-libs || find "${D}"/usr -name '*.la' -delete
+}