summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-07-20 14:02:34 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-07-20 14:02:34 +0000
commit65943e709f2ea392a63c4940cd5f29799092b44a (patch)
tree0efd1654e5255e0f33e8edf43098c019d8df8a4a /net-libs
parentBug #268336 continued -> Use Maks Verver's clever sighandler solution to emul... (diff)
downloadgentoo-2-65943e709f2ea392a63c4940cd5f29799092b44a.tar.gz
gentoo-2-65943e709f2ea392a63c4940cd5f29799092b44a.tar.bz2
gentoo-2-65943e709f2ea392a63c4940cd5f29799092b44a.zip
fix compilation with glibc-2.10, bug 277735
(Portage version: 13823-svn/cvs/Linux i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/clinkcc/ChangeLog6
-rw-r--r--net-libs/clinkcc/clinkcc-1.7.1.ebuild3
-rw-r--r--net-libs/clinkcc/files/clinkcc-1.7.1-glibc-2.10.patch11
3 files changed, 18 insertions, 2 deletions
diff --git a/net-libs/clinkcc/ChangeLog b/net-libs/clinkcc/ChangeLog
index caa7a7af8451..3768c50fba43 100644
--- a/net-libs/clinkcc/ChangeLog
+++ b/net-libs/clinkcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/clinkcc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/clinkcc/ChangeLog,v 1.1 2009/06/18 18:57:17 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/clinkcc/ChangeLog,v 1.2 2009/07/20 14:02:34 volkmar Exp $
+
+ 20 Jul 2009; Mounir Lamouri <volkmar@gentoo.org>
+ +files/clinkcc-1.7.1-glibc-2.10.patch, clinkcc-1.7.1.ebuild:
+ Fix compilation with glibc-2.10. Fix bug 277735
*clinkcc-1.7.1 (18 Jun 2009)
diff --git a/net-libs/clinkcc/clinkcc-1.7.1.ebuild b/net-libs/clinkcc/clinkcc-1.7.1.ebuild
index 3d0493fbe2ee..6e40033cb652 100644
--- a/net-libs/clinkcc/clinkcc-1.7.1.ebuild
+++ b/net-libs/clinkcc/clinkcc-1.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/clinkcc/clinkcc-1.7.1.ebuild,v 1.1 2009/06/18 18:57:17 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/clinkcc/clinkcc-1.7.1.ebuild,v 1.2 2009/07/20 14:02:34 volkmar Exp $
EAPI="2"
@@ -36,6 +36,7 @@ src_prepare() {
sed -i -e "s:sample::" Makefile.am || die "sed failed"
epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch # bug 277735
eautoreconf # fix install-sh permission denied
}
diff --git a/net-libs/clinkcc/files/clinkcc-1.7.1-glibc-2.10.patch b/net-libs/clinkcc/files/clinkcc-1.7.1-glibc-2.10.patch
new file mode 100644
index 000000000000..b086e480e146
--- /dev/null
+++ b/net-libs/clinkcc/files/clinkcc-1.7.1-glibc-2.10.patch
@@ -0,0 +1,11 @@
+--- src/cybergarage/upnp/ssdp/SSDP.cpp.old 2009-07-20 15:52:39.000000000 +0000
++++ src/cybergarage/upnp/ssdp/SSDP.cpp 2009-07-20 15:53:52.000000000 +0000
+@@ -45,7 +45,7 @@
+
+ int CyberLink::SSDP::GetLeaseTime(const char *cacheCnt)
+ {
+- char *eqStrPos = strchr(cacheCnt, '=');
++ const char *eqStrPos = strchr(cacheCnt, '=');
+ if (eqStrPos == NULL)
+ return 0;
+ return atoi((eqStrPos + 1));