summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-02-06 03:03:27 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-02-06 03:03:27 +0000
commit7b0afbc5553dca30814f9178c68ae090dfb37bcc (patch)
tree4b33931001b3cab119405b47238b8007d7760534 /net-libs
parentAdd support for Python 3. (diff)
downloadgentoo-2-7b0afbc5553dca30814f9178c68ae090dfb37bcc.tar.gz
gentoo-2-7b0afbc5553dca30814f9178c68ae090dfb37bcc.tar.bz2
gentoo-2-7b0afbc5553dca30814f9178c68ae090dfb37bcc.zip
Version bump, sercurity fix, bug #455766
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/cyassl/ChangeLog8
-rw-r--r--net-libs/cyassl/cyassl-2.5.0.ebuild111
-rw-r--r--net-libs/cyassl/metadata.xml2
3 files changed, 120 insertions, 1 deletions
diff --git a/net-libs/cyassl/ChangeLog b/net-libs/cyassl/ChangeLog
index 555ef2f45f23..09cd3c2ba395 100644
--- a/net-libs/cyassl/ChangeLog
+++ b/net-libs/cyassl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/cyassl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/ChangeLog,v 1.26 2013/02/03 19:40:39 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/ChangeLog,v 1.27 2013/02/06 03:03:27 blueness Exp $
+
+*cyassl-2.5.0 (06 Feb 2013)
+
+ 06 Feb 2013; Anthony G. Basile <blueness@gentoo.org> +cyassl-2.5.0.ebuild,
+ metadata.xml:
+ Version bump, sercurity fix, bug #455766
03 Feb 2013; Agostino Sarubbo <ago@gentoo.org> cyassl-2.4.6.ebuild:
Stable for arm, wrt bug #448980
diff --git a/net-libs/cyassl/cyassl-2.5.0.ebuild b/net-libs/cyassl/cyassl-2.5.0.ebuild
new file mode 100644
index 000000000000..39961db46118
--- /dev/null
+++ b/net-libs/cyassl/cyassl-2.5.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/cyassl-2.5.0.ebuild,v 1.1 2013/02/06 03:03:27 blueness Exp $
+
+EAPI="4"
+
+WANT_AUTOMAKE=1.12
+
+inherit autotools eutils
+
+DESCRIPTION="Lightweight SSL/TLS library targeted at embedded and RTOS environments"
+HOMEPAGE="http://www.yassl.com/yaSSL/Home.html"
+SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+
+#Add CRYPTO_OPTS=ecc when fixed
+CACHE_SIZE="small big +huge"
+CRYPTO_OPTS="aes-gcm aes-ccm aes-ni camellia +hc128 md2 +psk +ripemd sha512"
+CERT_OPTS="ocsp crl crl-monitor +sessioncerts +testcert"
+IUSE="debug -dtls ipv6 +httpd +sniffer static-libs threads +zlib cyassl-hardening ${CACHE_SIZE} ${CRYPTO_OPTS} ${CERT_OPTS}"
+
+#You can only pick one cach size
+#sha512 is broken on x86
+#Testing freezes with dtls
+REQUIRED_USE="^^ ( small big huge )
+ test? ( !dtls )"
+
+DEPEND="app-arch/unzip
+ sniffer? ( net-libs/libpcap )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.8-disable-testsuit-ifnothreads.patch
+
+ #Bug #454300
+ epatch "${FILESDIR}"/${PN}-2.4.6-respect-CFLAGS.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+
+ if use threads; then
+ myconf+=( --disable-singleThreaded )
+ else
+ myconf+=( --enable-singleThreaded )
+ fi
+
+ if use amd64; then
+ myconf+=( --enable-fastmath --enable-fasthugemath --enable-bump )
+ elif use x86; then
+ #not pie friendly, sorry x86, no fast math for you :(
+ myconf+=( --disable-fastmath --disable-fasthugemath --disable-bump )
+ fi
+
+ #There are lots of options, so we'll force a few reasonable
+ #We may change this in the future, in particular ecc needs to be fixed
+ econf \
+ --enable-opensslExtra \
+ --enable-fortress \
+ --enable-keygen \
+ --enable-certgen \
+ --disable-debug \
+ --disable-ecc \
+ --disable-ntru \
+ --disable-noFilesystem \
+ --disable-noInline \
+ $(use_enable debug) \
+ $(use_enable small smallcache) \
+ $(use_enable big bigcache) \
+ $(use_enable huge hugecache) \
+ $(use_enable aes-gcm aesgcm) \
+ $(use_enable aes-ccm aesccm) \
+ $(use_enable aes-ni aesni) \
+ $(use_enable camellia) \
+ $(use_enable hc128) \
+ $(use_enable md2) \
+ $(use_enable psk) \
+ $(use_enable ripemd) \
+ $(use_enable sha512) \
+ $(use_enable dtls) \
+ $(use_enable ipv6) \
+ $(use_enable httpd webServer) \
+ $(use_enable ocsp) \
+ $(use_enable crl) \
+ $(use_enable crl-monitor) \
+ $(use_enable sessioncerts) \
+ $(use_enable sniffer) \
+ $(use_enable testcert) \
+ $(use_enable static-libs static) \
+ $(use_enable cyassl-hardening gcc-hardening) \
+ $(use_with zlib libz) \
+ "${myconf[@]}"
+}
+
+src_test() {
+ "${S}"/tests/unit
+ "${S}"/ctaocrypt/benchmark/benchmark
+}
+
+src_install() {
+ default
+
+ mv "${D}"/usr/share/doc/"${PN}"/* \
+ "${D}"/usr/share/doc/"${P}"/
+ rmdir "${D}"/usr/share/doc/"${PN}"/
+}
diff --git a/net-libs/cyassl/metadata.xml b/net-libs/cyassl/metadata.xml
index b51be1854f2f..935a6dbcfcc7 100644
--- a/net-libs/cyassl/metadata.xml
+++ b/net-libs/cyassl/metadata.xml
@@ -7,7 +7,9 @@
</maintainer>
<use>
<flag name="aes-gcm">Enable AES Galois/Counter mode</flag>
+ <flag name="aes-ccm">Eanble AES Counter with CBC-MAC mode </flag>
<flag name="aes-ni">Enable Intel AES instruction support</flag>
+ <flag name="camellia">Enable Camellia-CBC cipher support </flag>
<!-- add this when ecc is fixed
<flag name="ecc">Enable Elliptic Curve support</flag>
-->