summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-20 06:36:42 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-20 06:36:42 +0000
commit7cd1ba52ced291f1960abcfa908d661081e7f53b (patch)
treeca2a61d27cbb15cdc978beeed9c3d39639f776a2 /net-libs
parentVersion bump, fixes crashes and leaks. (diff)
downloadgentoo-2-7cd1ba52ced291f1960abcfa908d661081e7f53b.tar.gz
gentoo-2-7cd1ba52ced291f1960abcfa908d661081e7f53b.tar.bz2
gentoo-2-7cd1ba52ced291f1960abcfa908d661081e7f53b.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libsoup-gnome/ChangeLog8
-rw-r--r--net-libs/libsoup-gnome/libsoup-gnome-2.38.1.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/net-libs/libsoup-gnome/ChangeLog b/net-libs/libsoup-gnome/ChangeLog
index 45dcabc68515..92b78d7adc9a 100644
--- a/net-libs/libsoup-gnome/ChangeLog
+++ b/net-libs/libsoup-gnome/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libsoup-gnome
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/ChangeLog,v 1.70 2012/04/13 23:04:35 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/ChangeLog,v 1.71 2012/04/20 06:36:42 tetromino Exp $
+
+*libsoup-gnome-2.38.1 (20 Apr 2012)
+
+ 20 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +libsoup-gnome-2.38.1.ebuild:
+ Version bump.
*libsoup-gnome-2.38.0 (13 Apr 2012)
diff --git a/net-libs/libsoup-gnome/libsoup-gnome-2.38.1.ebuild b/net-libs/libsoup-gnome/libsoup-gnome-2.38.1.ebuild
new file mode 100644
index 000000000000..07c5b0219d49
--- /dev/null
+++ b/net-libs/libsoup-gnome/libsoup-gnome-2.38.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/libsoup-gnome-2.38.1.ebuild,v 1.1 2012/04/20 06:36:42 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+MY_PN=${PN/-gnome}
+MY_P=${MY_PN}-${PV}
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="GNOME plugin for libsoup"
+HOMEPAGE="http://live.gnome.org/LibSoup"
+SRC_URI="${SRC_URI//-gnome}"
+
+LICENSE="LGPL-2"
+SLOT="2.4"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-solaris"
+IUSE="debug doc +introspection"
+
+RDEPEND="~net-libs/libsoup-${PV}
+ || ( gnome-base/libgnome-keyring <gnome-base/gnome-keyring-2.29.4 )
+ dev-db/sqlite:3
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/gtk-doc-am-1.10
+ doc? ( >=dev-util/gtk-doc-1.10 )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-tls-check
+ $(use_enable introspection)
+ --with-libsoup-system
+ --with-gnome"
+ DOCS="AUTHORS NEWS README"
+}
+
+src_configure() {
+ # FIXME: we need addpredict to workaround bug #324779 until
+ # root cause (bug #249496) is solved
+ addpredict /usr/share/snmp/mibs/.index
+ gnome2_src_configure
+}
+
+src_prepare() {
+ # Use lib present on the system
+ epatch "${FILESDIR}"/${PN}-2.38.0-system-lib.patch
+ eautoreconf
+ gnome2_src_prepare
+}