summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2010-01-24 22:09:16 +0000
committerOlivier Crête <tester@gentoo.org>2010-01-24 22:09:16 +0000
commit89dcc4c13463a7b3200d82b551bf0c699b4cbae5 (patch)
tree570a4c3e71106068a7907baf85720fd523deae41 /net-libs
parentRe-create Manifest. (diff)
downloadgentoo-2-89dcc4c13463a7b3200d82b551bf0c699b4cbae5.tar.gz
gentoo-2-89dcc4c13463a7b3200d82b551bf0c699b4cbae5.tar.bz2
gentoo-2-89dcc4c13463a7b3200d82b551bf0c699b4cbae5.zip
Version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/farsight2/ChangeLog7
-rw-r--r--net-libs/farsight2/farsight2-0.0.17.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/net-libs/farsight2/ChangeLog b/net-libs/farsight2/ChangeLog
index 4b1a68e4dcd5..4eddc1802ed8 100644
--- a/net-libs/farsight2/ChangeLog
+++ b/net-libs/farsight2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/farsight2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/ChangeLog,v 1.24 2010/01/18 21:43:07 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/ChangeLog,v 1.25 2010/01/24 22:09:16 tester Exp $
+
+*farsight2-0.0.17 (24 Jan 2010)
+
+ 24 Jan 2010; Olivier Crête <tester@gentoo.org> +farsight2-0.0.17.ebuild:
+ Version bump
18 Jan 2010; Jeroen Roovers <jer@gentoo.org> farsight2-0.0.15.ebuild,
farsight2-0.0.16.ebuild:
diff --git a/net-libs/farsight2/farsight2-0.0.17.ebuild b/net-libs/farsight2/farsight2-0.0.17.ebuild
new file mode 100644
index 000000000000..625dbb5abb92
--- /dev/null
+++ b/net-libs/farsight2/farsight2-0.0.17.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farsight2/farsight2-0.0.17.ebuild,v 1.1 2010/01/24 22:09:16 tester Exp $
+
+EAPI="2"
+
+DESCRIPTION="Farsight2 is an audio/video conferencing framework specifically designed for Instant Messengers."
+HOMEPAGE="http://farsight.freedesktop.org/"
+SRC_URI="http://farsight.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="python test msn upnp"
+SLOT="0"
+
+COMMONDEPEND=">=media-libs/gstreamer-0.10.23
+ >=media-libs/gst-plugins-base-0.10.23
+ >=dev-libs/glib-2.16
+ >=net-libs/libnice-0.0.9[gstreamer]
+ python? (
+ || ( >=dev-python/pygobject-2.16 >=dev-python/pygtk-2.12 )
+ >=dev-python/pygobject-2.12
+ >=dev-python/gst-python-0.10.10 )
+ upnp? ( net-libs/gupnp-igd )"
+
+RDEPEND="${COMMONDEPEND}
+ >=media-libs/gst-plugins-good-0.10.11
+ >=media-libs/gst-plugins-bad-0.10.13
+ || ( >=media-libs/gst-plugins-good-0.10.16
+ <media-libs/gst-plugins-bad-0.10.14 )
+ msn? ( >=media-plugins/gst-plugins-mimic-0.10.14 )"
+
+DEPEND="${COMMONDEPEND}
+ test? ( media-plugins/gst-plugins-vorbis
+ media-plugins/gst-plugins-speex )
+ dev-util/pkgconfig"
+
+src_configure() {
+ plugins="fsrtpconference,funnel,rtcpfilter,videoanyrate"
+ use msn && plugins="${plugins},fsmsnconference"
+ econf $(use_enable python) \
+ $(use_enable upnp gupnp) \
+ --with-plugins=${plugins}
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS README ChangeLog
+}
+
+src_test()
+{
+ use msn || { einfo "Tests disabled without msn use flag"; return ;}
+ if ! emake -j1 check; then
+ hasq test $FEATURES && die "Make check failed. See above for details."
+ hasq test $FEATURES || eerror "Make check failed. See above for details."
+ fi
+}