summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Noël Rivasseau <elvanor@gentoo.org>2013-05-04 20:53:40 +0000
committerJean-Noël Rivasseau <elvanor@gentoo.org>2013-05-04 20:53:40 +0000
commit988ffecc508dc2b1aca30956359cacab42054826 (patch)
tree5ddf00235c12e7938366ebce36b4262680e9c890 /net-libs
parentVersion bump, refactor ebuild and 9999 a little for better distutils-r1 suppo... (diff)
downloadgentoo-2-988ffecc508dc2b1aca30956359cacab42054826.tar.gz
gentoo-2-988ffecc508dc2b1aca30956359cacab42054826.tar.bz2
gentoo-2-988ffecc508dc2b1aca30956359cacab42054826.zip
Version bump to 2.1.
(Portage version: 2.1.11.62/cvs/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/pjsip/ChangeLog7
-rw-r--r--net-libs/pjsip/pjsip-2.1.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/net-libs/pjsip/ChangeLog b/net-libs/pjsip/ChangeLog
index 79cc965e94cb..6369e36ba031 100644
--- a/net-libs/pjsip/ChangeLog
+++ b/net-libs/pjsip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/pjsip
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/pjsip/ChangeLog,v 1.10 2013/01/13 11:23:36 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/pjsip/ChangeLog,v 1.11 2013/05/04 20:53:40 elvanor Exp $
+
+*pjsip-2.1 (04 May 2013)
+
+ 04 May 2013; <elvanor@gentoo.org> +pjsip-2.1.ebuild:
+ Version bump to 2.1.
13 Jan 2013; Agostino Sarubbo <ago@gentoo.org> pjsip-1.14.ebuild:
Stable for x86, wrt bug #448278
diff --git a/net-libs/pjsip/pjsip-2.1.ebuild b/net-libs/pjsip/pjsip-2.1.ebuild
new file mode 100644
index 000000000000..564da593ef3f
--- /dev/null
+++ b/net-libs/pjsip/pjsip-2.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/pjsip/pjsip-2.1.ebuild,v 1.1 2013/05/04 20:53:40 elvanor Exp $
+
+EAPI="2"
+
+DESCRIPTION="Multimedia communication libraries written in C language
+for building VoIP applications."
+HOMEPAGE="http://www.pjsip.org/"
+SRC_URI="http://www.pjsip.org/release/${PV}/pjproject-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa cli doc examples ext-sound g711 g722 g7221 gsm ilbc l16
+oss python speex"
+#small-filter large-filter speex-aec ssl
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ gsm? ( media-sound/gsm )
+ ilbc? ( dev-libs/ilbc-rfc3951 )
+ speex? ( media-libs/speex )"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/pjproject-${PV}.0"
+
+src_configure() {
+ # Disable through portage available codecs
+ econf --disable-gsm-codec \
+ --disable-speex-codec \
+ --disable-ilbc-codec \
+ --disable-speex-aec \
+ $(use_enable alsa sound) \
+ $(use_enable oss) \
+ $(use_enable ext-sound) \
+ $(use_enable g711 g711-codec) \
+ $(use_enable l16 l16-codec) \
+ $(use_enable g722 g722-codec) \
+ $(use_enable g7221 g7221-codec) || die "econf failed."
+ #$(use_enable small-filter) \
+ #$(use_enable large-filter) \
+ #$(use_enable speex-aec) \
+ #$(use_enable ssl tls) #broken? sflphone doesn't compile if enabled or disabled
+}
+
+src_compile() {
+ emake dep || die "emake dep failed."
+ emake -j1 || die "emake failed."
+}
+
+src_install() {
+ DESTDIR="${D}" emake install || die "emake install failed."
+
+ if use cli; then
+ newbin pjsip-apps/bin/pjsua* pjsua
+ fi
+
+ if use python; then
+ pushd pjsip-apps/src/python
+ python setup.py install --prefix="${D}/usr/"
+ popd
+ fi
+
+ if use doc; then
+ dodoc README.txt README-RTEMS
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${P}/examples"
+ doins "${S}/pjsip-apps/src/samples/"*
+ fi
+}