summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-05-07 11:08:44 +0000
committerJohannes Huber <johu@gentoo.org>2012-05-07 11:08:44 +0000
commitb0fb8c19e597c4d1955ebf625ae089c7a7951efa (patch)
tree0903a5e87d9d11fa016629318993ea2bb913e1ae /net-libs
parentBump to EAPI=4. Migrate to qt4-r2.eclass. Respect LINGUAS. Patch by kensingto... (diff)
downloadgentoo-2-b0fb8c19e597c4d1955ebf625ae089c7a7951efa.tar.gz
gentoo-2-b0fb8c19e597c4d1955ebf625ae089c7a7951efa.tar.bz2
gentoo-2-b0fb8c19e597c4d1955ebf625ae089c7a7951efa.zip
Version bump. Adds patch to build with gcc47 spotted by David Kredba <nheghathivhistha@gmail.com> wrt bug #414153.
(Portage version: 2.2.0_alpha101/cvs/Linux i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libmsn/ChangeLog9
-rw-r--r--net-libs/libmsn/files/libmsn-4.2.1-gcc47.patch11
-rw-r--r--net-libs/libmsn/libmsn-4.2.1.ebuild25
3 files changed, 44 insertions, 1 deletions
diff --git a/net-libs/libmsn/ChangeLog b/net-libs/libmsn/ChangeLog
index a8c6765ee8ee..0a4c8dcbebfe 100644
--- a/net-libs/libmsn/ChangeLog
+++ b/net-libs/libmsn/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libmsn
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libmsn/ChangeLog,v 1.32 2012/01/31 21:00:13 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmsn/ChangeLog,v 1.33 2012/05/07 11:08:44 johu Exp $
+
+*libmsn-4.2.1 (07 May 2012)
+
+ 07 May 2012; Johannes Huber <johu@gentoo.org> +files/libmsn-4.2.1-gcc47.patch,
+ +libmsn-4.2.1.ebuild:
+ Version bump. Adds patch to build with gcc47 spotted by David Kredba
+ <nheghathivhistha@gmail.com> wrt bug #414153.
31 Jan 2012; Johannes Huber <johu@gentoo.org>
-files/libmsn-4.1-openssl-1.patch, -libmsn-4.1.ebuild:
diff --git a/net-libs/libmsn/files/libmsn-4.2.1-gcc47.patch b/net-libs/libmsn/files/libmsn-4.2.1-gcc47.patch
new file mode 100644
index 000000000000..aa6e9b08c875
--- /dev/null
+++ b/net-libs/libmsn/files/libmsn-4.2.1-gcc47.patch
@@ -0,0 +1,11 @@
+diff -ruN libmsn-4.2.1.orig//msn/util.cpp libmsn-4.2.1//msn/util.cpp
+--- libmsn-4.2.1.orig//msn/util.cpp 2009-07-22 21:57:10.000000000 +0200
++++ libmsn-4.2.1//msn/util.cpp 2012-05-07 12:45:47.581493381 +0200
+@@ -30,6 +30,7 @@
+ #include <openssl/rand.h>
+ #include <cstring>
+ #include <sys/timeb.h>
++#include <unistd.h>
+ #include "md5.h"
+ #include "libsiren/siren7.h"
+
diff --git a/net-libs/libmsn/libmsn-4.2.1.ebuild b/net-libs/libmsn/libmsn-4.2.1.ebuild
new file mode 100644
index 000000000000..7d4e7df8d311
--- /dev/null
+++ b/net-libs/libmsn/libmsn-4.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmsn/libmsn-4.2.1.ebuild,v 1.1 2012/05/07 11:08:44 johu Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Library for connecting to Microsoft's MSN Messenger service."
+HOMEPAGE="http://sourceforge.net/projects/libmsn/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/openssl
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(README THANKS TODO)
+
+PATCHES=( "${FILESDIR}/${P}-gcc47.patch" )