summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-19 20:37:04 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-19 20:37:04 +0000
commitc61a7718940431aae620ace1f2ebbf5be2c22efd (patch)
treee102eef498499a9c5cfa24a23ac532c4424adb8c /net-libs
parentmasked libwww (diff)
downloadgentoo-2-c61a7718940431aae620ace1f2ebbf5be2c22efd.tar.gz
gentoo-2-c61a7718940431aae620ace1f2ebbf5be2c22efd.tar.bz2
gentoo-2-c61a7718940431aae620ace1f2ebbf5be2c22efd.zip
version bump
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libwww/ChangeLog9
-rw-r--r--net-libs/libwww/files/digest-libwww-5.4.01
-rw-r--r--net-libs/libwww/libwww-5.3.2-r1.ebuild51
-rw-r--r--net-libs/libwww/libwww-5.4.0.ebuild50
4 files changed, 81 insertions, 30 deletions
diff --git a/net-libs/libwww/ChangeLog b/net-libs/libwww/ChangeLog
index b3ebf0ad06f5..0f61445e2517 100644
--- a/net-libs/libwww/ChangeLog
+++ b/net-libs/libwww/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libwww
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/ChangeLog,v 1.1 2002/02/01 21:53:34 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/ChangeLog,v 1.2 2002/06/19 20:37:04 seemant Exp $
+
+*libwww-5.4.0 (19 Jun 2002)
+
+ 19 Jun 2002; Seemant Kulleen <seemant@gentoo.org> libwww-5.4.0.ebuild
+ files/digest-libwww-5.4.0 :
+
+ Version bump.
*libwww-5.3.2-r1 (1 Feb 2002)
diff --git a/net-libs/libwww/files/digest-libwww-5.4.0 b/net-libs/libwww/files/digest-libwww-5.4.0
new file mode 100644
index 000000000000..f875bc95b421
--- /dev/null
+++ b/net-libs/libwww/files/digest-libwww-5.4.0
@@ -0,0 +1 @@
+MD5 c3734ca6caa405707e134cc8c6d7e422 w3c-libwww-5.4.0.tgz 1129121
diff --git a/net-libs/libwww/libwww-5.3.2-r1.ebuild b/net-libs/libwww/libwww-5.3.2-r1.ebuild
index f7e23fb52042..a7c945830647 100644
--- a/net-libs/libwww/libwww-5.3.2-r1.ebuild
+++ b/net-libs/libwww/libwww-5.3.2-r1.ebuild
@@ -1,49 +1,42 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/libwww-5.3.2-r1.ebuild,v 1.2 2001/05/30 18:24:34 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/libwww-5.3.2-r1.ebuild,v 1.3 2002/06/19 20:37:04 seemant Exp $
-A=w3c-${P}.tar.gz
-S=${WORKDIR}/w3c-${P}
+MY_P=w3c-${P}
+S=${WORKDIR}/${MY_P}
DESCRIPTION="A general-purpose client side WEB API"
-SRC_URI="http://www.w3.org/Library/Distribution/${A}"
+SRC_URI="http://www.w3.org/Library/Distribution/${MY_P}.tar.gz"
HOMEPAGE="http://www.w3.org/Library/"
-DEPEND="virtual/glibc sys-devel/perl
- >=sys-libs/zlib-1.1.3
- mysql? ( >=dev-db/mysql-3.23.26 )
- ssl? ( >=dev-libs/openssl-0.9.6 )"
+SLOT=""
-RDEPEND="virtual/glibc
- >=sys-libs/zlib-1.1.3
- ssl? ( >=dev-libs/openssl-0.9.6 )"
+DEPEND="sys-devel/perl
+ >=sys-libs/zlib-1.1.4
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
src_compile() {
- local myconf
+ local myconf
- if [ "`use mysql`" ]
- then
- myconf="--with-mysql"
- fi
+ use mysql && myconf="--with-mysql"
+
+ use ssl && myconf="${myconf} --with-ssl"
- if [ "`use ssl`" ]
- then
- myconf="${myconf} --with-ssl"
- fi
+ ./configure \
+ --with-zlib \
+ --with-md5 \
+ --with-expat \
+ ${myconf} || die
- try ./configure --prefix=/usr --host=${CHOST} --with-zlib \
- --with-md5 --with-expat ${myconf}
- try make
+ emake || die
}
src_install () {
- try make prefix=${D}/usr install
- dodoc COPYRIGH ChangeLog
- docinto html
- dodoc *.html
+ make prefix=${D}/usr install || die
+ dodoc COPYRIGH ChangeLog
+ dohtml -r .
}
-
diff --git a/net-libs/libwww/libwww-5.4.0.ebuild b/net-libs/libwww/libwww-5.4.0.ebuild
new file mode 100644
index 000000000000..18801902c02f
--- /dev/null
+++ b/net-libs/libwww/libwww-5.4.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/libwww-5.4.0.ebuild,v 1.1 2002/06/19 20:37:04 seemant Exp $
+
+inherit libtool
+
+MY_P=w3c-${P}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A general-purpose client side WEB API"
+SRC_URI="http://www.w3.org/Library/Distribution/${MY_P}.tgz"
+HOMEPAGE="http://www.w3.org/Library/"
+
+SLOT=""
+
+DEPEND="sys-devel/perl
+ >=sys-libs/zlib-1.1.4
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+
+ local myconf
+
+ use mysql \
+ && myconf="--with-mysql" \
+ || myconf="--without-mysql"
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ elibtoolize
+
+ ./configure \
+ --with-zlib \
+ --with-md5 \
+ --with-expat \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr install || die
+ dodoc COPYRIGH ChangeLog
+ dohtml -r .
+
+}