summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-22 22:33:00 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-22 22:33:00 +0000
commitca06a34ceb8fa7be51afc81914e0ea0e4ae18eff (patch)
tree35252c5c8b2692614f7477e639b415d0e34c6e97 /net-libs
parentVersion bump. Add ecap USE flag (#277885). (diff)
downloadgentoo-2-ca06a34ceb8fa7be51afc81914e0ea0e4ae18eff.tar.gz
gentoo-2-ca06a34ceb8fa7be51afc81914e0ea0e4ae18eff.tar.bz2
gentoo-2-ca06a34ceb8fa7be51afc81914e0ea0e4ae18eff.zip
Version bump. I18n, depth color and full screen updates support. Clean up old revisions.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gtk-vnc/ChangeLog9
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.3.10.ebuild38
2 files changed, 46 insertions, 1 deletions
diff --git a/net-libs/gtk-vnc/ChangeLog b/net-libs/gtk-vnc/ChangeLog
index ef18019afecb..12b7cb707498 100644
--- a/net-libs/gtk-vnc/ChangeLog
+++ b/net-libs/gtk-vnc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/gtk-vnc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.36 2009/10/05 16:38:02 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.37 2009/10/22 22:33:00 eva Exp $
+
+*gtk-vnc-0.3.10 (22 Oct 2009)
+
+ 22 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +gtk-vnc-0.3.10.ebuild:
+ Version bump. I18n, depth color and full screen updates support. Clean up
+ old revisions.
05 Oct 2009; Raúl Porcel <armin76@gentoo.org> gtk-vnc-0.3.8-r1.ebuild:
ia64/sparc stable wrt #279511
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.3.10.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.3.10.ebuild
new file mode 100644
index 000000000000..be77385a6b6b
--- /dev/null
+++ b/net-libs/gtk-vnc/gtk-vnc-0.3.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.3.10.ebuild,v 1.1 2009/10/22 22:33:00 eva Exp $
+
+EAPI="2"
+
+inherit base gnome.org
+
+DESCRIPTION="VNC viewer widget for GTK."
+HOMEPAGE="http://live.gnome.org/gtk-vnc"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples python sasl"
+
+# libview is used in examples/gvncviewer -- no need
+# TODO: review nsplugin when it will be considered less experimental
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=net-libs/gnutls-1.4
+ x11-libs/cairo
+ python? ( >=dev-python/pygtk-2 )
+ sasl? ( dev-libs/cyrus-sasl )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-util/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.35"
+
+src_configure() {
+ econf \
+ $(use_with examples) \
+ $(use_with python) \
+ $(use_with sasl) \
+ --with-coroutine=gthread \
+ --without-libview
+}