summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-06-01 12:33:14 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-06-01 12:33:14 +0000
commite7e1afa636f3989f76ea176d718934cd5ba3c42a (patch)
tree2ebca8d2deb4046bc9bd55716329aeb120fe1cc4 /net-libs
parentAdded ~ppc wrt bug 179645 (diff)
downloadgentoo-2-e7e1afa636f3989f76ea176d718934cd5ba3c42a.tar.gz
gentoo-2-e7e1afa636f3989f76ea176d718934cd5ba3c42a.tar.bz2
gentoo-2-e7e1afa636f3989f76ea176d718934cd5ba3c42a.zip
Version bump wrt security #180436, thanks to Gergan Penkov <gpp666_999 at yahoo dot de> for the patchset
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/xulrunner/ChangeLog8
-rw-r--r--net-libs/xulrunner/files/digest-xulrunner-1.8.1.46
-rw-r--r--net-libs/xulrunner/xulrunner-1.8.1.4.ebuild154
3 files changed, 167 insertions, 1 deletions
diff --git a/net-libs/xulrunner/ChangeLog b/net-libs/xulrunner/ChangeLog
index d6d4e9da947a..d5d0f668da45 100644
--- a/net-libs/xulrunner/ChangeLog
+++ b/net-libs/xulrunner/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/xulrunner
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/ChangeLog,v 1.26 2007/05/23 15:06:39 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/ChangeLog,v 1.27 2007/06/01 12:33:14 armin76 Exp $
+
+*xulrunner-1.8.1.4 (01 Jun 2007)
+
+ 01 Jun 2007; Raúl Porcel <armin76@gentoo.org> +xulrunner-1.8.1.4.ebuild:
+ Version bump wrt security #180436, thanks to Gergan Penkov <gpp666_999 at
+ yahoo dot de> for the patchset
23 May 2007; Gustavo Zacarias <gustavoz@gentoo.org>
xulrunner-1.8.1.3.ebuild:
diff --git a/net-libs/xulrunner/files/digest-xulrunner-1.8.1.4 b/net-libs/xulrunner/files/digest-xulrunner-1.8.1.4
new file mode 100644
index 000000000000..6dd8859f8f1d
--- /dev/null
+++ b/net-libs/xulrunner/files/digest-xulrunner-1.8.1.4
@@ -0,0 +1,6 @@
+MD5 6e0eeada69004f30c7f6e6ad133ccb2f xulrunner-1.8.1.4-patches-0.1.tar.bz2 61728
+RMD160 abeeef43afb3de3652382f514f918e85f92d2b83 xulrunner-1.8.1.4-patches-0.1.tar.bz2 61728
+SHA256 8dd2389654b2640d5ddc3298fde8e1f74cde07b6fcd0aa6a3480f2c81e611145 xulrunner-1.8.1.4-patches-0.1.tar.bz2 61728
+MD5 f9422104ef62a02afb78becca010d9f1 xulrunner-1.8.1.4-source.tar.bz2 35471439
+RMD160 a5bb693b706c12c73cc77532acdf7389f3197e2f xulrunner-1.8.1.4-source.tar.bz2 35471439
+SHA256 099089124364b57481667c11f2b8807766b4b4ef3819033db47b5f654745f6bd xulrunner-1.8.1.4-source.tar.bz2 35471439
diff --git a/net-libs/xulrunner/xulrunner-1.8.1.4.ebuild b/net-libs/xulrunner/xulrunner-1.8.1.4.ebuild
new file mode 100644
index 000000000000..e8ee0cda7a26
--- /dev/null
+++ b/net-libs/xulrunner/xulrunner-1.8.1.4.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/xulrunner-1.8.1.4.ebuild,v 1.1 2007/06/01 12:33:14 armin76 Exp $
+
+WANT_AUTOCONF="2.1"
+
+inherit flag-o-matic toolchain-funcs eutils makeedit multilib autotools mozconfig-2 java-pkg-opt-2
+PATCH="${P}-patches-0.1"
+
+DESCRIPTION="Mozilla runtime package that can be used to bootstrap XUL+XPCOM applications"
+HOMEPAGE="http://developer.mozilla.org/en/docs/XULRunner"
+SRC_URI="http://www.archlinux.org/~jgc/mozilla/${P}-source.tar.bz2
+ mirror://gentoo/${PATCH}.tar.bz2"
+
+SLOT="0"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=sys-devel/binutils-2.16.1
+ >=dev-libs/nss-3.11.5
+ >=dev-libs/nspr-4.6.5-r1
+ java? ( >=virtual/jre-1.4 )"
+
+
+DEPEND="java? ( >=virtual/jdk-1.4 )
+ ${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/mozilla"
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export MOZ_CO_PROJECT=xulrunner
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+
+src_unpack() {
+ unpack ${P}-source.tar.bz2 ${PATCH}.tar.bz2
+
+ # Apply our patches
+ cd "${S}" || die "cd failed"
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}"/patch
+
+ eautoreconf || die "failed running eautoreconf"
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+ mozconfig_config
+
+ mozconfig_annotate '' --enable-extensions="default,cookie,permissions,spellcheck"
+ mozconfig_annotate '' --enable-native-uconv
+ mozconfig_annotate '' --enable-image-encoder=all
+ mozconfig_annotate '' --enable-canvas
+ #mozconfig_annotate '' --enable-js-binary
+ mozconfig_annotate '' --enable-embedding-tests
+ mozconfig_annotate '' --with-system-nspr
+ mozconfig_annotate '' --with-system-nss
+ mozconfig_annotate '' --with-system-bz2
+ mozconfig_annotate '' --enable-jsd
+ mozconfig_annotate '' --enable-xpctools
+ # Bug 60668: Galeon doesn't build without oji enabled, so enable it
+ # regardless of java setting.
+ mozconfig_annotate '' --enable-oji --enable-mathml
+ mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
+
+ #disable java
+ if ! use java ; then
+ mozconfig_annotate '-java' --disable-javaxpcom
+ fi
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # -fstack-protector breaks us
+ if gcc-version ge 4 1; then
+ gcc-specs-ssp && append-flags -fno-stack-protector
+ else
+ gcc-specs-ssp && append-flags -fno-stack-protector-all
+ fi
+ filter-flags -fstack-protector -fstack-protector-all
+
+ ####################################
+ #
+ # Configure and build
+ #
+ ####################################
+
+ CPPFLAGS="${CPPFLAGS} -DARON_WAS_HERE" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
+ econf || die
+
+ # It would be great if we could pass these in via CPPFLAGS or CFLAGS prior
+ # to econf, but the quotes cause configure to fail.
+ sed -i -e \
+ 's|-DARON_WAS_HERE|-DGENTOO_NSPLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsplugins\\\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsbrowser/plugins\\\"|' \
+ ${S}/config/autoconf.mk \
+ ${S}/xpfe/global/buildconfig.html
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+ emake DESTDIR="${D}" install || die "emake install failed"
+ X_DATE=`date +%Y%m%d`
+
+ # Add Gentoo package version to preferences - copied from debian rules
+ echo // Gentoo package version \
+ > ${D}/usr/$(get_libdir)/xulrunner/defaults/pref/vendor.js
+ echo "pref(\"general.useragent.product\",\"Gecko\");" \
+ >> ${D}/usr/$(get_libdir)/xulrunner/defaults/pref/vendor.js
+ echo "pref(\"general.useragent.productSub\",\"${X_DATE}\");" \
+ >> ${D}/usr/$(get_libdir)/xulrunner/defaults/pref/vendor.js
+ echo "pref(\"general.useragent.productComment\",\"Gentoo\");" \
+ >> ${D}/usr/$(get_libdir)/xulrunner/defaults/pref/vendor.js
+
+ if use java ; then
+ java-pkg_dojar ${D}${MOZILLA_FIVE_HOME}/javaxpcom.jar
+ rm -f ${D}${MOZILLA_FIVE_HOME}/javaxpcom.jar
+ fi
+
+ # xulrunner registration, the gentoo way
+ insinto /etc/gre.d
+ newins ${FILESDIR}/${PN}.conf ${PV}.conf
+ sed -i -e \
+ "s|version|${PV}|
+ s|instpath|${MOZILLA_FIVE_HOME}|" \
+ ${D}/etc/gre.d/${PV}.conf
+}
+
+pkg_postinst() {
+ elog "Please remember to rebuild any packages that you have built"
+ elog "against xulrunner. Some packages might be broken by the upgrade; if this"
+ elog "is the case, please search at http://bugs.gentoo.org and open a new bug"
+ elog "if one does not exist."
+}