summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-04-04 17:02:02 +0000
committerMichael Palimaka <kensington@gentoo.org>2015-04-04 17:02:02 +0000
commitf3affa098eeee488416aee2c73825d1bf9216980 (patch)
tree8d31bceba33f07837351ea6749e0407794fc2c05 /net-libs
parentRemove old. (diff)
downloadgentoo-2-f3affa098eeee488416aee2c73825d1bf9216980.tar.gz
gentoo-2-f3affa098eeee488416aee2c73825d1bf9216980.tar.bz2
gentoo-2-f3affa098eeee488416aee2c73825d1bf9216980.zip
Migrate to EAPI 5.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libgcal/ChangeLog11
-rw-r--r--net-libs/libgcal/libgcal-0.9.6-r1.ebuild (renamed from net-libs/libgcal/libgcal-0.9.6.ebuild)12
2 files changed, 14 insertions, 9 deletions
diff --git a/net-libs/libgcal/ChangeLog b/net-libs/libgcal/ChangeLog
index d728ed0e9c71..504d2ebfe02a 100644
--- a/net-libs/libgcal/ChangeLog
+++ b/net-libs/libgcal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libgcal
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libgcal/ChangeLog,v 1.1 2011/01/12 14:47:59 tampakrap Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgcal/ChangeLog,v 1.2 2015/04/04 17:02:02 kensington Exp $
+
+*libgcal-0.9.6-r1 (04 Apr 2015)
+
+ 04 Apr 2015; Michael Palimaka <kensington@gentoo.org>
+ +libgcal-0.9.6-r1.ebuild, -libgcal-0.9.6.ebuild:
+ Migrate to EAPI 5.
*libgcal-0.9.6 (12 Jan 2011)
@@ -8,4 +14,3 @@
+metadata.xml:
Initial commit, ebuild by James Freedman, Mieszko Ślusarczyk, Thilo Bangert
and P Purkayastha, bug 246121
-
diff --git a/net-libs/libgcal/libgcal-0.9.6.ebuild b/net-libs/libgcal/libgcal-0.9.6-r1.ebuild
index 235eefaa95fe..f06b421bf9fa 100644
--- a/net-libs/libgcal/libgcal-0.9.6.ebuild
+++ b/net-libs/libgcal/libgcal-0.9.6-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libgcal/libgcal-0.9.6.ebuild,v 1.1 2011/01/12 14:47:59 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgcal/libgcal-0.9.6-r1.ebuild,v 1.1 2015/04/04 17:02:02 kensington Exp $
-EAPI="3"
+EAPI=5
inherit cmake-utils
@@ -11,8 +11,8 @@ HOMEPAGE="http://code.google.com/p/libgcal/"
SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="debug doc test"
# Some tests fail
@@ -27,7 +27,7 @@ DEPEND="${RDEPEND}
test? ( dev-libs/check )
"
-DOCS=(README)
+DOCS=( README )
src_configure() {
mycmakeargs=(
@@ -43,7 +43,7 @@ src_compile() {
}
src_install() {
- use doc && HTML_DOCS=("${CMAKE_BUILD_DIR}/docs/doxygen/html/")
+ use doc && HTML_DOCS=( "${BUILD_DIR}/docs/doxygen/html/" )
cmake-utils_src_install
}