summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-08-26 11:05:06 +0000
committerTim Harder <radhermit@gentoo.org>2011-08-26 11:05:06 +0000
commit2e4d75e858028642c2cac128543643ce398066b9 (patch)
treedc108df971d6d99c5fb2c17f56ed5b13df777261 /net-mail/altermime
parentAdd a udev rules file that allows persistent naming of APC UPS devices. (diff)
downloadgentoo-2-2e4d75e858028642c2cac128543643ce398066b9.tar.gz
gentoo-2-2e4d75e858028642c2cac128543643ce398066b9.tar.bz2
gentoo-2-2e4d75e858028642c2cac128543643ce398066b9.zip
Version bump.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/altermime')
-rw-r--r--net-mail/altermime/ChangeLog8
-rw-r--r--net-mail/altermime/altermime-0.3.11.ebuild29
-rw-r--r--net-mail/altermime/files/altermime-0.3.11-respect-flags.patch20
3 files changed, 56 insertions, 1 deletions
diff --git a/net-mail/altermime/ChangeLog b/net-mail/altermime/ChangeLog
index 4b545d0aeadf..2958034d684c 100644
--- a/net-mail/altermime/ChangeLog
+++ b/net-mail/altermime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/altermime
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/altermime/ChangeLog,v 1.21 2011/08/12 21:33:57 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/altermime/ChangeLog,v 1.22 2011/08/26 11:05:06 radhermit Exp $
+
+*altermime-0.3.11 (26 Aug 2011)
+
+ 26 Aug 2011; Tim Harder <radhermit@gentoo.org> +altermime-0.3.11.ebuild,
+ +files/altermime-0.3.11-respect-flags.patch:
+ Version bump.
12 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
altermime-0.3.10-r1.ebuild:
diff --git a/net-mail/altermime/altermime-0.3.11.ebuild b/net-mail/altermime/altermime-0.3.11.ebuild
new file mode 100644
index 000000000000..dba7e18e7c2b
--- /dev/null
+++ b/net-mail/altermime/altermime-0.3.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/altermime/altermime-0.3.11.ebuild,v 1.1 2011/08/26 11:05:06 radhermit Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION=" alterMIME is a small program which is used to alter your mime-encoded mailpacks"
+SRC_URI="http://www.pldaniels.com/altermime/${P}.tar.gz"
+HOMEPAGE="http://pldaniels.com/altermime/"
+
+LICENSE="Sendmail"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.3.10-MIME_headers-overflow.patch \
+ "${FILESDIR}"/${P}-respect-flags.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ dobin altermime
+ dodoc CHANGELOG README
+}
diff --git a/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch b/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch
new file mode 100644
index 000000000000..9f114ca17491
--- /dev/null
+++ b/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch
@@ -0,0 +1,20 @@
+--- altermime-0.3.11.orig/Makefile
++++ altermime-0.3.11/Makefile
+@@ -9,7 +9,7 @@
+ # opposite of a disclaimer.
+ ALTERMIME_OPTIONS=-DALTERMIME_PRETEXT
+ #ALTERMIME_OPTIONS=
+-CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)
++CFLAGS+=-Wall $(ALTERMIME_OPTIONS)
+ OBJS= strstack.o mime_alter.o ffget.o pldstr.o filename-filters.o logger.o MIME_headers.o libmime-decoders.o boundary-stack.o qpe.o
+
+
+@@ -19,7 +19,7 @@
+ all: altermime
+
+ altermime: altermime.c ${OBJS}
+- ${CC} ${CFLAGS} altermime.c ${OBJS} -o altermime
++ ${CC} ${CFLAGS} ${LDFLAGS} altermime.c ${OBJS} -o altermime
+
+
+ # Build Install