summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-11-02 19:02:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-11-02 19:02:35 +0000
commitaaefc90dfc62d6d4e871e0c918845f0d8f30403b (patch)
tree95e2882d47ca5dac0fe68d0d8eac3614d10ea311 /net-mail/altermime
parentRemove voxus from metadata.xml (diff)
downloadgentoo-2-aaefc90dfc62d6d4e871e0c918845f0d8f30403b.tar.gz
gentoo-2-aaefc90dfc62d6d4e871e0c918845f0d8f30403b.tar.bz2
gentoo-2-aaefc90dfc62d6d4e871e0c918845f0d8f30403b.zip
Fixes for #241038, thanks to Kerin Millar
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/altermime')
-rw-r--r--net-mail/altermime/ChangeLog8
-rw-r--r--net-mail/altermime/altermime-0.3.10-r1.ebuild30
-rw-r--r--net-mail/altermime/files/altermime-0.3.10-respect-flags.patch12
3 files changed, 49 insertions, 1 deletions
diff --git a/net-mail/altermime/ChangeLog b/net-mail/altermime/ChangeLog
index c7cec17da79f..9a30943ef37b 100644
--- a/net-mail/altermime/ChangeLog
+++ b/net-mail/altermime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/altermime
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/altermime/ChangeLog,v 1.17 2010/06/06 01:21:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/altermime/ChangeLog,v 1.18 2010/11/02 19:02:35 patrick Exp $
+
+*altermime-0.3.10-r1 (02 Nov 2010)
+
+ 02 Nov 2010; Patrick Lauer <patrick@gentoo.org>
+ +altermime-0.3.10-r1.ebuild, +files/altermime-0.3.10-respect-flags.patch:
+ Fixes for #241038, thanks to Kerin Millar
06 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
altermime-0.3.10.ebuild:
diff --git a/net-mail/altermime/altermime-0.3.10-r1.ebuild b/net-mail/altermime/altermime-0.3.10-r1.ebuild
new file mode 100644
index 000000000000..a3512ac3ae32
--- /dev/null
+++ b/net-mail/altermime/altermime-0.3.10-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/altermime/altermime-0.3.10-r1.ebuild,v 1.1 2010/11/02 19:02:35 patrick Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION=" alterMIME is a small program which is used to alter your mime-encoded mailpacks"
+SRC_URI="http://www.pldaniels.com/altermime/${P}.tar.gz"
+HOMEPAGE="http://pldaniels.com/altermime/"
+
+LICENSE="Sendmail"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fprintf-fixes.patch \
+ "${FILESDIR}"/${P}-MIME_headers-overflow.patch \
+ "${FILESDIR}"/${P}-respect-flags.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install () {
+ dobin altermime || die
+ dodoc CHANGELOG README || die
+}
diff --git a/net-mail/altermime/files/altermime-0.3.10-respect-flags.patch b/net-mail/altermime/files/altermime-0.3.10-respect-flags.patch
new file mode 100644
index 000000000000..243d49c11034
--- /dev/null
+++ b/net-mail/altermime/files/altermime-0.3.10-respect-flags.patch
@@ -0,0 +1,12 @@
+--- Makefile.orig 2008-11-16 08:45:45.000000000 +0000
++++ Makefile 2010-10-08 00:35:48.258944495 +0100
+@@ -11,3 +11,3 @@
+ ALTERMIME_OPTIONS=
+-CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)
++CFLAGS+=-Wall
+ OBJS= strstack.o mime_alter.o ffget.o pldstr.o filename-filters.o logger.o MIME_headers.o libmime-decoders.o boundary-stack.o qpe.o
+@@ -21,3 +21,3 @@
+ altermime: altermime.c ${OBJS}
+- ${CC} ${CFLAGS} altermime.c ${OBJS} -o altermime
++ ${CC} ${CFLAGS} ${LDFLAGS} altermime.c ${OBJS} -o altermime
+