summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-01-04 08:26:53 +0000
committerEray Aslan <eras@gentoo.org>2012-01-04 08:26:53 +0000
commit762de8e351472e87046f016b12f15a25ef26e65b (patch)
treef7b010af8eee8f8031c3e974fd077fc40c02a4d7 /net-mail/cyrus-imap-admin
parentadd tests for savedconfig.eclass:restore_config too (diff)
downloadgentoo-2-762de8e351472e87046f016b12f15a25ef26e65b.tar.gz
gentoo-2-762de8e351472e87046f016b12f15a25ef26e65b.tar.bz2
gentoo-2-762de8e351472e87046f016b12f15a25ef26e65b.zip
version bump
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/cyrus-imap-admin')
-rw-r--r--net-mail/cyrus-imap-admin/ChangeLog9
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.13.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/net-mail/cyrus-imap-admin/ChangeLog b/net-mail/cyrus-imap-admin/ChangeLog
index ea262ca829f0..cf131cc079c2 100644
--- a/net-mail/cyrus-imap-admin/ChangeLog
+++ b/net-mail/cyrus-imap-admin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/cyrus-imap-admin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.108 2011/12/18 18:00:27 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.109 2012/01/04 08:26:53 eras Exp $
+
+*cyrus-imap-admin-2.4.13 (04 Jan 2012)
+
+ 04 Jan 2012; Eray Aslan <eras@gentoo.org> +cyrus-imap-admin-2.4.13.ebuild:
+ version bump
18 Dec 2011; Raúl Porcel <armin76@gentoo.org>
cyrus-imap-admin-2.4.12.ebuild:
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.13.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.13.ebuild
new file mode 100644
index 000000000000..cc37d59f2882
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.13.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.13.ebuild,v 1.1 2012/01/04 08:26:53 eras Exp $
+
+EAPI=4
+
+inherit eutils perl-app db-use
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Utilities and Perl modules to administer a Cyrus IMAP server."
+HOMEPAGE="http://www.cyrusimap.org/"
+SRC_URI="ftp://ftp.cyrusimap.org/cyrus-imapd/cyrus-imapd-${MY_PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="berkdb kerberos ssl"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ >=dev-libs/cyrus-sasl-2.1.13
+ dev-perl/Term-ReadLine-Perl
+ dev-perl/TermReadKey
+ berkdb? ( >=sys-libs/db-3.2 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( virtual/krb5 )"
+
+DEPEND="$RDEPEND"
+
+S="${WORKDIR}/cyrus-imapd-${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.4.10-ldflags.patch"
+}
+
+src_configure() {
+ local myconf
+ if use berkdb ; then
+ myconf="--with-bdb-incdir=$(db_includedir)"
+ fi
+ econf \
+ --disable-server \
+ --enable-murder \
+ --enable-netscapehack \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --with-perl=/usr/bin/perl \
+ --without-krb \
+ --without-krbdes \
+ $(use_with berkdb bdb) \
+ $(use_enable kerberos gssapi) \
+ $(use_with ssl openssl) \
+ ${myconf}
+}
+
+src_compile() {
+ emake -C "${S}/lib" all
+ emake -C "${S}/perl" all
+}
+
+src_install () {
+ emake -C "${S}/perl" DESTDIR="${D}" INSTALLDIRS=vendor install
+ fixlocalpod # bug #98122
+}