summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-10-16 20:56:38 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-10-16 20:56:38 +0000
commit85b2b563a7b5c127875f26f39ff1e83e408e5abf (patch)
treefd3de5c0d2672af36fc00a9104ea236e01316fcd /net-mail/ezmlm-idx-pgsql
parentNew ezmlm-idx mailing list manager (enhanced ezmlm) (diff)
downloadgentoo-2-85b2b563a7b5c127875f26f39ff1e83e408e5abf.tar.gz
gentoo-2-85b2b563a7b5c127875f26f39ff1e83e408e5abf.tar.bz2
gentoo-2-85b2b563a7b5c127875f26f39ff1e83e408e5abf.zip
ezmlm-idx, ezmlm-idx-pgsql and ezmlm-idx-mysql
Diffstat (limited to 'net-mail/ezmlm-idx-pgsql')
-rw-r--r--net-mail/ezmlm-idx-pgsql/ChangeLog10
-rw-r--r--net-mail/ezmlm-idx-pgsql/ezmlm-idx-pgsql-0.40.ebuild63
-rw-r--r--net-mail/ezmlm-idx-pgsql/files/digest-ezmlm-idx-pgsql-0.402
3 files changed, 75 insertions, 0 deletions
diff --git a/net-mail/ezmlm-idx-pgsql/ChangeLog b/net-mail/ezmlm-idx-pgsql/ChangeLog
new file mode 100644
index 000000000000..e6b2f7443f75
--- /dev/null
+++ b/net-mail/ezmlm-idx-pgsql/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-mail/ezmlm-idx-pgsql
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx-pgsql/ChangeLog,v 1.1 2002/10/16 20:56:38 drobbins Exp $
+
+*ezmlm-idx-pgsql-0.40 (16 Oct 2002)
+
+ 16 Oct 2002; Daniel Robbins <drobbins@gentoo.org>: See ChangeLog for
+ net-mail/ezmlm-idx, of which this is a clone (and should be kept in-sync with
+ the ezmlm-idx ebuid.)
+
diff --git a/net-mail/ezmlm-idx-pgsql/ezmlm-idx-pgsql-0.40.ebuild b/net-mail/ezmlm-idx-pgsql/ezmlm-idx-pgsql-0.40.ebuild
new file mode 100644
index 000000000000..54a227e7ced5
--- /dev/null
+++ b/net-mail/ezmlm-idx-pgsql/ezmlm-idx-pgsql-0.40.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx-pgsql/ezmlm-idx-pgsql-0.40.ebuild,v 1.1 2002/10/16 20:56:38 drobbins Exp $
+
+# NOTE: ezmlm-idx, ezmlm-idx-mysql and ezmlm-idx-pgsql all supported by this single ebuild
+# (Please keep them in sync)
+
+PB=ezmlm-idx
+S2=${WORKDIR}/${P}
+S=${WORKDIR}/ezmlm-0.53
+DESCRIPTION="Simple yet powerful mailing list manager for qmail."
+SRC_URI="http://gd.tuwien.ac.at/infosys/mail/qmail/ezmlm-patches/${PB}-${PV}.tar.gz http://cr.yp.to/software/ezmlm-0.53.tar.gz"
+HOMEPAGE="http://www.ezmlm.org"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+DEPEND="sys-apps/grep sys-apps/groff"
+RDEPEND="net-mail/qmail"
+PROVIDE="net-mail/ezmlm"
+
+if [ "$PN" = "${PB}-pgsql" ]
+then
+ DEPEND="$DEPEND dev-db/postgresql"
+ RDEPEND="$RDEPEND dev-db/postgresql"
+elif [ "$PN" = "${PB}-mysql" ]
+then
+ DEPEND="$DEPEND dev-db/mysql"
+ RDEPEND="$RDEPEND dev-db/mysql"
+fi
+
+src_unpack() {
+ unpack ${A}
+ cd ${S2}
+ mv ${S2}/* ${S}
+ cd ${S}
+ patch < idx.patch
+ #remove cat-man pages
+ cp MAN MAN.orig
+ cat MAN.orig | grep -v cat > MAN
+}
+
+src_compile() {
+ cd ${S}
+ echo "/usr/bin" > conf-bin
+ echo "/usr/share/man" > conf-man
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+ if [ "$PN" = "${PB}-pgsql" ]
+ then
+ make pgsql
+ elif [ "$PN" = "${PB}-mysql" ]
+ then
+ make mysql
+ fi
+ emake || die
+}
+
+src_install () {
+ install -d ${D}/usr/bin ${D}/usr/share/man
+ echo "${D}/usr/bin" > conf-bin
+ echo "${D}/usr/share/man" > conf-man
+ make setup || die
+}
diff --git a/net-mail/ezmlm-idx-pgsql/files/digest-ezmlm-idx-pgsql-0.40 b/net-mail/ezmlm-idx-pgsql/files/digest-ezmlm-idx-pgsql-0.40
new file mode 100644
index 000000000000..20d368cc7fec
--- /dev/null
+++ b/net-mail/ezmlm-idx-pgsql/files/digest-ezmlm-idx-pgsql-0.40
@@ -0,0 +1,2 @@
+MD5 c6137114060cff19301a956e73d46fc0 ezmlm-idx-0.40.tar.gz 553974
+MD5 108c632caaa8cdbfd3041e6c449191b2 ezmlm-0.53.tar.gz 62693