summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2001-12-05 02:33:04 +0000
committerGeert Bevin <gbevin@gentoo.org>2001-12-05 02:33:04 +0000
commit3305cab09d899221a66abe94be3cc9b5a97e5b75 (patch)
treee99ed02b93c9bfd2e4bfe81b442f03631f55517c /net-mail/fastforward
parentUpgraded to new version and integrate with startup scripts. (diff)
downloadgentoo-2-3305cab09d899221a66abe94be3cc9b5a97e5b75.tar.gz
gentoo-2-3305cab09d899221a66abe94be3cc9b5a97e5b75.tar.bz2
gentoo-2-3305cab09d899221a66abe94be3cc9b5a97e5b75.zip
Reviewed entire qmail installation since the installation was broken.
It's now installed exactly according to what's explained in the qmail howto v2. It uses daemontools for service launching. To start/stop/reload, there is an additional script /var/qmail/bin/qmail-control that can be used instead of the general svscan startup file.
Diffstat (limited to 'net-mail/fastforward')
-rw-r--r--net-mail/fastforward/fastforward-0.51.ebuild53
-rw-r--r--net-mail/fastforward/files/digest-fastforward-0.511
2 files changed, 54 insertions, 0 deletions
diff --git a/net-mail/fastforward/fastforward-0.51.ebuild b/net-mail/fastforward/fastforward-0.51.ebuild
new file mode 100644
index 000000000000..6dc3596b4dfb
--- /dev/null
+++ b/net-mail/fastforward/fastforward-0.51.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Geert Bevin <gbevin@theleaf.be>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fastforward/fastforward-0.51.ebuild,v 1.1 2001/12/05 02:33:04 gbevin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Fastforward handles qmail forwarding according to a cdb database"
+HOMEPAGE="http://cr.yp.to/fastforward.html"
+
+SRC_URI="http://cr.yp.to/software/fastforward-0.51.tar.gz"
+
+DEPEND="virtual/glibc
+ sys-apps/groff"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack ${P}.tar.gz
+
+ cd ${S}
+
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+
+}
+
+src_compile() {
+
+ cd ${S}
+
+ emake it || die
+}
+
+
+
+src_install() {
+
+ into /usr
+ dodoc ALIASES BLURB CHANGES FILES INSTALL README SYSDEPS TARGETS
+ dodoc THANKS TODO VERSION
+
+ insopts -o root -g qmail -m 755
+ insinto /var/qmail/bin
+ doins fastforward newaliases newinclude printforward printmaillist \
+ setforward setmaillist
+
+ into /usr
+ for i in *.1
+ do
+ doman $i
+ done
+
+}
diff --git a/net-mail/fastforward/files/digest-fastforward-0.51 b/net-mail/fastforward/files/digest-fastforward-0.51
new file mode 100644
index 000000000000..6e03baf1e5e9
--- /dev/null
+++ b/net-mail/fastforward/files/digest-fastforward-0.51
@@ -0,0 +1 @@
+MD5 6dc619180ba9726380dc1047e45a1d8d fastforward-0.51.tar.gz 40960