summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Marichez <falco@gentoo.org>2007-09-03 14:31:42 +0000
committerRaphaël Marichez <falco@gentoo.org>2007-09-03 14:31:42 +0000
commit029123af88a27bd7b63e0daa49cf86603fca9999 (patch)
treec928e86299364527ba39e9472103323a116f55e7 /net-mail/fetchmail
parentVersion bump. (diff)
downloadgentoo-2-029123af88a27bd7b63e0daa49cf86603fca9999.tar.gz
gentoo-2-029123af88a27bd7b63e0daa49cf86603fca9999.tar.bz2
gentoo-2-029123af88a27bd7b63e0daa49cf86603fca9999.zip
Fix possible security issue (DoS), bug 191154
(Portage version: 2.1.2.12)
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.8-r1.ebuild85
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-6.3.8-r13
-rw-r--r--net-mail/fetchmail/files/fetchmail-6.3.8-null-msg-pointer.patch13
3 files changed, 101 insertions, 0 deletions
diff --git a/net-mail/fetchmail/fetchmail-6.3.8-r1.ebuild b/net-mail/fetchmail/fetchmail-6.3.8-r1.ebuild
new file mode 100644
index 000000000000..52b7587eb972
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.3.8-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.8-r1.ebuild,v 1.1 2007/09/03 14:31:41 falco Exp $
+
+inherit eutils
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://fetchmail.berlios.de"
+SRC_URI="http://download2.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE="ssl nls ipv6 kerberos krb4 hesiod"
+
+RDEPEND="hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( app-crypt/mit-krb5 )
+ nls? ( virtual/libintl )
+ elibc_FreeBSD? ( sys-libs/com_err )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fixes DoS, #191154
+ epatch "${FILESDIR}"/${P}-null-msg-pointer.patch
+
+ # this patch fixes bug #34788 (ticho@gentoo.org 2004-09-03)
+ epatch "${FILESDIR}"/${PN}-6.2.5-broken-headers.patch
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_enable ipv6 inet6) \
+ $(use_with kerberos gssapi) $(use_with kerberos kerberos5) \
+ $(use_with krb4 kerberos) \
+ $(use_with ssl) \
+ $(use_with hesiod) \
+ ${myconf} || die "Configuration failed."
+ # wont compile reliably on smp (mkennedy@gentoo.org 2003-11-12)
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README README.NTLM README.SSL TODO
+
+ newinitd "${FILESDIR}"/fetchmail fetchmail
+ newconfd "${FILESDIR}"/conf.d-fetchmail fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ elog
+ elog "You will not be able to use fetchmailconf(1), because you"
+ elog "don't seem to have Python with tkinter support."
+ elog
+ elog "If you want to be able to use fetchmailconf(1), do the following:"
+ elog " 1. Add 'tk' to the USE variable in /etc/make.conf."
+ elog " 2. (Re-)merge Python."
+ elog
+ fi
+
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.3.8-r1 b/net-mail/fetchmail/files/digest-fetchmail-6.3.8-r1
new file mode 100644
index 000000000000..e32b9c4065b0
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-6.3.8-r1
@@ -0,0 +1,3 @@
+MD5 66b97500b0a1e3c0916b3b5314f597f5 fetchmail-6.3.8.tar.bz2 1323515
+RMD160 34034f9ae9fe44ba35f0a16d3128d4a9b0001df2 fetchmail-6.3.8.tar.bz2 1323515
+SHA256 5612f9af367f641e0efd084f44fcf1889669e711dbd8c60f6b7953e494d1b09b fetchmail-6.3.8.tar.bz2 1323515
diff --git a/net-mail/fetchmail/files/fetchmail-6.3.8-null-msg-pointer.patch b/net-mail/fetchmail/files/fetchmail-6.3.8-null-msg-pointer.patch
new file mode 100644
index 000000000000..cc89aa6a44c4
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail-6.3.8-null-msg-pointer.patch
@@ -0,0 +1,13 @@
+Index: sink.c
+===================================================================
+--- sink.c (revision 5118)
++++ sink.c (revision 5119)
+@@ -262,7 +262,7 @@
+ const char *md1 = "MAILER-DAEMON", *md2 = "MAILER-DAEMON@";
+
+ /* don't bounce in reply to undeliverable bounces */
+- if (!msg->return_path[0] ||
++ if (!msg || !msg->return_path[0] ||
+ strcmp(msg->return_path, "<>") == 0 ||
+ strcasecmp(msg->return_path, md1) == 0 ||
+ strncasecmp(msg->return_path, md2, strlen(md2)) == 0)