summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-02-05 07:06:41 +0000
committerTorsten Veller <tove@gentoo.org>2010-02-05 07:06:41 +0000
commit8cade36d3fece4e867bf463882cad59803fb82af (patch)
treedc4554a3379118771f507b90d4fc38c57e1d13b6 /net-mail/fetchmail
parentarm stable, bug #301943 (diff)
downloadgentoo-2-8cade36d3fece4e867bf463882cad59803fb82af.tar.gz
gentoo-2-8cade36d3fece4e867bf463882cad59803fb82af.tar.bz2
gentoo-2-8cade36d3fece4e867bf463882cad59803fb82af.zip
Version bump
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/ChangeLog9
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.14.ebuild103
2 files changed, 110 insertions, 2 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index 65f528a47f56..b086276bda19 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/fetchmail
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.175 2009/10/30 10:16:51 tove Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.176 2010/02/05 07:06:41 tove Exp $
+
+*fetchmail-6.3.14 (05 Feb 2010)
+
+ 05 Feb 2010; Torsten Veller <tove@gentoo.org> +fetchmail-6.3.14.ebuild:
+ Version bump
30 Oct 2009; Torsten Veller <tove@gentoo.org> fetchmail-6.3.13.ebuild:
Run --with-ssl before --with-kerberos. Kerberos requires ssl. Heimdal is
diff --git a/net-mail/fetchmail/fetchmail-6.3.14.ebuild b/net-mail/fetchmail/fetchmail-6.3.14.ebuild
new file mode 100644
index 000000000000..e990c0fcd9b9
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.3.14.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.14.ebuild,v 1.1 2010/02/05 07:06:41 tove Exp $
+
+EAPI=2
+
+inherit multilib python eutils
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://fetchmail.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl nls kerberos hesiod tk"
+
+RDEPEND="hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( virtual/krb5 >=dev-libs/openssl-0.9.6 )
+ nls? ( virtual/libintl )
+ elibc_FreeBSD? ( sys-libs/com_err )
+ dev-lang/python[tk?]"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+RESTRICT=test
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+}
+
+src_prepare() {
+ # this patch fixes bug #34788 (ticho@gentoo.org 2004-09-03)
+ epatch "${FILESDIR}"/${PN}-6.2.5-broken-headers.patch
+
+ # dont compile during src_install
+ : > "${S}"/py-compile
+}
+
+src_configure() {
+# PYTHON=: \
+ econf \
+ --disable-dependency-tracking \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl) \
+ $(use kerberos && echo "--with-ssl" ) \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ $(use_with hesiod) \
+ ${myconf} || die "Configuration failed."
+}
+
+src_install() {
+ # dir for pidfile
+ dodir /var/run/${PN} || die "dodir failed"
+ keepdir /var/run/${PN}
+ fowners ${PN}:${PN} /var/run/${PN} || die "fowners failed"
+
+ # fetchmail's homedir (holds fetchmail's .fetchids)
+ dodir /var/lib/${PN} || die "dodir failed"
+ keepdir /var/lib/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN} || die "fowners failed"
+ fperms 700 /var/lib/${PN} || die "fperms failed"
+
+ emake DESTDIR="${D}" install || die
+ python_need_rebuild
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO || die
+
+ newinitd "${FILESDIR}"/fetchmail.new fetchmail || die
+ newconfd "${FILESDIR}"/conf.d-fetchmail fetchmail || die
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/fetchmailconf.py
+
+ if ! has_version dev-lang/python[tk] ; then
+ elog "Reinstall ${CATEGORY}/${PN} with USE=tk"
+ elog "if you want to use fetchmailconf."
+ fi
+
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages
+}