summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-12-16 10:30:56 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-12-16 10:30:56 +0000
commit511730da021772bd0471e6587e70a87ce0d99f67 (patch)
tree88baf94be9440c78af5e615ddb15b449f2214e69 /net-mail/libpst/libpst-0.5.1.ebuild
parentget_libdir support for multilib archs. (Manifest recommit) (diff)
downloadgentoo-2-511730da021772bd0471e6587e70a87ce0d99f67.tar.gz
gentoo-2-511730da021772bd0471e6587e70a87ce0d99f67.tar.bz2
gentoo-2-511730da021772bd0471e6587e70a87ce0d99f67.zip
Version bump ; new upstream maintainer (w/ a working homepage too!). Closes bug 74556.
Diffstat (limited to 'net-mail/libpst/libpst-0.5.1.ebuild')
-rw-r--r--net-mail/libpst/libpst-0.5.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-mail/libpst/libpst-0.5.1.ebuild b/net-mail/libpst/libpst-0.5.1.ebuild
new file mode 100644
index 000000000000..3b2a3dea689e
--- /dev/null
+++ b/net-mail/libpst/libpst-0.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/libpst-0.5.1.ebuild,v 1.1 2004/12/16 10:30:56 ka0ttic Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tools and library for reading Outlook files (.pst format)"
+HOMEPAGE="http://alioth.debian.org/projects/libpst/"
+SRC_URI="http://alioth.debian.org/download.php/844/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS CREDITS TODO FILE-FORMAT || die "dodoc failed"
+ dohtml FILE-FORMAT.html || die "dohtml failed"
+}