summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-10-17 18:54:06 +0000
committerTim Harder <radhermit@gentoo.org>2011-10-17 18:54:06 +0000
commit3ded067e2d8f622bcfe29adf41683b65e338fc6d (patch)
treee3224b9d80ec261e90c22132a3b90a6ab16fd74a /net-mail/mswatch
parentput a date on the games gtk+:1 mask (diff)
downloadgentoo-2-3ded067e2d8f622bcfe29adf41683b65e338fc6d.tar.gz
gentoo-2-3ded067e2d8f622bcfe29adf41683b65e338fc6d.tar.bz2
gentoo-2-3ded067e2d8f622bcfe29adf41683b65e338fc6d.zip
Initial import.
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/mswatch')
-rw-r--r--net-mail/mswatch/ChangeLog10
-rw-r--r--net-mail/mswatch/metadata.xml5
-rw-r--r--net-mail/mswatch/mswatch-1.2.0.ebuild34
3 files changed, 49 insertions, 0 deletions
diff --git a/net-mail/mswatch/ChangeLog b/net-mail/mswatch/ChangeLog
new file mode 100644
index 000000000000..9cf095bf9ce6
--- /dev/null
+++ b/net-mail/mswatch/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-mail/mswatch
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mswatch/ChangeLog,v 1.1 2011/10/17 18:54:06 radhermit Exp $
+
+*mswatch-1.2.0 (17 Oct 2011)
+
+ 17 Oct 2011; Tim Harder <radhermit@gentoo.org> +mswatch-1.2.0.ebuild,
+ +metadata.xml:
+ Initial import.
+
diff --git a/net-mail/mswatch/metadata.xml b/net-mail/mswatch/metadata.xml
new file mode 100644
index 000000000000..51f94e3fbe0e
--- /dev/null
+++ b/net-mail/mswatch/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+</pkgmetadata>
diff --git a/net-mail/mswatch/mswatch-1.2.0.ebuild b/net-mail/mswatch/mswatch-1.2.0.ebuild
new file mode 100644
index 000000000000..98a88e9f0b16
--- /dev/null
+++ b/net-mail/mswatch/mswatch-1.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mswatch/mswatch-1.2.0.ebuild,v 1.1 2011/10/17 18:54:06 radhermit Exp $
+
+EAPI="4"
+
+inherit linux-info autotools-utils
+
+DESCRIPTION="A utility to watch mailstores for changes and initiate mailbox syncs"
+HOMEPAGE="http://mswatch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/glib-2.6:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+CONFIG_CHECK="~INOTIFY_USER"
+ERROR_INOTIFY_USER="${P} requires in-kernel inotify support."
+
+src_configure() {
+ econf \
+ --with-notify=inotify \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ remove_libtool_files
+}