summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-01-27 14:32:10 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-01-27 14:32:10 +0000
commit6d8643a7d8748d49260903bc32944e73969c5629 (patch)
tree0ecb86106f4923c4144c2f9bf2d9a9a867087207 /net-mail/notmuch
parentsci-chemistry/ball: Add fix for tests, #454162; backport patches upstream inc... (diff)
downloadgentoo-2-6d8643a7d8748d49260903bc32944e73969c5629.tar.gz
gentoo-2-6d8643a7d8748d49260903bc32944e73969c5629.tar.bz2
gentoo-2-6d8643a7d8748d49260903bc32944e73969c5629.zip
Version bump.
NEWS ~~~~ (Extracted headlines from NEWS file. See it for details.) Internal test framework changes ------------------------------- - Set a default value for TERM when running tests (Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key E1DBFAB5)
Diffstat (limited to 'net-mail/notmuch')
-rw-r--r--net-mail/notmuch/ChangeLog17
-rw-r--r--net-mail/notmuch/files/0.15.1-0001-lib-Makefile.local-depend-on-libs-we-a.patch25
-rw-r--r--net-mail/notmuch/notmuch-0.15.1.ebuild195
3 files changed, 236 insertions, 1 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index dda6e58c2b32..24cd039d04b2 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,21 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.68 2013/01/22 16:51:12 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.69 2013/01/27 14:32:10 aidecoe Exp $
+
+*notmuch-0.15.1 (27 Jan 2013)
+
+ 27 Jan 2013; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ +notmuch-0.15.1.ebuild,
+ +files/0.15.1-0001-lib-Makefile.local-depend-on-libs-we-a.patch:
+ Version bump.
+
+ NEWS
+ ~~~~
+ (Extracted headlines from NEWS file. See it for details.)
+
+ Internal test framework changes
+ -------------------------------
+ - Set a default value for TERM when running tests
22 Jan 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> notmuch-0.15.ebuild,
+files/0.15-0001-lib-Makefile.local-depend-on-libs-we-a.patch:
diff --git a/net-mail/notmuch/files/0.15.1-0001-lib-Makefile.local-depend-on-libs-we-a.patch b/net-mail/notmuch/files/0.15.1-0001-lib-Makefile.local-depend-on-libs-we-a.patch
new file mode 100644
index 000000000000..b0d1e91533b9
--- /dev/null
+++ b/net-mail/notmuch/files/0.15.1-0001-lib-Makefile.local-depend-on-libs-we-a.patch
@@ -0,0 +1,25 @@
+From 624cd2eef34963ca521d9dbabc886585ea2f5d54 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Mon, 21 Jan 2013 20:37:53 +0100
+Subject: [PATCH] lib/Makefile.local: depend on libs we are linking with
+
+---
+ lib/Makefile.local | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/Makefile.local b/lib/Makefile.local
+index 7785944..155ac02 100644
+--- a/lib/Makefile.local
++++ b/lib/Makefile.local
+@@ -73,7 +73,7 @@ libnotmuch_modules := $(libnotmuch_c_srcs:.c=.o) $(libnotmuch_cxx_srcs:.cc=.o)
+ $(dir)/libnotmuch.a: $(libnotmuch_modules)
+ $(call quiet,AR) rcs $@ $^
+
+-$(dir)/$(LIBNAME): $(libnotmuch_modules) notmuch.sym
++$(dir)/$(LIBNAME): $(libnotmuch_modules) notmuch.sym util/libutil.a parse-time-string/libparse-time-string.a
+ $(call quiet,CXX $(CXXFLAGS)) $(libnotmuch_modules) $(FINAL_LIBNOTMUCH_LDFLAGS) $(LIBRARY_LINK_FLAG) -o $@ util/libutil.a parse-time-string/libparse-time-string.a
+
+ notmuch.sym: $(srcdir)/$(dir)/notmuch.h $(libnotmuch_modules)
+--
+1.8.1.1
+
diff --git a/net-mail/notmuch/notmuch-0.15.1.ebuild b/net-mail/notmuch/notmuch-0.15.1.ebuild
new file mode 100644
index 000000000000..e011deffe097
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.15.1.ebuild
@@ -0,0 +1,195 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.15.1.ebuild,v 1.1 2013/01/27 14:32:10 aidecoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2:2.6 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.1"
+
+inherit elisp-common eutils pax-utils distutils
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="http://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="
+ pick? ( emacs )
+ test? ( crypt emacs python )
+ "
+IUSE="bash-completion crypt debug doc emacs mutt nmbug pick python test vim
+ zsh-completion"
+
+CDEPEND="
+ >=dev-libs/glib-2.22
+ >=dev-libs/gmime-2.6.7
+ dev-libs/xapian
+ sys-libs/talloc
+ debug? ( dev-util/valgrind )
+ emacs? ( >=virtual/emacs-23 )
+ x86? ( >=dev-libs/xapian-1.2.7-r2 )
+ vim? ( || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 ) )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( python? ( dev-python/sphinx ) )
+ test? ( app-misc/dtach || ( >=app-editors/emacs-23[libxml2]
+ >=app-editors/emacs-vcs-23[libxml2] ) sys-devel/gdb )
+ "
+RDEPEND="${CDEPEND}
+ crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git virtual/perl-File-Temp virtual/perl-PodParser )
+ mutt? ( dev-perl/File-Which dev-perl/Mail-Box dev-perl/MailTools
+ dev-perl/String-ShellQuote dev-perl/Term-ReadLine-Gnu
+ virtual/perl-Digest-SHA virtual/perl-File-Path virtual/perl-Getopt-Long
+ virtual/perl-PodParser
+ )
+ zsh-completion? ( app-shells/zsh )
+ "
+
+PATCHES=(
+ "${FILESDIR}/${PV}-0001-lib-Makefile.local-depend-on-libs-we-a.patch"
+ )
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+SITEFILE_PICK="60${PN}-pick-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+
+bindings() {
+ if use $1; then
+ pushd bindings/$1 || die
+ shift
+ $@
+ popd || die
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ local p
+ for p in "${PATCHES[@]}"; do
+ epatch "${p}"
+ done
+
+ default
+ bindings python distutils_src_prepare
+
+ if use mutt; then
+ mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+ fi
+
+ if use pick; then
+ mv contrib/notmuch-pick/README contrib/notmuch-pick/README-pick || die
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bashcompletiondir="${ROOT}/usr/share/bash-completion"
+ --emacslispdir="${ROOT}/${SITELISP}/${PN}"
+ --emacsetcdir="${ROOT}/${SITEETC}/${PN}"
+ --with-gmime-version=2.6
+ --zshcompletiondir="${ROOT}/usr/share/zsh/site-functions"
+ $(use_with bash-completion)
+ $(use_with emacs)
+ $(use_with zsh-completion)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ bindings python distutils_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ emake notmuch-mutt.1
+ popd || die
+ fi
+
+ if use doc; then
+ pydocs() {
+ mv README README-python || die
+ pushd docs || die
+ emake html
+ mv html ../python || die
+ popd || die
+ }
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+ fi
+}
+
+src_test() {
+ pax-mark -m notmuch
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" default
+ pax-mark -ze notmuch
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ if use pick; then
+ pushd contrib/notmuch-pick || die
+ elisp-install "${PN}" notmuch-pick.el || die
+ dodoc README-pick
+ popd || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE_PICK}" || die
+ fi
+ fi
+
+ if use nmbug; then
+ dobin contrib/nmbug/nmbug
+ fi
+
+ if use mutt; then
+ [[ -e /etc/mutt/notmuch-mutt.rc ]] && NOTMUCH_MUTT_RC_EXISTS=1
+ pushd contrib/notmuch-mutt || die
+ dobin notmuch-mutt
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd || die
+ fi
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins -r vim/plugin vim/syntax
+ fi
+
+ DOCS="" bindings python distutils_src_install
+
+ if use doc; then
+ bindings python dohtml -r python
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ use python && distutils_pkg_postinst
+
+ if use mutt && [[ ! ${NOTMUCH_MUTT_RC_EXISTS} ]]; then
+ elog "To enable notmuch support in mutt, add the following line into"
+ elog "your mutt config file, please:"
+ elog ""
+ elog " source /etc/mutt/notmuch-mutt.rc"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ use python && distutils_pkg_postrm
+}