summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-16 01:01:28 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-16 01:01:28 +0000
commit82e03955f1ce778f8d6989264ef4fc65c2f01c7d (patch)
treeec6c3f1f5d6fff62637a8cab6ee651f69a3bfb5f /net-mail/spruce
parentConverted gpg USE flag to crypt USE flag instead (diff)
downloadgentoo-2-82e03955f1ce778f8d6989264ef4fc65c2f01c7d.tar.gz
gentoo-2-82e03955f1ce778f8d6989264ef4fc65c2f01c7d.tar.bz2
gentoo-2-82e03955f1ce778f8d6989264ef4fc65c2f01c7d.zip
Changed gpg USE toggle to crypt USE toggle
Diffstat (limited to 'net-mail/spruce')
-rw-r--r--net-mail/spruce/ChangeLog8
-rw-r--r--net-mail/spruce/spruce-0.7.6-r2.ebuild35
2 files changed, 22 insertions, 21 deletions
diff --git a/net-mail/spruce/ChangeLog b/net-mail/spruce/ChangeLog
index 67be2cfd5595..68757f7305fa 100644
--- a/net-mail/spruce/ChangeLog
+++ b/net-mail/spruce/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/spruce
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/spruce/ChangeLog,v 1.1 2002/02/01 21:53:34 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/spruce/ChangeLog,v 1.2 2002/04/16 01:00:28 seemant Exp $
+
+*spruce-0.7.6-r2 (15 Apr 2002)
+
+ 15 Apr 2002; Seemant Kulleen <seemant@gentoo.org> spruce-0.7.6-r2.ebuild :
+
+ Changed the gpg USE toggle to the more general crypt USE toggle instead.
*spruce-0.7.6-r2 (1 Feb 2002)
diff --git a/net-mail/spruce/spruce-0.7.6-r2.ebuild b/net-mail/spruce/spruce-0.7.6-r2.ebuild
index 3a65624ee576..7de48b653b5c 100644
--- a/net-mail/spruce/spruce-0.7.6-r2.ebuild
+++ b/net-mail/spruce/spruce-0.7.6-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Joe Bormolini <lordjoe@bigfoot.com>
# Maintainer: Desktop Team <desktop@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/spruce/spruce-0.7.6-r2.ebuild,v 1.2 2002/03/06 18:55:22 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/spruce/spruce-0.7.6-r2.ebuild,v 1.3 2002/04/16 01:00:28 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Gtk email client"
@@ -10,10 +10,10 @@ SRC_URI="ftp://spruce.sourceforge.net/pub/spruce/devel/${P}.tar.gz"
HOMEPAGE="http://spruce.sourceforge.net/"
RDEPEND=">=x11-libs/gtk+-1.2.10-r4
- gnome-base/libglade
- ssl? ( >=dev-libs/openssl-0.9.6 )
- gpg? ( app-crypt/gnupg )
- gnome? ( >=gnome-base/gnome-print-0.29-r1 )"
+ gnome-base/libglade
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ crypt? ( app-crypt/gnupg )
+ gnome? ( >=gnome-base/gnome-print-0.29-r1 )"
DEPEND="$RDEPEND
nls? ( sys-devel/gettext )"
@@ -27,24 +27,19 @@ src_unpack() {
src_compile() {
local myopts
- if [ -z "`use nls`" ]; then
- myopts="--disable-nls"
- fi
+ use nls \
+ || myopts="--disable-nls"
- if [ "`use ssl`" ]; then
- echo "SSL does not work"
+ use ssl \
+ && echo "SSL does not work"
# myopts="$myopts --with-ssl"
- fi
- if [ "`use gpg`" ] ; then
- myopts="$myopts --enable-pgp"
- else
- myopts="$myopts --disable-pgp"
- fi
+ use crypt \
+ && myopts="$myopts --enable-pgp" \
+ || myopts="$myopts --disable-pgp"
- if [ "`use gnome`" ] ; then
- myopts="$myopts --enable-gnome"
- fi
+ use gnome \
+ && myopts="$myopts --enable-gnome"
CFLAGS="${CFLAGS} `gnome-config --cflags print gdk_pixbuf`"