summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-10-04 02:30:29 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-10-04 02:30:29 +0000
commit1615d4860625f536d7998e22fcbd7a9092d7d2b3 (patch)
tree996292f2fccb9bcaa389e3783f8550b70b09bc54 /net-mail/sylpheed
parentVersion bump + fixes #6926 #8380 #8707 (diff)
downloadgentoo-2-1615d4860625f536d7998e22fcbd7a9092d7d2b3.tar.gz
gentoo-2-1615d4860625f536d7998e22fcbd7a9092d7d2b3.tar.bz2
gentoo-2-1615d4860625f536d7998e22fcbd7a9092d7d2b3.zip
version bump, bug fixes
Diffstat (limited to 'net-mail/sylpheed')
-rw-r--r--net-mail/sylpheed/ChangeLog9
-rw-r--r--net-mail/sylpheed/files/digest-sylpheed-0.8.51
-rw-r--r--net-mail/sylpheed/sylpheed-0.8.5.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/net-mail/sylpheed/ChangeLog b/net-mail/sylpheed/ChangeLog
index b65f08cb027e..cd764a7d43fc 100644
--- a/net-mail/sylpheed/ChangeLog
+++ b/net-mail/sylpheed/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/sylpheed
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.15 2002/10/01 11:28:25 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.16 2002/10/04 02:30:29 bcowan Exp $
+
+*sylpheed-0.8.5 (03 Oct 2002)
+
+03 Oct 2002; Brad Cowan <bcowan@gentoo.org> sylpheed-0.8.5.ebuild,
+ files/digest-sylpheed-0.8.5 :
+
+ Version bump, bugfixes.
*sylpheed-0.8.4 (01 Oct 2002)
diff --git a/net-mail/sylpheed/files/digest-sylpheed-0.8.5 b/net-mail/sylpheed/files/digest-sylpheed-0.8.5
new file mode 100644
index 000000000000..1bf21cec4f21
--- /dev/null
+++ b/net-mail/sylpheed/files/digest-sylpheed-0.8.5
@@ -0,0 +1 @@
+MD5 e603c1c48c2932d595b775354b550c2e sylpheed-0.8.5.tar.bz2 1891572
diff --git a/net-mail/sylpheed/sylpheed-0.8.5.ebuild b/net-mail/sylpheed/sylpheed-0.8.5.ebuild
new file mode 100644
index 000000000000..5a99b8ed7287
--- /dev/null
+++ b/net-mail/sylpheed/sylpheed-0.8.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/sylpheed-0.8.5.ebuild,v 1.1 2002/10/04 02:30:29 bcowan Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A lightweight email client and newsreader"
+SRC_URI="http://sylpheed.good-day.net/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://sylpheed.good-day.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+PROVIDE="virtual/sylpheed"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=media-libs/compface-1.4
+ ssl? ( dev-libs/openssl )
+ pda? ( app-misc/jpilot )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+src_compile() {
+
+ local myconf
+
+ use gnome || myconf="--disable-gdk-pixbuf --disable-imlib"
+ use nls || myconf="$myconf --disable-nls"
+ use ssl && myconf="$myconf --enable-ssl"
+ use crypt && myconf="$myconf --enable-gpgme"
+ use pda && myconf="$myconf --enable-jpilot"
+ use ldap && myconf="$myconf --enable-ldap"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --enable-ipv6 $myconf || die
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ manualdir=${D}/usr/share/doc/${PF}/html \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* NEWS README* TODO*
+}
+