summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-03-05 12:03:53 +0000
committerTorsten Veller <tove@gentoo.org>2010-03-05 12:03:53 +0000
commit2a1c5d16ab605e51abd95ae0828d295deb9afb93 (patch)
treeb85facc4a2b1905fee4a978ab76da012e8ba320d /net-mail/topal/files
parentFixes load_plugin error via Moose::Meta::Class (#307869). Thanks to Jason Mills (diff)
downloadgentoo-2-2a1c5d16ab605e51abd95ae0828d295deb9afb93.tar.gz
gentoo-2-2a1c5d16ab605e51abd95ae0828d295deb9afb93.tar.bz2
gentoo-2-2a1c5d16ab605e51abd95ae0828d295deb9afb93.zip
Version bump. Thanks to Peter Gantner (#306981)
(Portage version: 2.2_rc64/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/topal/files')
-rw-r--r--net-mail/topal/files/64-Makefile.patch3
-rw-r--r--net-mail/topal/files/72-Makefile.patch79
2 files changed, 81 insertions, 1 deletions
diff --git a/net-mail/topal/files/64-Makefile.patch b/net-mail/topal/files/64-Makefile.patch
index 694a06539e8d..834b75b750c6 100644
--- a/net-mail/topal/files/64-Makefile.patch
+++ b/net-mail/topal/files/64-Makefile.patch
@@ -20,12 +20,13 @@ diff -Naur topal-64.orig/MIME-tool/Makefile topal-64/MIME-tool/Makefile
diff -Naur topal-64.orig/Makefile topal-64/Makefile
--- topal-64.orig/Makefile 2008-10-24 12:16:45.000000000 +0200
+++ topal-64/Makefile 2009-04-22 09:37:18.000000000 +0200
-@@ -36,26 +36,28 @@
+@@ -36,26 +36,29 @@
INSTALLPATHDOC ?= $(INSTALLPATH)/share/doc/topal
INSTALLPATHPATCHES ?= $(INSTALLPATH)/share/topal/patches
+CC=gcc
+CFLAGS=-Wall -O2
++LDFLAGS=
+
# The default action.
all: topal mime-tool README.txt
diff --git a/net-mail/topal/files/72-Makefile.patch b/net-mail/topal/files/72-Makefile.patch
new file mode 100644
index 000000000000..d517913d0863
--- /dev/null
+++ b/net-mail/topal/files/72-Makefile.patch
@@ -0,0 +1,79 @@
+diff -uraN topal-72-orig/MIME-tool/Makefile topal-72/MIME-tool/Makefile
+--- topal-72-orig/MIME-tool/Makefile 2010-02-25 21:28:39.000000000 +0100
++++ topal-72/MIME-tool/Makefile 2010-03-04 13:24:53.691055969 +0100
+@@ -1,10 +1,14 @@
+ .PHONY: all clean realclean distrib
+
++CC=gcc
++CFLAGS=-Wall -O2
++LDFLAGS=
++
++
+ all: mime-tool
+
+ mime-tool: mime.c
+- gcc -Wall -O2 -o mime-tool mime.c
+- -strip mime-tool
++ $(CC) $(CFLAGS) $(LDFLAGS) -o mime-tool mime.c
+
+ realclean: clean
+ -rm mime-tool
+diff -uraN topal-72-orig/Makefile topal-72/Makefile
+--- topal-72-orig/Makefile 2010-02-25 21:28:39.000000000 +0100
++++ topal-72/Makefile 2010-03-04 13:44:58.220101516 +0100
+@@ -15,6 +15,10 @@
+
+ .PHONY: all clean realclean distclean package install distrib all2 FORCE
+
++CC=gcc
++CFLAGS=-Wall -O2
++LDFLAGS=
++
+ RELEASECODE=$(shell grep '^<dt>' README.html | tail -1 | sed 's/.* release //; sx</a>.*$$xx')
+ BUILDDATE=$(shell date '+%Y-%m-%dT%H%M%S%Z')
+
+@@ -42,20 +46,19 @@
+ all2: package distrib
+
+ ada-readline-c.o: ada-readline-c.c
+- gcc -c -Wall -O2 $(TOPALDEBUG) ada-readline-c.c
++ $(CC) -c $(CFLAGS) $(TOPALDEBUG) ada-readline-c.c
+
+ ada-echo-c.o: ada-echo-c.c
+- gcc -c -Wall -O2 $(TOPALDEBUG) ada-echo-c.c
++ $(CC) -c $(CFLAGS) $(TOPALDEBUG) ada-echo-c.c
+
+ externals-c.o: externals-c.c
+- gcc -c -Wall -O2 $(TOPALDEBUG) externals-c.c
++ $(CC) -c $(CFLAGS) $(TOPALDEBUG) externals-c.c
+
+ mime-tool:
+- make -C MIME-tool
++ $(MAKE) -C MIME-tool
+
+ topal: $(TOPALDEPS)
+- gnatmake -gnatwa -gnato -O2 $(TOPALDEBUG) topal
+- -strip topal
++ gnatmake -gnatwa -gnato -O2 $(TOPALDEBUG) topal -largs "$(LDFLAGS)"
+
+ topal.gz: topal
+ gzip -c9 topal > topal.gz
+@@ -85,13 +88,13 @@
+ README.txt: README.html
+ lynx -dont_wrap_pre -underscore -nolist -dump README.html > README.txt
+
+-install: all
++install:
+ install -d $(INSTALLPATHBIN) $(INSTALLPATHDOC) $(INSTALLPATHMAN)/man1 $(INSTALLPATHPATCHES)
+- install -m 755 -s topal $(INSTALLPATHBIN)
+- install -m 644 README.html README.txt COPYING $(INSTALLPATHDOC)
++ install -m 755 topal $(INSTALLPATHBIN)
++ install -m 644 README.txt $(INSTALLPATHDOC)
+ install -m 644 topal.man $(INSTALLPATHMAN)/man1/topal.1
+- install -m 644 pine-*.patch alpine-*.patch alpine-*.patch-* $(INSTALLPATHPATCHES)
+- install -m 755 -s MIME-tool/mime-tool $(INSTALLPATHBIN)
++ install -m 644 alpine-*.patch alpine-*.patch-* $(INSTALLPATHPATCHES)
++ install -m 755 MIME-tool/mime-tool $(INSTALLPATHBIN)
+ install -m 644 MIME-tool/mime-tool.man $(INSTALLPATHMAN)/man1/mime-tool.1
+
+ clean: