summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-10-15 12:43:13 +0000
committerEray Aslan <eras@gentoo.org>2012-10-15 12:43:13 +0000
commit04d581fddf773efd3de643c98d7bd6f37e5e549c (patch)
tree4a37c1850e37071df88d9ef27b0b1ec7a7d04afe /net-mail/topal/topal-75.ebuild
parentAdd topal and chappa USE flags for use with mail-client/alpine - bug #391387.... (diff)
downloadgentoo-2-04d581fddf773efd3de643c98d7bd6f37e5e549c.tar.gz
gentoo-2-04d581fddf773efd3de643c98d7bd6f37e5e549c.tar.bz2
gentoo-2-04d581fddf773efd3de643c98d7bd6f37e5e549c.zip
Version bump
(Portage version: 2.2.0_alpha138/cvs/Linux x86_64, signed Manifest commit with key 0x586A3B1F)
Diffstat (limited to 'net-mail/topal/topal-75.ebuild')
-rw-r--r--net-mail/topal/topal-75.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-mail/topal/topal-75.ebuild b/net-mail/topal/topal-75.ebuild
new file mode 100644
index 000000000000..cbf4a1ed4821
--- /dev/null
+++ b/net-mail/topal/topal-75.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/topal/topal-75.ebuild,v 1.1 2012/10/15 12:43:13 eras Exp $
+
+EAPI=4
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Topal is a 'glue' program that links GnuPG and Pine/Alpine."
+HOMEPAGE="http://homepage.ntlworld.com/phil.brooke/topal/"
+SRC_URI="http://homepage.ntlworld.com/phil.brooke/topal/rel-${PV}/topal-package-${PV}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=">=app-crypt/gnupg-2.0.7-r1
+ || ( net-mail/metamail app-misc/run-mailcap )
+ || ( app-text/dos2unix app-text/hd2u )
+ sys-libs/ncurses
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ virtual/ada
+ doc? ( app-text/texlive )"
+
+src_prepare() {
+ rm "${S}"/MIME-tool/mime-tool || die
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+ use doc || sed -i -e '/pdflatex/s/^/#/' Makefile
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake install \
+ INSTALLPATH="${D}"/usr \
+ INSTALLPATHDOC="${D}/usr/share/doc/${PF}"
+ dohtml "${S}"/*.html
+}