summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-29 19:38:20 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-29 19:38:20 +0000
commitcc153508a747b098eb212d54273b9601aff98300 (patch)
tree0012004ef777acb041508f4c3f748e11c5dd5776 /net-mail/vmailmgr
parentUpdated version of powertweak. diff pulled from cvs on 10/29/2002. (diff)
downloadgentoo-2-cc153508a747b098eb212d54273b9601aff98300.tar.gz
gentoo-2-cc153508a747b098eb212d54273b9601aff98300.tar.bz2
gentoo-2-cc153508a747b098eb212d54273b9601aff98300.zip
Now inherits the gcc eclass and adds fixes appropriately for gcc3 or
gcc2 users.
Diffstat (limited to 'net-mail/vmailmgr')
-rw-r--r--net-mail/vmailmgr/ChangeLog7
-rw-r--r--net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild16
2 files changed, 19 insertions, 4 deletions
diff --git a/net-mail/vmailmgr/ChangeLog b/net-mail/vmailmgr/ChangeLog
index 453307fe510a..ea7f9ce11358 100644
--- a/net-mail/vmailmgr/ChangeLog
+++ b/net-mail/vmailmgr/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for net-mail/vmailmgr
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vmailmgr/ChangeLog,v 1.5 2002/09/30 12:50:18 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vmailmgr/ChangeLog,v 1.6 2002/10/29 19:38:20 raker Exp $
*vmailmgr-0.96.9-r1 (16 Apr 2002)
+ 29 Oct 2002; Nick Hadaway <raker@gentoo.org>
+ Now inheriting the gcc eclass so gcc2/gcc3 related fixes are only
+ applied if you are using the associated compiler. Please see bug
+ #8994
+
30 Sep 2002; Nick Hadaway <raker@gentoo.org>
vmailmgr-0.96.9-r1.ebuild :
Reverted back to make DESTDIR=${D} install instead of einstall.
diff --git a/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild b/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild
index 8d36d74126c5..45b56f5b7f0a 100644
--- a/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild
+++ b/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild,v 1.9 2002/10/04 21:22:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild,v 1.10 2002/10/29 19:38:20 raker Exp $
S=${WORKDIR}/${P}
@@ -17,9 +17,12 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc sparc64"
+inherit gcc
+
src_unpack() {
- unpack ${A} ; cd ${S}
+ unpack ${A}
+ cd ${S}
patch -p1 < ${FILESDIR}/${P}-gentoo-r1.diff || die
}
@@ -27,7 +30,14 @@ src_unpack() {
src_compile() {
export CXX=g++
- export LIBS="-lcrypt -lsupc++"
+
+ if [ "`gcc-major-version`" = "3" ]; then
+ export LIBS="-lcrypt -lsupc++"
+ fi
+
+ if [ "`gcc-major-version`" = "2" ]; then
+ export LIBS="-lcrypt"
+ fi
econf || die "./configure failed"