summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-10-16 17:01:17 +0000
committerMarinus Schraal <foser@gentoo.org>2002-10-16 17:01:17 +0000
commit134331fab7eea43e8b1345d594c3712008818f4e (patch)
tree441e3451b5596e8e00673afdf38219f34cb441de /net-mail
parentChanged keyword from "~x86" to "x86" cause all other versions are now (diff)
downloadgentoo-2-134331fab7eea43e8b1345d594c3712008818f4e.tar.gz
gentoo-2-134331fab7eea43e8b1345d594c3712008818f4e.tar.bz2
gentoo-2-134331fab7eea43e8b1345d594c3712008818f4e.zip
New bugfixing patch
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/evolution/ChangeLog11
-rw-r--r--net-mail/evolution/evolution-1.0.8-r2.ebuild205
-rw-r--r--net-mail/evolution/files/digest-evolution-1.0.8-r22
-rw-r--r--net-mail/evolution/files/evolution-1.0.8-mark-read-crash.patch48
4 files changed, 263 insertions, 3 deletions
diff --git a/net-mail/evolution/ChangeLog b/net-mail/evolution/ChangeLog
index 57afe85470cf..18d0b985c1de 100644
--- a/net-mail/evolution/ChangeLog
+++ b/net-mail/evolution/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for net-mail/evolution
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.24 2002/08/28 19:34:28 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.25 2002/10/16 17:01:17 foser Exp $
- 28 Aug 2002; Martin Schlemmer <azarah@gentoo.org> evolution-1.0.8-r1.ebuild :
- Add scrollkeeper to DEPEND.
+*evolution-1.0.8-r2 (16 Oct 2002)
+ 16 Oct 2002; foser <foser@gentoo.org> evolution-1.0.8-r2.ebuild :
+ Added a patch which hopefully fixes bug #5373
+
*evolution-1.0.8-r1 (20 Jul 2002)
+ 28 Aug 2002; Martin Schlemmer <azarah@gentoo.org> evolution-1.0.8-r1.ebuild :
+ Add scrollkeeper to DEPEND.
+
20 Aug 2002; Mark Guertin <gerk@gentoo.org> evolution-1.0.8-r1.ebuild :
Put scrollkepper within doc?() in DEPEND to prevent it from trying to pull
All the doc stuff, even with USE="-doc" (also a nasty bug in docbook-sgml-utils
diff --git a/net-mail/evolution/evolution-1.0.8-r2.ebuild b/net-mail/evolution/evolution-1.0.8-r2.ebuild
new file mode 100644
index 000000000000..9f9ab6316141
--- /dev/null
+++ b/net-mail/evolution/evolution-1.0.8-r2.ebuild
@@ -0,0 +1,205 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0.8-r2.ebuild,v 1.1 2002/10/16 17:01:17 foser Exp $
+
+IUSE="ssl nls mozilla ldap doc spell pda"
+
+#provide Xmake and Xemake
+
+inherit virtualx libtool
+
+DB3=db-3.1.17
+S=${WORKDIR}/${P}
+DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz
+ ftp://ftp.ximian.com/pub/source/${PN}/${P}.tar.gz
+ http://people.codefactory.se/~micke/${PN}/${P}.tar.gz
+ http://www.sleepycat.com/update/3.1.17/${DB3}.tar.gz"
+HOMEPAGE="http://www.ximian.com"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+RDEPEND="app-text/scrollkeeper
+ >=gnome-extra/bonobo-conf-0.14
+ >=gnome-base/bonobo-1.0.18
+ >=gnome-extra/gal-0.19.2
+ =gnome-base/gconf-1.0*
+ >=gnome-extra/gtkhtml-1.0.2-r2
+ >=gnome-base/oaf-0.6.7
+ >=gnome-base/ORBit-0.5.12
+ ( >=gnome-base/libglade-0.17-r1
+ <gnome-base/libglade-2.0 )
+ >=media-libs/gdk-pixbuf-0.14.0
+ >=dev-libs/libxml-1.8.16
+ =gnome-base/gnome-vfs-1.0*
+ >=gnome-base/gnome-print-0.34
+ >=dev-util/gob-1.0.12
+ doc? ( >=app-text/scrollkeeper-0.3.10-r1 )
+ ssl? ( >=net-www/mozilla-0.9.9 )
+ ldap? ( >=net-nds/openldap-2.0 )
+ mozilla? ( >=net-www/mozilla-0.9.9 )
+ pda? ( >=gnome-extra/gnome-pilot-0.1.61-r2 )
+ spell? ( >=app-text/gnome-spell-0.4.1-r2 )"
+
+# Added dependency on "dev-util/gob" this should fix a configure bug
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.4.1-r1
+ doc? ( dev-util/gtk-doc )
+ nls? ( >=dev-util/intltool-0.20
+ sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Fix the filter crash. This is actually a problem in the add and
+ # edit code. Mikael Hallendal originally fixed the bug in the add
+ # code. I added the fixes for the edit code.
+ #
+ # Martin Schlemmer (02 April 2002)
+ patch -p0 < ${FILESDIR}/evolution-1.0.3-filter-crash.patch || die
+ # add mandrake patches
+ # fix KDE detection
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-kde.patch || die
+ # call pilot conduit applet (not pilot link applet)
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-conduit.patch || die
+ # Patch from Preston A. Elder to resolve bug #1355
+ # fix a problem with literal strings and sertain IMAP servers
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-imapfix.diff || die
+ # Use DTD compliant scrollkeeper file (from Mandrake/CVS)
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.8-scrollkeeper.patch || die
+ # Patch for the mark read crash bug
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.8-mark-read-crash.patch || die
+
+ # lobtoolize to fix not all libs installing, and buggy .la files.
+ # also add the gnome-pilot.m4 to the macros directory to fix
+ # problems with the pilot conduct
+ cd ${S}
+ if [ ! -f ${S}/macros/gnome-pilot.m4 ]
+ then
+ cp ${FILESDIR}/gnome-pilot.m4 ${S}/macros || die
+ fi
+ elibtoolize
+ xml-i18n-toolize --force
+ aclocal -I macros
+ autoconf
+ automake --add-missing
+
+ (cd libical ; aclocal ; autoconf)
+
+ # Fix sandbox errors
+ cd ${S}/default_user
+ cp Makefile.in Makefile.in.orig
+ sed -e 's:-mkdir $(defaultdir:-mkdir $(DESTDIR)$(defaultdir:g' \
+ Makefile.in.orig > Makefile.in
+}
+
+src_compile() {
+
+ cd ${WORKDIR}/${DB3}/build_unix
+ ../dist/configure --prefix=${WORKDIR}/db3 || die
+
+ make || die
+ make prefix=${WORKDIR}/db3 install || die
+
+ cd ${S}
+
+ local myconf=""
+
+ MOZILLA=$MOZILLA_FIVE_HOME
+
+ if [ -n "`use pda`" ] ; then
+ myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
+ else
+ myconf="${myconf} --enable-pilot-conduits=no"
+ fi
+
+ if [ -n "`use ldap`" ] ; then
+ myconf="${myconf} --with-openldap=yes"
+ else
+ myconf="${myconf} --with-openldap=no"
+ fi
+
+ if [ -n "`use mozilla`" ] ; then
+ myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nspr-libs --without-nspr-includes"
+ fi
+
+ if [ -n "`use ssl`" ] ; then
+ myconf="${myconf} --with-nss-includes=${MOZILLA}/include/nss \
+ --with-nss-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nss-libs --without-nss-includes"
+ fi
+
+ # SSL needs NSPR libs ...
+ if [ -n "`use ssl`" ] && [ -z "`use mozilla`" ] ; then
+ myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA}"
+ fi
+
+ if [ -n "`use doc`" ] ; then
+ myconf="${myconf} --enable-gtk-doc"
+ else
+ myconf="${myconf} --disable-gtk-doc"
+ fi
+
+ if [ -z "`use nls`" ] ; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} -I/usr/include/libpisock"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-db3=${WORKDIR}/db3 \
+ --disable-python-bindings \
+ ${myconf} || die
+
+ #needs to be able to connect to X display to build.
+ Xemake || Xmake || die
+}
+
+src_install() {
+ cd omf-install
+ cp Makefile Makefile.old
+ sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
+ rm Makefile.old
+ cd ${S}
+
+ # Install with $DESTDIR, as in some rare cases $D gets hardcoded
+ # into the binaries (seems like a ccache problem at present),
+ # because everything is recompiled with the "new" PREFIX, if
+ # $DESTDIR is _not_ used.
+ make DESTDIR=${D} \
+ prefix=/usr \
+ mandir=/usr/share/man \
+ infodir=/usr/share/info \
+ datadir=/usr/share \
+ sysconfdir=/etc \
+ localstatedir=/var/lib \
+ KDE_APPLNK_DIR=/usr/share/applnk \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog HACKING MAINTAINERS
+ dodoc NEWS README
+}
+
+pkg_postinst() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
+pkg_postrm() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
diff --git a/net-mail/evolution/files/digest-evolution-1.0.8-r2 b/net-mail/evolution/files/digest-evolution-1.0.8-r2
new file mode 100644
index 000000000000..a0cb8c572d95
--- /dev/null
+++ b/net-mail/evolution/files/digest-evolution-1.0.8-r2
@@ -0,0 +1,2 @@
+MD5 024e62b7cd37315d40b16d76b072e59d evolution-1.0.8.tar.gz 13929927
+MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1954117
diff --git a/net-mail/evolution/files/evolution-1.0.8-mark-read-crash.patch b/net-mail/evolution/files/evolution-1.0.8-mark-read-crash.patch
new file mode 100644
index 000000000000..a3746bb4a4ce
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.0.8-mark-read-crash.patch
@@ -0,0 +1,48 @@
+--- evolution-1.0.8/mail/folder-browser.c.stackcorrupt Mon Sep 2 15:30:46 2002
++++ evolution-1.0.8/mail/folder-browser.c Mon Sep 2 15:31:04 2002
+@@ -1341,6 +1341,30 @@
+ message_list_hide_add(ml, "(match-all (system-flag \"seen\"))", ML_HIDE_SAME, ML_HIDE_SAME);
+ }
+
++static void
++mark_as_seen_cb (GtkWidget *widget, FolderBrowser *fb)
++{
++ mark_as_seen (NULL, fb, NULL);
++}
++
++static void
++mark_as_unseen_cb (GtkWidget *widget, FolderBrowser *fb)
++{
++ mark_as_unseen (NULL, fb, NULL);
++}
++
++static void
++mark_as_important_cb (GtkWidget *widget, FolderBrowser *fb)
++{
++ mark_as_important (NULL, fb, NULL);
++}
++
++static void
++mark_as_unimportant_cb (GtkWidget *widget, FolderBrowser *fb)
++{
++ mark_as_unimportant (NULL, fb, NULL);
++}
++
+ /* dum de dum, about the 3rd copy of this function throughout the mailer/camel */
+ static const char *
+ strip_re(const char *subject)
+@@ -1456,10 +1480,10 @@
+ { N_("Reply to _All"), NULL, GTK_SIGNAL_FUNC (reply_to_all), NULL, 0 },
+ { N_("_Forward"), NULL, GTK_SIGNAL_FUNC (forward), NULL, 0 },
+ { "", NULL, (NULL), NULL, 0 },
+- { N_("Mar_k as Read"), NULL, GTK_SIGNAL_FUNC (mark_as_seen), NULL, CAN_MARK_READ },
+- { N_("Mark as U_nread"), NULL, GTK_SIGNAL_FUNC (mark_as_unseen), NULL, CAN_MARK_UNREAD },
+- { N_("Mark as _Important"), NULL, GTK_SIGNAL_FUNC (mark_as_important), NULL, CAN_MARK_IMPORTANT },
+- { N_("Mark as Unim_portant"), NULL, GTK_SIGNAL_FUNC (mark_as_unimportant), NULL, CAN_MARK_UNIMPORTANT },
++ { N_("Mar_k as Read"), NULL, GTK_SIGNAL_FUNC (mark_as_seen_cb), NULL, CAN_MARK_READ },
++ { N_("Mark as U_nread"), NULL, GTK_SIGNAL_FUNC (mark_as_unseen_cb), NULL, CAN_MARK_UNREAD },
++ { N_("Mark as _Important"), NULL, GTK_SIGNAL_FUNC (mark_as_important_cb), NULL, CAN_MARK_IMPORTANT },
++ { N_("Mark as Unim_portant"), NULL, GTK_SIGNAL_FUNC (mark_as_unimportant_cb), NULL, CAN_MARK_UNIMPORTANT },
+
+ E_POPUP_SEPARATOR,
+