summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-03 09:27:07 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-03 09:27:07 +0000
commit23365af8ebe9ccdbb99839900ee5dd3cd01a0d6f (patch)
tree2d013d5eb4d124482d4545763a1535afde822a90 /net-mail
parentversion bump (diff)
downloadgentoo-2-23365af8ebe9ccdbb99839900ee5dd3cd01a0d6f.tar.gz
gentoo-2-23365af8ebe9ccdbb99839900ee5dd3cd01a0d6f.tar.bz2
gentoo-2-23365af8ebe9ccdbb99839900ee5dd3cd01a0d6f.zip
New pine ebuild. No maildir support patched in yet. Includes Eduardo
Chappa's patch collection.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/pine/ChangeLog9
-rw-r--r--net-mail/pine/files/digest-pine-4.512
-rw-r--r--net-mail/pine/pine-4.51.ebuild124
3 files changed, 134 insertions, 1 deletions
diff --git a/net-mail/pine/ChangeLog b/net-mail/pine/ChangeLog
index 12748c3367c5..f5292310d86b 100644
--- a/net-mail/pine/ChangeLog
+++ b/net-mail/pine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/pine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.16 2002/12/13 11:00:07 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.17 2003/01/03 09:27:07 raker Exp $
+
+*pine-4.51 (03 Jan 2002)
+
+ 03 Jan 2002; Nick Hadaway <raker@gentoo.org> pine-4.51.ebuild,
+ files/digest-pine-4.51 :
+ Version bump. No maildir patch yet. Includes the entire Eduardo
+ Chappa patch collection for 4.51.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-mail/pine/files/digest-pine-4.51 b/net-mail/pine/files/digest-pine-4.51
new file mode 100644
index 000000000000..646843821cd1
--- /dev/null
+++ b/net-mail/pine/files/digest-pine-4.51
@@ -0,0 +1,2 @@
+MD5 4ce7c7776b56177852975a2ad19f7202 pine4.51.tar.gz 3778582
+MD5 eb056b8f1db71ee86efb0847f1331b2a all.patch.gz 85838
diff --git a/net-mail/pine/pine-4.51.ebuild b/net-mail/pine/pine-4.51.ebuild
new file mode 100644
index 000000000000..f41526537ed2
--- /dev/null
+++ b/net-mail/pine/pine-4.51.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/pine-4.51.ebuild,v 1.1 2003/01/03 09:27:07 raker Exp $
+
+IUSE="ssl ldap"
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="A tool for reading, sending and managing electronic messages."
+SRC_URI="ftp://ftp.cac.washington.edu/${PN}/${PN}${PV}.tar.gz
+ http://www.math.washington.edu/~chappa/pine/patches/pine4.51/all.patch.gz"
+HOMEPAGE="http://www.washington.edu/pine/
+ http://www.math.washington.edu/~chappa/pine/patches/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/pam-0.72
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )"
+
+SLOT="0"
+LICENSE="PICO"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+inherit eutils
+
+src_unpack() {
+ unpack ${PN}${PV}.tar.gz
+ cd ${S}
+
+ epatch ${DISTDIR}/all.patch.gz
+
+ epatch ${FILESDIR}/pine-4.21-fixhome.patch
+
+ epatch ${FILESDIR}/imap-4.7c2-flock.patch
+ cp ${FILESDIR}/flock.c ${S}/imap/src/osdep/unix
+
+ if [ "`use ldap`" ] ; then
+ # link to shared ldap libs instead of static
+ epatch ${FILESDIR}/pine-4.30-ldap.patch
+ mkdir ${S}/ldap
+ ln -s /usr/lib ${S}/ldap/libraries
+ ln -s /usr/include ${S}/ldap/include
+ fi
+
+ epatch ${FILESDIR}/pine-4.40-boguswarning.patch
+
+ epatch ${FILESDIR}/pine-4.31-segfix.patch
+
+ epatch ${FILESDIR}/pine-4.40-lockfile-perm.patch
+
+ epatch ${FILESDIR}/imap-2000-time.patch
+
+ epatch ${FILESDIR}/pine-4.33-whitespace.patch
+
+ if [ -n "$DEBUGBUILD" ]; then
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS} -g -DDEBUG -DDEBUGJOURNAL:" \
+ < makefile.orig > makefile.lnx
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS} -g -DDEBUG:" \
+ < makefile.orig > makefile.lnx
+ else
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS}:" \
+ < makefile.orig > makefile.lnx
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+ fi
+}
+
+src_compile() {
+ BUILDOPTS=""
+ if [ "`use ssl`" ]
+ then
+ BUILDOPTS="${BUILDOPTS} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
+ cd ${S}/imap/src/osdep/unix
+ cp Makefile Makefile.orig
+ sed \
+ -e "s:\$(SSLDIR)/certs:/etc/ssl/certs:" \
+ -e "s:\$(SSLCERTS):/etc/ssl/certs:" \
+ -e "s:-I\$(SSLINCLUDE) ::" \
+ < Makefile.orig > Makefile
+ cd ${S}
+ else
+ BUILDOPTS="${BUILDOPTS} NOSSL"
+ fi
+ if [ "`use ldap`" ]
+ then
+ ./contrib/ldap-setup lnp lnp
+ BUILDOPTS="${BUILDOPTS} LDAPCFLAGS=-DENABLE_LDAP"
+ else
+ BUILDOPTS="${BUILDOPTS} NOLDAP"
+ fi
+
+ ./build ${BUILDOPTS} lnp || die
+}
+
+src_install() {
+ into /usr
+ dobin bin/pine bin/pico bin/pilot bin/mtest bin/rpdump bin/rpload
+
+ doman doc/pine.1 doc/pico.1 doc/pilot.1 doc/rpdump.1 doc/rpload.1
+
+ insinto /etc
+ doins doc/mime.types
+ donewins doc/mailcap.unx mailcap
+
+ dodoc CPYRIGHT README doc/brochure.txt doc/tech-notes.txt
+ use mbox || dodoc README.maildir
+
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/FAQ imap/docs/RELNOTES
+
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt
+
+ docinto html/tech-notes
+ dodoc doc/tech-notes/*.html
+}
+