summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-06-22 10:59:09 +0000
committerEray Aslan <eras@gentoo.org>2011-06-22 10:59:09 +0000
commit47b05fc513e42bc6fd24236620980dcfcf6fa073 (patch)
treeffdd4407e108b75cad5d9d22df33c517578905f5 /net-mail
parentClean up FILESDIR (diff)
downloadgentoo-2-47b05fc513e42bc6fd24236620980dcfcf6fa073.tar.gz
gentoo-2-47b05fc513e42bc6fd24236620980dcfcf6fa073.tar.bz2
gentoo-2-47b05fc513e42bc6fd24236620980dcfcf6fa073.zip
version bump
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/cyrus-imap-admin/ChangeLog8
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.9.ebuild64
-rw-r--r--net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.4.9-ldflags.patch56
3 files changed, 127 insertions, 1 deletions
diff --git a/net-mail/cyrus-imap-admin/ChangeLog b/net-mail/cyrus-imap-admin/ChangeLog
index 2d9d74c06b48..272970cf6ad5 100644
--- a/net-mail/cyrus-imap-admin/ChangeLog
+++ b/net-mail/cyrus-imap-admin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/cyrus-imap-admin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.100 2011/06/22 10:56:40 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.101 2011/06/22 10:59:09 eras Exp $
+
+*cyrus-imap-admin-2.4.9 (22 Jun 2011)
+
+ 22 Jun 2011; Eray Aslan <eras@gentoo.org> +cyrus-imap-admin-2.4.9.ebuild,
+ +files/cyrus-imap-admin-2.4.9-ldflags.patch:
+ Version bump
22 Jun 2011; Eray Aslan <eras@gentoo.org>
-files/cyrus-imap-admin-2.2-fPIC.patch,
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.9.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.9.ebuild
new file mode 100644
index 000000000000..2e180588436a
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.9.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.9.ebuild,v 1.1 2011/06/22 10:59:09 eras Exp $
+
+EAPI=4
+
+inherit eutils perl-app db-use
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Utilities and Perl modules to administer a Cyrus IMAP server."
+HOMEPAGE="http://www.cyrusimap.org/"
+SRC_URI="ftp://ftp.cyrusimap.org/cyrus-imapd/cyrus-imapd-${MY_PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="berkdb kerberos ssl"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ >=dev-libs/cyrus-sasl-2.1.13
+ dev-perl/Term-ReadLine-Perl
+ dev-perl/TermReadKey
+ berkdb? ( >=sys-libs/db-3.2 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( virtual/krb5 )"
+
+DEPEND="$RDEPEND"
+
+S="${WORKDIR}/cyrus-imapd-${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+}
+
+src_configure() {
+ local myconf
+ if use berkdb ; then
+ myconf="--with-bdb-incdir=$(db_includedir)"
+ fi
+ econf \
+ --disable-server \
+ --enable-murder \
+ --enable-netscapehack \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --with-perl=/usr/bin/perl \
+ --without-krb \
+ --without-krbdes \
+ $(use_with berkdb bdb) \
+ $(use_enable kerberos gssapi) \
+ $(use_with ssl openssl) \
+ ${myconf}
+}
+
+src_compile() {
+ emake -C "${S}/lib" all || die "compile problem"
+ emake -C "${S}/perl" all || die "compile problem"
+}
+
+src_install () {
+ emake -C "${S}/perl" DESTDIR="${D}" INSTALLDIRS=vendor install || die "install problem"
+ fixlocalpod # bug #98122
+}
diff --git a/net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.4.9-ldflags.patch b/net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.4.9-ldflags.patch
new file mode 100644
index 000000000000..a05941408250
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/files/cyrus-imap-admin-2.4.9-ldflags.patch
@@ -0,0 +1,56 @@
+--- perl/Makefile.in 2011-06-21 22:50:39.000000000 +0300
++++ perl/Makefile.in 2011-06-22 12:42:04.000000000 +0300
+@@ -74,6 +74,7 @@
+ cyrus_prefix = @cyrus_prefix@
+
+ CC = @CC@
++LDFLAGS = @LDFLAGS@
+ PLMAKE = imap/Makefile
+
+ all::
+@@ -83,6 +84,7 @@
+ if [ -f Makefile.PL -a ! -f Makefile ]; then \
+ LIB_RT="$(LIB_RT)" \
+ ZLIB="$(ZLIB)" \
++ LDDLFLAGS="-shared $(LDFLAGS)" \
+ BDB_LIB="$(BDB_LIB)" BDB_INC="$(BDB_INC)" \
+ OPENSSL_LIB="$(OPENSSL_LIB)" OPENSSL_INC="$(OPENSSL_INC)" \
+ SASL_LIB="$(SASL_LIB)" SASL_INC="$(SASL_INC)" CC="$(CC)" \
+--- perl/imap/Makefile.PL 2011-06-21 22:50:39.000000000 +0300
++++ perl/imap/Makefile.PL 2011-06-22 12:42:22.000000000 +0300
+@@ -53,6 +53,8 @@
+ my $LIB_RT = $ENV{LIB_RT};
+ my $ZLIB = $ENV{ZLIB};
+
++my $LDDLFLAGS = $ENV{LDDLFLAGS};
++
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+ # the contents of the Makefile that is written.
+ $libs = "-lcyrus";
+@@ -75,6 +77,7 @@
+ 'OBJECT' => 'IMAP.o',
+ 'MYEXTLIB' => '../../lib/libcyrus.a ../../lib/libcyrus_min.a',
+ 'LIBS' => ["$BDB_LIB $SASL_LIB $OPENSSL_LIB $LIB_RT $ZLIB -lssl -lcrypto"],
++ 'LDDLFLAGS' => "$LDDLFLAGS",
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "-I../../lib -I../.. -I../../com_err/et $SASL_INC $OPENSSL_INC",
+ 'EXE_FILES' => [cyradm],
+--- perl/sieve/managesieve/Makefile.PL 2011-06-21 22:50:39.000000000 +0300
++++ perl/sieve/managesieve/Makefile.PL 2011-06-22 13:13:04.000000000 +0300
+@@ -53,6 +53,8 @@
+ my $LIB_RT = $ENV{LIB_RT};
+ my $ZLIB = $ENV{ZLIB};
+
++my $LDDLFLAGS = $ENV{LDFLAGS};
++
+ $libs = "-lcyrus";
+
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+@@ -63,6 +65,7 @@
+ 'VERSION_FROM' => 'managesieve.pm', # finds $VERSION
+ 'MYEXTLIB' => '../lib/isieve.o ../lib/lex.o ../lib/mystring.o ../lib/request.o ../../../lib/libcyrus.a ../../../lib/libcyrus_min.a',
+ 'LIBS' => ["$BDB_LIB $SASL_LIB $OPENSSL_LIB $LIB_RT $ZLIB -lssl -lcrypto"],
++ 'LDDLFLAGS' => "-shared $LDDLFLAGS",
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "-I../lib/ -I../../../lib/ $SASL_INC $OPENSSL_INC",
+ );