summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-10 00:33:37 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-10 00:33:37 +0000
commitb17adae436755d3546a674962724f8537594e1fe (patch)
treeaa58cb5b4574df4e1dc0c00a8d030663a78610e8 /net-mail
parentNew ebuild for mate-extra/mate-screensaver, replaces xscreensaver, integratin... (diff)
downloadgentoo-2-b17adae436755d3546a674962724f8537594e1fe.tar.gz
gentoo-2-b17adae436755d3546a674962724f8537594e1fe.tar.bz2
gentoo-2-b17adae436755d3546a674962724f8537594e1fe.zip
Fix by Martin von Gagern for building w/readline-6.3 #503954.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailutils/ChangeLog8
-rw-r--r--net-mail/mailutils/files/mailutils-2.99.98-readline-6.3.patch39
-rw-r--r--net-mail/mailutils/mailutils-2.99.98.ebuild5
3 files changed, 48 insertions, 4 deletions
diff --git a/net-mail/mailutils/ChangeLog b/net-mail/mailutils/ChangeLog
index 96279e7577f5..15c222ffdd60 100644
--- a/net-mail/mailutils/ChangeLog
+++ b/net-mail/mailutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/mailutils
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/ChangeLog,v 1.68 2013/10/28 13:27:50 eras Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/ChangeLog,v 1.69 2014/03/10 00:33:37 vapier Exp $
+
+ 10 Mar 2014; Mike Frysinger <vapier@gentoo.org>
+ +files/mailutils-2.99.98-readline-6.3.patch, mailutils-2.99.98.ebuild:
+ Fix by Martin von Gagern for building w/readline-6.3 #503954.
28 Oct 2013; Eray Aslan <eras@gentoo.org>
-files/mailutils-2.99.97-gsasl.patch, -mailutils-2.99.97.ebuild:
diff --git a/net-mail/mailutils/files/mailutils-2.99.98-readline-6.3.patch b/net-mail/mailutils/files/mailutils-2.99.98-readline-6.3.patch
new file mode 100644
index 000000000000..de9a487aaaf3
--- /dev/null
+++ b/net-mail/mailutils/files/mailutils-2.99.98-readline-6.3.patch
@@ -0,0 +1,39 @@
+https://bugs.gentoo.org/503954
+
+fix build w/readline-6.3
+
+patch by Martin von Gagern
+
+--- mailutils-2.99.98/mu/shell.c
++++ mailutils-2.99.98/mu/shell.c
+@@ -336,7 +336,7 @@ mutool_initialize_readline (const char *
+ {
+ /* Allow conditional parsing of the ~/.inputrc file. */
+ rl_readline_name = (char *) name;
+- rl_attempted_completion_function = (CPPFunction *) shell_completion;
++ rl_attempted_completion_function = shell_completion;
+ rl_getc_function = _shell_getc;
+ read_history (get_history_file_name ());
+ }
+--- mailutils-2.99.98/mail/mailline.c
++++ mailutils-2.99.98/mail/mailline.c
+@@ -93,7 +93,7 @@ ml_readline_init ()
+
+ #ifdef WITH_READLINE
+ rl_readline_name = "mail";
+- rl_attempted_completion_function = (CPPFunction*)ml_command_completion;
++ rl_attempted_completion_function = ml_command_completion;
+ rl_getc_function = ml_getc;
+ #endif
+ #ifdef HAVE_SIGACTION
+--- mailutils-2.99.98/examples/nntpclient.c
++++ mailutils-2.99.98/examples/nntpclient.c
+@@ -163,7 +163,7 @@ initialize_readline ()
+ rl_readline_name = (char *) "nntp";
+
+ /* Tell the completer that we want a crack first. */
+- rl_attempted_completion_function = (CPPFunction *) nntp_completion;
++ rl_attempted_completion_function = nntp_completion;
+ }
+
+ /* Attempt to complete on the contents of TEXT. START and END bound the
diff --git a/net-mail/mailutils/mailutils-2.99.98.ebuild b/net-mail/mailutils/mailutils-2.99.98.ebuild
index f0c089fc754c..b664ed1f7247 100644
--- a/net-mail/mailutils/mailutils-2.99.98.ebuild
+++ b/net-mail/mailutils/mailutils-2.99.98.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/mailutils-2.99.98.ebuild,v 1.3 2013/09/22 06:50:40 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/mailutils-2.99.98.ebuild,v 1.4 2014/03/10 00:33:37 vapier Exp $
EAPI=5
PYTHON_DEPEND="python? 2"
@@ -55,6 +55,7 @@ src_prepare() {
# Disable bytecompilation of Python modules.
echo "#!/bin/sh" > build-aux/py-compile
epatch "${FILESDIR}/${P}-array_bounds.patch"
+ epatch "${FILESDIR}/${P}-readline-6.3.patch" #503954
}
src_configure() {