summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-01-16 16:53:00 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-01-16 16:53:00 +0000
commit31290199d7d4549771c3b13d946f97da59bb0060 (patch)
tree7e43a7cbf3802abe7eead2d29d999a21c35ef577 /net-misc/arm
parentRestrict Jython ABIs. (diff)
downloadgentoo-2-31290199d7d4549771c3b13d946f97da59bb0060.tar.gz
gentoo-2-31290199d7d4549771c3b13d946f97da59bb0060.tar.bz2
gentoo-2-31290199d7d4549771c3b13d946f97da59bb0060.zip
Hotfix version bump with --docPath fix
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/arm')
-rw-r--r--net-misc/arm/ChangeLog7
-rw-r--r--net-misc/arm/arm-1.4.1.3.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/net-misc/arm/ChangeLog b/net-misc/arm/ChangeLog
index a4cf8bd548ed..41b1b401263a 100644
--- a/net-misc/arm/ChangeLog
+++ b/net-misc/arm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/arm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/ChangeLog,v 1.5 2011/01/09 02:02:06 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/ChangeLog,v 1.6 2011/01/16 16:53:00 blueness Exp $
+
+*arm-1.4.1.3 (16 Jan 2011)
+
+ 16 Jan 2011; Anthony G. Basile <blueness@gentoo.org> +arm-1.4.1.3.ebuild:
+ Hotfix version bump with --docPath fix
*arm-1.4.1.0 (09 Jan 2011)
diff --git a/net-misc/arm/arm-1.4.1.3.ebuild b/net-misc/arm/arm-1.4.1.3.ebuild
new file mode 100644
index 000000000000..229b1c1eb3e6
--- /dev/null
+++ b/net-misc/arm/arm-1.4.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arm/arm-1.4.1.3.ebuild,v 1.1 2011/01/16 16:53:00 blueness Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="ncurses"
+
+inherit python distutils
+
+DESCRIPTION="A ncurses-based status monitor for Tor relays"
+HOMEPAGE="http://www.atagar.com/arm/"
+SRC_URI="http://www.atagar.com/arm/resources/static/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-misc/tor-0.2.1.27"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install --docPath "${EPREFIX}"/usr/share/doc/${PF}
+}
+
+pkg_postinst() {
+ elog "Some graphing data issues have been noted in testing"
+ elog "when run as root. It is not recommended to run arm as"
+ elog "root until those issues have been isolated and fixed."
+ elog
+ elog "Trouble with graphs under app-misc/screen? Try:"
+ elog 'TERM="rxvt-unicode" arm'
+}