summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-08-27 21:50:26 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-08-27 21:50:26 +0000
commit60e564845e84bc4fe850ade8825d69f4e73715d8 (patch)
treec6592852275cc4e1060b949647f4a456f0ddb4f2 /net-misc/asterisk-app_notify
parentFix use of install in patch. (diff)
downloadgentoo-2-60e564845e84bc4fe850ade8825d69f4e73715d8.tar.gz
gentoo-2-60e564845e84bc4fe850ade8825d69f4e73715d8.tar.bz2
gentoo-2-60e564845e84bc4fe850ade8825d69f4e73715d8.zip
Initial import.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-misc/asterisk-app_notify')
-rw-r--r--net-misc/asterisk-app_notify/ChangeLog11
-rw-r--r--net-misc/asterisk-app_notify/Manifest3
-rw-r--r--net-misc/asterisk-app_notify/asterisk-app_notify-0.9.ebuild39
-rw-r--r--net-misc/asterisk-app_notify/files/app_notify-0.9-astcfg.diff35
-rw-r--r--net-misc/asterisk-app_notify/files/digest-asterisk-app_notify-0.91
-rw-r--r--net-misc/asterisk-app_notify/metadata.xml8
6 files changed, 97 insertions, 0 deletions
diff --git a/net-misc/asterisk-app_notify/ChangeLog b/net-misc/asterisk-app_notify/ChangeLog
new file mode 100644
index 000000000000..f438b8da6faf
--- /dev/null
+++ b/net-misc/asterisk-app_notify/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/asterisk-app_notify
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_notify/ChangeLog,v 1.1 2005/08/27 21:50:26 stkn Exp $
+
+*asterisk-app_notify-0.9 (27 Aug 2005)
+
+ 27 Aug 2005; Stefan Knoblich <stkn@gentoo.org>
+ +files/app_notify-0.9-astcfg.diff, +metadata.xml,
+ +asterisk-app_notify-0.9.ebuild:
+ Initial import.
+
diff --git a/net-misc/asterisk-app_notify/Manifest b/net-misc/asterisk-app_notify/Manifest
new file mode 100644
index 000000000000..4a7ecf933dcc
--- /dev/null
+++ b/net-misc/asterisk-app_notify/Manifest
@@ -0,0 +1,3 @@
+MD5 7e4a6bc7852f5c3401a1953f076c3d4a asterisk-app_notify-0.9.ebuild 846
+MD5 23f907476297db3a183a156b1b391c40 files/digest-asterisk-app_notify-0.9 61
+MD5 e9feeca2b8769b6a47354d06f0598ede files/app_notify-0.9-astcfg.diff 853
diff --git a/net-misc/asterisk-app_notify/asterisk-app_notify-0.9.ebuild b/net-misc/asterisk-app_notify/asterisk-app_notify-0.9.ebuild
new file mode 100644
index 000000000000..bb652982ede2
--- /dev/null
+++ b/net-misc/asterisk-app_notify/asterisk-app_notify-0.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_notify/asterisk-app_notify-0.9.ebuild,v 1.1 2005/08/27 21:50:26 stkn Exp $
+
+inherit eutils
+
+MY_PN="app_notify"
+
+DESCRIPTION="Asterisk application plugin to notify users"
+HOMEPAGE="http://www.mezzo.net/asterisk/"
+SRC_URI="http://www.mezzo.net/asterisk/${MY_PN}-${PV}.tgz"
+
+IUSE=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=net-misc/asterisk-1.0.7-r1"
+
+S=${WORKDIR}/${MY_PN}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # use asterisk-config...
+ epatch ${FILESDIR}/${MY_PN}-0.9-astcfg.diff
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc README sampleClient.c
+}
diff --git a/net-misc/asterisk-app_notify/files/app_notify-0.9-astcfg.diff b/net-misc/asterisk-app_notify/files/app_notify-0.9-astcfg.diff
new file mode 100644
index 000000000000..23a5c224d2a6
--- /dev/null
+++ b/net-misc/asterisk-app_notify/files/app_notify-0.9-astcfg.diff
@@ -0,0 +1,35 @@
+--- app_notify/Makefile.orig 2005-08-27 23:39:30.000000000 +0000
++++ app_notify/Makefile 2005-08-27 23:41:10.000000000 +0000
+@@ -8,15 +8,13 @@
+
+ NAME=app_notify
+
+-CFLAGS=-g -Wall -D_REENTRANT -D_GNU_SOURCE -fPIC
++DESTDIR=
++
++CFLAGS+=-g -Wall -D_REENTRANT -D_GNU_SOURCE -fPIC
+ LIBS=
+ RES=$(NAME).so
+
+-ifeq (${OSARCH},Darwin)
+-SOLINK=-dynamic -bundle -undefined suppress -force_flat_namespace
+-else
+-SOLINK=-shared -Xlinker -x
+-endif
++SOLINK=$(shell /usr/bin/asterisk-config --solink)
+
+ MODULES_DIR=/usr/lib/asterisk/modules
+
+@@ -28,10 +26,8 @@
+ clean:
+ rm -f $(NAME).o $(NAME).so notifyClient.o notifyClient sampleClient
+
+-install: all
+- if [ -f $(NAME).so ]; then \
+- install -m 755 $(NAME).so $(MODULES_DIR) ; \
+- fi
++install:
++ install -D -m 755 $(NAME).so $(DESTDIR)$(MODULES_DIR)/$(NAME).so
+
+ reload: install
+ asterisk -rx "unload ${RES}"
diff --git a/net-misc/asterisk-app_notify/files/digest-asterisk-app_notify-0.9 b/net-misc/asterisk-app_notify/files/digest-asterisk-app_notify-0.9
new file mode 100644
index 000000000000..b7cf863a2c1b
--- /dev/null
+++ b/net-misc/asterisk-app_notify/files/digest-asterisk-app_notify-0.9
@@ -0,0 +1 @@
+MD5 1a64ee5c64bd268a2230e2e371d31760 app_notify-0.9.tgz 3028
diff --git a/net-misc/asterisk-app_notify/metadata.xml b/net-misc/asterisk-app_notify/metadata.xml
new file mode 100644
index 000000000000..a3cddc42f9cc
--- /dev/null
+++ b/net-misc/asterisk-app_notify/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>voip</herd>
+<maintainer>
+ <email>stkn@gentoo.org</email>
+</maintainer>
+</pkgmetadata>