summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-06-25 15:14:09 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-06-25 15:14:09 +0000
commitea16bd2f51516a303278a45a66e2f495d8b1a81a (patch)
tree481e2d0bbd8ad15098a427ab2d5c7a3ee5472d82 /net-misc/asterisk/files
parentStable on amd64 wrt bug #325507 (diff)
downloadgentoo-2-ea16bd2f51516a303278a45a66e2f495d8b1a81a.tar.gz
gentoo-2-ea16bd2f51516a303278a45a66e2f495d8b1a81a.tar.bz2
gentoo-2-ea16bd2f51516a303278a45a66e2f495d8b1a81a.zip
New upstream version. A DTMF crasher has been fixed, several off-by-one errors have been addressed. Also the build system has seen some improvements. With thanks to Oliver Jacksch for a rebased patch, closes bug #324657. Research by Jaco Kroon closes bug #325231 by Kerin Millar. Cleaned up old ebuilds.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/asterisk/files')
-rw-r--r--net-misc/asterisk/files/1.6.2/asterisk-1.6.2.9-gsm-pic.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.9-gsm-pic.patch b/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.9-gsm-pic.patch
new file mode 100644
index 000000000000..df85382f0df0
--- /dev/null
+++ b/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.9-gsm-pic.patch
@@ -0,0 +1,64 @@
+diff -uNr asterisk-1.6.2.9.ORIG/codecs/gsm/Makefile asterisk-1.6.2.9/codecs/gsm/Makefile
+--- asterisk-1.6.2.9.ORIG/codecs/gsm/Makefile 2010-03-09 21:39:20.000000000 +0100
++++ asterisk-1.6.2.9/codecs/gsm/Makefile 2010-03-09 21:39:20.000000000 +0100
+@@ -37,30 +37,6 @@
+ ######### ppro's, etc, as well as the AMD K6 and K7. The compile will
+ ######### probably require gcc.
+
+-ifeq (,$(findstring $(OSARCH),Darwin SunOS))
+- ifeq (,$(strip $(findstring $(PROC) ,"x86_64 amd64 ultrasparc sparc64 arm armv5b armeb ppc powerpc ppc64 ia64 s390 bfin mipsel mips ")))
+- ifeq (,$(strip $(findstring $(shell uname -m) ,"ppc ppc64 alpha armv4l s390 ")))
+- OPTIMIZE+=-march=$(PROC)
+- endif
+- endif
+-else
+- ifneq (,$(findstring $(OSARCH),Darwin))
+- ifeq ($(shell /usr/bin/sw_vers -productVersion | cut -c1-4),10.6)
+- # Snow Leopard reports i386, even though it's really x86_64
+- OPTIMIZE+=-mtune=native
+- endif
+- endif
+-endif
+-
+-#The problem with sparc is the best stuff is in newer versions of gcc (post 3.0) only.
+-#This works for even old (2.96) versions of gcc and provides a small boost either way.
+-#A ultrasparc cpu is really v9 but the stock debian stable 3.0 gcc doesn't support it.
+-#So we go lowest common available by gcc and go a step down, still a step up from
+-#the default as we now have a better instruction set to work with. - Belgarath
+-ifeq ($(PROC),ultrasparc)
+-OPTIMIZE+=-mcpu=v8 -mtune=$(PROC) -O3
+-endif
+-
+ PG =
+ #PG = -g -pg
+ ######### Profiling flags. If you don't know what that means, leave it blank.
+@@ -215,11 +191,9 @@
+ # XXX Keep a space after each findstring argument
+ # XXX should merge with GSM_OBJECTS
+ ifeq ($(OSARCH),linux-gnu)
+-ifeq (,$(findstring $(shell uname -m) , x86_64 amd64 ppc ppc64 alpha armv4l sparc64 parisc s390 ))
+-ifeq (,$(findstring $(PROC) , arm armv5b armeb powerpc ia64 s390 bfin mipsel mips ))
+-GSM_SOURCES+= $(SRC)/k6opt.s
+-endif
+-endif
++ ifneq ($(K6OPT),)
++ GSM_SOURCES+= $(SRC)/k6opt.s
++ endif
+ endif
+
+ TOAST_SOURCES = $(SRC)/toast.c \
+@@ -267,11 +241,9 @@
+ $(SRC)/table.o
+
+ ifeq ($(OSARCH),linux-gnu)
+-ifeq (,$(findstring $(shell uname -m) , x86_64 amd64 ppc ppc64 alpha armv4l sparc64 parisc ))
+-ifeq (,$(findstring $(PROC) , arm armv5b armeb powerpc ia64 bfin mipsel mips ))
+-GSM_OBJECTS+= $(SRC)/k6opt.o
+-endif
+-endif
++ ifneq ($(K6OPT),)
++ GSM_OBJECTS+= $(SRC)/k6opt.o
++ endif
+ endif
+
+ TOAST_OBJECTS = $(SRC)/toast.o \