summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-06-01 02:24:09 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-06-01 02:24:09 +0000
commit9f59e1fc337db535fbb4f02c6de8882b20d4ba18 (patch)
treea384ea1480f8016ea6ce08609ab0c183e8cc5c59 /net-misc/axel/axel-1.0a.ebuild
parentremoving this as it seems masking it isn't enough to avoid bugreports from ea... (diff)
downloadgentoo-2-9f59e1fc337db535fbb4f02c6de8882b20d4ba18.tar.gz
gentoo-2-9f59e1fc337db535fbb4f02c6de8882b20d4ba18.tar.bz2
gentoo-2-9f59e1fc337db535fbb4f02c6de8882b20d4ba18.zip
Package net-misc/axel adedd.
Diffstat (limited to 'net-misc/axel/axel-1.0a.ebuild')
-rw-r--r--net-misc/axel/axel-1.0a.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/axel/axel-1.0a.ebuild b/net-misc/axel/axel-1.0a.ebuild
new file mode 100644
index 000000000000..cd1a4380a4b3
--- /dev/null
+++ b/net-misc/axel/axel-1.0a.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/axel-1.0a.ebuild,v 1.1 2002/06/01 02:24:09 stroke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Axel: A light Unix download accelerator"
+HOMEPAGE="http://www.lintux.cx/axel.html"
+SRC_URI="http://www.lintux.cx/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local mconf
+ cd work/${P}
+ ( [ -n "$DEBUG" ] || [ -n "$DEBUGBUILD" ] ) && \
+ myconf="${myconf} --debug=1 --strip=0"
+ ./configure --prefix=/usr \
+ --etcdir=/etc \
+ --mandir=/usr/share/man $myconf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc API CHANGES COPYING CREDITS README axelrc.example
+}