summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-03-13 13:44:09 +0000
committerMichael Weber <xmw@gentoo.org>2013-03-13 13:44:09 +0000
commitc65683cd1332296b9a18ccfc6aa922a65be235cf (patch)
tree0793bd8e99bde28ee6b727a75ed9c30a23b695cd /net-misc/batctl
parentVersion bump (diff)
downloadgentoo-2-c65683cd1332296b9a18ccfc6aa922a65be235cf.tar.gz
gentoo-2-c65683cd1332296b9a18ccfc6aa922a65be235cf.tar.bz2
gentoo-2-c65683cd1332296b9a18ccfc6aa922a65be235cf.zip
Version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-misc/batctl')
-rw-r--r--net-misc/batctl/ChangeLog7
-rw-r--r--net-misc/batctl/batctl-2013.1.0.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/net-misc/batctl/ChangeLog b/net-misc/batctl/ChangeLog
index b4a47f2855d6..9b9128d271d9 100644
--- a/net-misc/batctl/ChangeLog
+++ b/net-misc/batctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/batctl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/batctl/ChangeLog,v 1.10 2013/01/14 10:52:43 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/batctl/ChangeLog,v 1.11 2013/03/13 13:44:09 xmw Exp $
+
+*batctl-2013.1.0 (13 Mar 2013)
+
+ 13 Mar 2013; Michael Weber <xmw@gentoo.org> +batctl-2013.1.0.ebuild:
+ Version bump
*batctl-2013.0.0 (14 Jan 2013)
diff --git a/net-misc/batctl/batctl-2013.1.0.ebuild b/net-misc/batctl/batctl-2013.1.0.ebuild
new file mode 100644
index 000000000000..75ff94593661
--- /dev/null
+++ b/net-misc/batctl/batctl-2013.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/batctl/batctl-2013.1.0.ebuild,v 1.1 2013/03/13 13:44:09 xmw Exp $
+
+EAPI=4
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="BATMAN advanced control and management tool"
+HOMEPAGE="http://www.open-mesh.org/"
+SRC_URI="http://downloads.open-mesh.org/batman/stable/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ if ( linux_config_exists && linux_chkconfig_present BATMAN_ADV ) \
+ || ! has_version net-misc/batman-adv ; then
+ ewarn "You need the batman-adv kernel module,"
+ ewarn "either from the kernel tree or via net-misc/batman-adv"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 REVISION=gentoo-"${PVR}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc README
+}