summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-11-02 15:58:45 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-11-02 15:58:45 +0000
commitc3a31132634391e157cdad497ba5acabe9c331e7 (patch)
tree554c0e3985c64b8351e1fc3efe25a38a7f8ef0d8 /net-misc/bird
parentnet-misc/asterisk-app_rtxfax: removing (pending 10/21/2009). (diff)
downloadgentoo-2-c3a31132634391e157cdad497ba5acabe9c331e7.tar.gz
gentoo-2-c3a31132634391e157cdad497ba5acabe9c331e7.tar.bz2
gentoo-2-c3a31132634391e157cdad497ba5acabe9c331e7.zip
Version bump, increases scalability of the BGP implementation. New accessors for AS path and allows import of kernel onlink routes.
(Portage version: 2.1.7.3/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/bird')
-rw-r--r--net-misc/bird/ChangeLog10
-rw-r--r--net-misc/bird/bird-1.1.5.ebuild59
-rw-r--r--net-misc/bird/files/1.1.5-nostrip.patch15
-rw-r--r--net-misc/bird/files/initd-v4-bird-1.1.539
-rw-r--r--net-misc/bird/files/initd-v6-bird-1.1.539
5 files changed, 161 insertions, 1 deletions
diff --git a/net-misc/bird/ChangeLog b/net-misc/bird/ChangeLog
index e3565e076a3d..827311698bca 100644
--- a/net-misc/bird/ChangeLog
+++ b/net-misc/bird/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/bird
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/ChangeLog,v 1.7 2009/10/02 11:52:08 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/ChangeLog,v 1.8 2009/11/02 15:58:45 chainsaw Exp $
+
+*bird-1.1.5 (02 Nov 2009)
+
+ 02 Nov 2009; <chainsaw@gentoo.org> +files/1.1.5-nostrip.patch,
+ +files/initd-v4-bird-1.1.5, +files/initd-v6-bird-1.1.5,
+ +bird-1.1.5.ebuild:
+ Version bump, increases scalability of the BGP implementation. New
+ accessors for AS path and allows import of kernel onlink routes.
*bird-1.1.4 (02 Oct 2009)
diff --git a/net-misc/bird/bird-1.1.5.ebuild b/net-misc/bird/bird-1.1.5.ebuild
new file mode 100644
index 000000000000..fcdc277d7d4f
--- /dev/null
+++ b/net-misc/bird/bird-1.1.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/bird-1.1.5.ebuild,v 1.1 2009/11/02 15:58:45 chainsaw Exp $
+
+inherit eutils
+
+DESCRIPTION="A routing daemon implementing OSPF, RIPv2 & BGP for IPv4 or IPv6"
+HOMEPAGE="http://bird.network.cz"
+SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug ipv6"
+
+RDEPEND="sys-libs/ncurses
+ sys-libs/readline
+ ${DEPEND}"
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-devel/m4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-nostrip.patch"
+}
+
+src_compile() {
+ econf \
+ --enable-client \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ || die "Configuration stage failed"
+ emake || die "Compilation stage failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ if use ipv6; then
+ # The only thing worse then not supplying
+ # a sample configuration file to a user is
+ # wasting his/her time with a totally
+ # broken one.
+ rm "${D}/etc/bird6.conf"
+ newinitd "${FILESDIR}/initd-v6-${P}" bird6
+ else
+ newinitd "${FILESDIR}/initd-v4-${P}" bird
+ fi
+}
+
+pkg_postinst() {
+ if use ipv6; then
+ elog "Please note that only the IPv6 versions of the BIRD client & daemon have been installed."
+ else
+ elog "Please note that only the IPv4 versions of the BIRD client & daemon have been installed."
+ fi
+ elog "BIRDs build system is not currently suited to providing both."
+}
diff --git a/net-misc/bird/files/1.1.5-nostrip.patch b/net-misc/bird/files/1.1.5-nostrip.patch
new file mode 100644
index 000000000000..d7acd2304b44
--- /dev/null
+++ b/net-misc/bird/files/1.1.5-nostrip.patch
@@ -0,0 +1,15 @@
+diff -uNr bird-1.1.5.ORIG/tools/Makefile.in bird-1.1.5/tools/Makefile.in
+--- bird-1.1.5.ORIG/tools/Makefile.in 2009-11-02 15:22:13.000000000 +0000
++++ bird-1.1.5/tools/Makefile.in 2009-11-02 15:22:31.000000000 +0000
+@@ -56,9 +56,9 @@
+
+ install: all
+ $(INSTALL) -d $(DESTDIR)/$(sbindir) $(DESTDIR)/$(sysconfdir) $(DESTDIR)/$(localstatedir)
+- $(INSTALL_PROGRAM) -s $(exedir)/bird $(DESTDIR)/$(sbindir)/bird@SUFFIX6@
++ $(INSTALL_PROGRAM) $(exedir)/bird $(DESTDIR)/$(sbindir)/bird@SUFFIX6@
+ if test -n "@CLIENT@" ; then \
+- $(INSTALL_PROGRAM) -s $(exedir)/birdc $(DESTDIR)/$(sbindir)/birdc@SUFFIX6@ ; \
++ $(INSTALL_PROGRAM) $(exedir)/birdc $(DESTDIR)/$(sbindir)/birdc@SUFFIX6@ ; \
+ fi
+ if ! test -f $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf ; then \
+ $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf ; \
diff --git a/net-misc/bird/files/initd-v4-bird-1.1.5 b/net-misc/bird/files/initd-v4-bird-1.1.5
new file mode 100644
index 000000000000..94087ccc8489
--- /dev/null
+++ b/net-misc/bird/files/initd-v4-bird-1.1.5
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/files/initd-v4-bird-1.1.5,v 1.1 2009/11/02 15:58:44 chainsaw Exp $
+
+EXE=bird
+CLI=birdc
+SOCK="/var/run/${EXE}.ctl"
+
+depend() {
+ need net
+ use logger
+}
+
+checkconfig() {
+ if [ ! -f "/etc/${EXE}.conf" ]; then
+ eerror "Please create /etc/${EXE}.conf"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+
+ ebegin "Starting BIRD"
+ "/usr/sbin/${EXE}" -c "/etc/${EXE}.conf" -s "${SOCK}"
+ eend $? "Failed to start BIRD"
+}
+
+stop() {
+ ebegin "Stopping BIRD"
+ if [ -f "${SOCK}" ]; then
+ echo "down" | "/usr/sbin/${CLI}" -s "${SOCK}" &>/dev/null
+ eend $? "Failed to stop BIRD"
+ else
+ eend 0
+ fi
+}
diff --git a/net-misc/bird/files/initd-v6-bird-1.1.5 b/net-misc/bird/files/initd-v6-bird-1.1.5
new file mode 100644
index 000000000000..f135078a3f8a
--- /dev/null
+++ b/net-misc/bird/files/initd-v6-bird-1.1.5
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/files/initd-v6-bird-1.1.5,v 1.1 2009/11/02 15:58:44 chainsaw Exp $
+
+EXE=bird
+CLI=birdc
+SOCK="/var/run/${EXE}.ctl"
+
+depend() {
+ need net
+ use logger
+}
+
+checkconfig() {
+ if [ ! -f "/etc/${EXE}.conf" ]; then
+ eerror "Please create /etc/${EXE}.conf"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+
+ ebegin "Starting BIRD"
+ "/usr/sbin/${EXE}" -c "/etc/${EXE}.conf" -s "${SOCK}"
+ eend $? "Failed to start BIRD"
+}
+
+stop() {
+ ebegin "Stopping BIRD"
+ if [ -f "${SOCK}" ]; then
+ echo "down" | "/usr/sbin/${CLI}" -s "${SOCK}" &>/dev/null
+ eend $? "Failed to stop BIRD"
+ else
+ eend 0
+ fi
+}