summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-12-25 08:53:10 +0000
committerTorsten Veller <tove@gentoo.org>2009-12-25 08:53:10 +0000
commit591d0a4d017881a644419bc4b77bd5d065777277 (patch)
treeec5dcdacbd34f82b790885595b9c909125daff58 /net-misc/bwwhois
parentRemove the markdown script (#298025) (diff)
downloadgentoo-2-591d0a4d017881a644419bc4b77bd5d065777277.tar.gz
gentoo-2-591d0a4d017881a644419bc4b77bd5d065777277.tar.bz2
gentoo-2-591d0a4d017881a644419bc4b77bd5d065777277.zip
Install perl-modules to VENDOR_LIB (#295899)
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/bwwhois')
-rw-r--r--net-misc/bwwhois/ChangeLog7
-rw-r--r--net-misc/bwwhois/bwwhois-5.0-r1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/net-misc/bwwhois/ChangeLog b/net-misc/bwwhois/ChangeLog
index 6d81e8119a97..abce3ff38ba1 100644
--- a/net-misc/bwwhois/ChangeLog
+++ b/net-misc/bwwhois/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/bwwhois
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bwwhois/ChangeLog,v 1.19 2009/07/29 16:24:15 gengor Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bwwhois/ChangeLog,v 1.20 2009/12/25 08:53:10 tove Exp $
+
+*bwwhois-5.0-r1 (25 Dec 2009)
+
+ 25 Dec 2009; Torsten Veller <tove@gentoo.org> +bwwhois-5.0-r1.ebuild:
+ Install perl-modules to VENDOR_LIB (#295899)
29 Jul 2009; Gordon Malm <gengor@gentoo.org> bwwhois-5.0.ebuild:
QA fixes/updates.
diff --git a/net-misc/bwwhois/bwwhois-5.0-r1.ebuild b/net-misc/bwwhois/bwwhois-5.0-r1.ebuild
new file mode 100644
index 000000000000..3921f1034af9
--- /dev/null
+++ b/net-misc/bwwhois/bwwhois-5.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bwwhois/bwwhois-5.0-r1.ebuild,v 1.1 2009/12/25 08:53:10 tove Exp $
+
+inherit perl-app
+
+MY_P=${P/bw/}
+
+DESCRIPTION="Perl-based whois client designed to work with the new Shared Registration System"
+SRC_URI="http://whois.bw.org/dist/${MY_P}.tgz"
+HOMEPAGE="http://whois.bw.org/"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ exeinto usr/bin
+ newexe whois bwwhois || die
+
+ newman whois.1 bwwhois.1 || die
+
+ insinto /etc/whois
+ doins whois.conf tld.conf sd.conf || die
+
+ perlinfo
+ insinto "${VENDOR_LIB}"
+ doins bwInclude.pm || die
+}