summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-12-16 17:29:55 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-12-16 17:29:55 +0000
commitc338f0d43f176773a7080b5d8bc5aa89b5ffb27a (patch)
tree6adec6f5fbada2d1bf789de6714fd94919248dba /net-misc/cgminer
parentAdd missing slot operator on exiv2 dependency (diff)
downloadgentoo-2-c338f0d43f176773a7080b5d8bc5aa89b5ffb27a.tar.gz
gentoo-2-c338f0d43f176773a7080b5d8bc5aa89b5ffb27a.tar.bz2
gentoo-2-c338f0d43f176773a7080b5d8bc5aa89b5ffb27a.zip
Version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/cgminer')
-rw-r--r--net-misc/cgminer/ChangeLog8
-rw-r--r--net-misc/cgminer/cgminer-4.9.0.ebuild98
-rw-r--r--net-misc/cgminer/metadata.xml1
3 files changed, 106 insertions, 1 deletions
diff --git a/net-misc/cgminer/ChangeLog b/net-misc/cgminer/ChangeLog
index 5786d3adadf9..b9c74bc3ea08 100644
--- a/net-misc/cgminer/ChangeLog
+++ b/net-misc/cgminer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/cgminer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.83 2014/11/26 20:40:21 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.84 2014/12/16 17:29:55 blueness Exp $
+
+*cgminer-4.9.0 (16 Dec 2014)
+
+ 16 Dec 2014; Anthony G. Basile <blueness@gentoo.org> +cgminer-4.9.0.ebuild,
+ metadata.xml:
+ Version bump
26 Nov 2014; Anthony G. Basile <blueness@gentoo.org> -cgminer-4.2.3.ebuild,
-cgminer-4.3.5.ebuild, -cgminer-4.4.2.ebuild, -cgminer-4.5.0.ebuild:
diff --git a/net-misc/cgminer/cgminer-4.9.0.ebuild b/net-misc/cgminer/cgminer-4.9.0.ebuild
new file mode 100644
index 000000000000..c80fafe9345d
--- /dev/null
+++ b/net-misc/cgminer/cgminer-4.9.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/cgminer-4.9.0.ebuild,v 1.1 2014/12/16 17:29:55 blueness Exp $
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Bitcoin CPU/GPU/FPGA/ASIC miner in C"
+HOMEPAGE="http://bitcointalk.org/?topic=28402.msg357369 http://github.com/ckolivas/cgminer"
+SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
+#SRC_URI="http://ck.kolivas.org/apps/cgminer/4.5/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+HARDWARE="ants1 ants2 avalon avalon2 avalon4 bab bitmine_A1 bflsc bitforce bitfury cointerra drillbit hashfast hashratio icarus klondike knc minion modminer spondoolies"
+IUSE="doc examples udev hardened ncurses ${HARDWARE}"
+
+REQUIRED_USE="|| ( ${HARDWARE} )"
+
+RDEPEND="net-misc/curl
+ >=dev-libs/jansson-2.6
+ ncurses? ( sys-libs/ncurses )
+ avalon? ( virtual/libusb:1[udev] )
+ avalon2? ( virtual/libusb:1[udev] )
+ avalon4? ( virtual/libusb:1[udev] )
+ bflsc? ( virtual/libusb:1[udev] )
+ bitforce? ( virtual/libusb:1[udev] )
+ bitfury? ( virtual/libusb:1[udev] )
+ cointerra? ( virtual/libusb:1[udev] )
+ drillbit? ( virtual/libusb:1[udev] )
+ hashfast? ( virtual/libusb:1[udev] )
+ hashratio? ( virtual/libusb:1[udev] )
+ icarus? ( virtual/libusb:1[udev] )
+ klondike? ( virtual/libusb:1[udev] )
+ modminer? ( virtual/libusb:1[udev] )
+ spondoolies? ( virtual/libusb:1[udev] )
+ udev? ( virtual/libudev )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.4.2-system-jansson.patch
+ eautoreconf
+}
+
+src_configure() {
+ use hardened && append-cflags "-nopie"
+
+ econf $(use_with ncurses curses) \
+ $(use_enable ants1) \
+ $(use_enable ants2) \
+ $(use_enable avalon) \
+ $(use_enable avalon2) \
+ $(use_enable avalon4) \
+ $(use_enable bab) \
+ $(use_enable bitmine_A1) \
+ $(use_enable bflsc) \
+ $(use_enable bitforce) \
+ $(use_enable bitfury) \
+ $(use_enable cointerra) \
+ $(use_enable drillbit) \
+ $(use_enable hashfast) \
+ $(use_enable hashratio) \
+ $(use_enable icarus) \
+ $(use_enable klondike) \
+ $(use_enable knc) \
+ $(use_enable minion) \
+ $(use_enable modminer) \
+ $(use_enable spondoolies) \
+ $(use_enable udev) \
+ --disable-forcecombo \
+ --with-system-libusb
+ # sanitize directories (is this still needed?)
+ sed -i 's~^\(\#define CGMINER_PREFIX \).*$~\1"'"${EPREFIX}/usr/lib/cgminer"'"~' config.h
+}
+
+src_install() { # How about using some make install?
+ dobin cgminer
+
+ if use udev; then
+ insinto /lib/udev/rules.d
+ use udev && doins 01-cgminer.rules
+ fi
+
+ if use doc; then
+ dodoc AUTHORS NEWS README API-README
+ use icarus || use bitforce || use modminer && dodoc FPGA-README
+ use avalon || use bflsc && dodoc ASIC-README
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc api-example.php miner.php API.java api-example.c example.conf
+ fi
+}
diff --git a/net-misc/cgminer/metadata.xml b/net-misc/cgminer/metadata.xml
index 79ed827efc15..1acccf6ee1de 100644
--- a/net-misc/cgminer/metadata.xml
+++ b/net-misc/cgminer/metadata.xml
@@ -15,6 +15,7 @@
<flag name="ants2">Enable support for Antminer S2 Bitmain</flag>
<flag name="avalon">Enable support for Avalon ASICs</flag>
<flag name="avalon2">Enable support for Avalon2 ASICs</flag>
+ <flag name="avalon4">Enable support for Avalon4 ASICs</flag>
<flag name="bab">Enable support for BlackArrow Bitfury</flag>
<flag name="bflsc">Enable support for BFL ASICs</flag>
<flag name="bitforce">Enable support for mining with ButterFly Labs BitFORCE FPGAs</flag>