summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2013-04-30 15:38:44 +0000
committerTony Vroon <chainsaw@gentoo.org>2013-04-30 15:38:44 +0000
commit96c496486316d11d7590266e978aca674403d815 (patch)
tree80c0516867986919628fe578f500c7afda2b5720 /net-misc/connman
parentOn second thought, fix automake-1.13 compatibility properly, with patches. (diff)
downloadgentoo-2-96c496486316d11d7590266e978aca674403d815.tar.gz
gentoo-2-96c496486316d11d7590266e978aca674403d815.tar.bz2
gentoo-2-96c496486316d11d7590266e978aca674403d815.zip
Version bump to 1.13; as requested by Andrew Brouwers in bug #468000.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/ChangeLog7
-rw-r--r--net-misc/connman/connman-1.13.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-misc/connman/ChangeLog b/net-misc/connman/ChangeLog
index d217245f1381..5314669bc5c0 100644
--- a/net-misc/connman/ChangeLog
+++ b/net-misc/connman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/connman
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.61 2013/03/14 12:51:31 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.62 2013/04/30 15:38:44 chainsaw Exp $
+
+*connman-1.13 (30 Apr 2013)
+
+ 30 Apr 2013; Tony Vroon <chainsaw@gentoo.org> +connman-1.13.ebuild:
+ Version bump to 1.13; as requested by Andrew Brouwers in bug #468000.
*connman-1.11 (14 Mar 2013)
diff --git a/net-misc/connman/connman-1.13.ebuild b/net-misc/connman/connman-1.13.ebuild
new file mode 100644
index 000000000000..d02d98f2dc81
--- /dev/null
+++ b/net-misc/connman/connman-1.13.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-1.13.ebuild,v 1.1 2013/04/30 15:38:44 chainsaw Exp $
+
+EAPI="5"
+inherit base
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="http://connman.net"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug doc examples +ethernet ofono openvpn policykit threads tools vpnc +wifi"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ >=net-firewall/iptables-1.4.8
+ net-libs/gnutls
+ bluetooth? ( net-wireless/bluez )
+ ofono? ( net-misc/ofono )
+ policykit? ( sys-auth/polkit )
+ openvpn? ( net-misc/openvpn )
+ vpnc? ( net-misc/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-0.7[dbus] )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39
+ doc? ( dev-util/gtk-doc )"
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable threads) \
+ $(use_enable tools) \
+ --disable-iospm \
+ --disable-hh2serial-gps \
+ --disable-openconnect
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dobin client/connmanctl || die "client installation failed"
+
+ keepdir /var/lib/${PN} || die
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN} || die
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
+}