summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-12-19 04:32:21 +0000
committerYixun Lan <dlan@gentoo.org>2014-12-19 04:32:21 +0000
commitaae3e8324cc349ee23962f6fde30a4e5bd6b00f3 (patch)
tree52cdc7ff7c32d96185e4fe8907165a31ec8b584c /net-misc/connman
parentBump (diff)
downloadgentoo-2-aae3e8324cc349ee23962f6fde30a4e5bd6b00f3.tar.gz
gentoo-2-aae3e8324cc349ee23962f6fde30a4e5bd6b00f3.tar.bz2
gentoo-2-aae3e8324cc349ee23962f6fde30a4e5bd6b00f3.zip
version bump, bug 532828
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/ChangeLog7
-rw-r--r--net-misc/connman/connman-1.27.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/net-misc/connman/ChangeLog b/net-misc/connman/ChangeLog
index 17ce96de69f9..4fc5bbefe5ed 100644
--- a/net-misc/connman/ChangeLog
+++ b/net-misc/connman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/connman
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.88 2014/10/19 13:59:21 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.89 2014/12/19 04:32:21 dlan Exp $
+
+*connman-1.27 (19 Dec 2014)
+
+ 19 Dec 2014; Yixun Lan <dlan@gentoo.org> +connman-1.27.ebuild:
+ version bump, bug 532828
*connman-1.26 (19 Oct 2014)
diff --git a/net-misc/connman/connman-1.27.ebuild b/net-misc/connman/connman-1.27.ebuild
new file mode 100644
index 000000000000..855d031ad20f
--- /dev/null
+++ b/net-misc/connman/connman-1.27.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-1.27.ebuild,v 1.1 2014/12/19 04:32:21 dlan Exp $
+
+EAPI="5"
+inherit base systemd
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="http://connman.net"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug doc examples +ethernet ofono openvpn openconnect policykit tools vpnc +wifi"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ >=net-firewall/iptables-1.4.8
+ net-libs/gnutls
+ bluetooth? ( net-wireless/bluez )
+ ofono? ( net-misc/ofono )
+ policykit? ( sys-auth/polkit )
+ openvpn? ( net-misc/openvpn )
+ vpnc? ( net-misc/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-2.0[dbus] )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39"
+
+PATCHES=( "${FILESDIR}/${PN}-1.16-execinfo-assumptions.patch" )
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openconnect openconnect builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable debug) \
+ $(use_enable tools) \
+ --disable-iospm \
+ --disable-hh2serial-gps
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dobin client/connmanctl || die "client installation failed"
+
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ systemd_dounit "${FILESDIR}"/connman.service
+}