summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-07-03 14:17:25 +0000
committerDror Levin <spatz@gentoo.org>2010-07-03 14:17:25 +0000
commit59083d4a62087a5e41bb9900c321fec8f9cb4f4f (patch)
tree0d09b43fd14c6fd94ece14ba9105956e68c94d46 /net-misc/curl
parentalpha/arm/ia64/s390/sh/sparc stable wrt #308645 (diff)
downloadgentoo-2-59083d4a62087a5e41bb9900c321fec8f9cb4f4f.tar.gz
gentoo-2-59083d4a62087a5e41bb9900c321fec8f9cb4f4f.tar.bz2
gentoo-2-59083d4a62087a5e41bb9900c321fec8f9cb4f4f.zip
Remove vulnerable version, bug 308645.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/ChangeLog5
-rw-r--r--net-misc/curl/curl-7.19.6.ebuild109
2 files changed, 4 insertions, 110 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index 4bc823718134..6ef7968f00ad 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/curl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.164 2010/07/03 14:09:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.165 2010/07/03 14:17:25 spatz Exp $
+
+ 03 Jul 2010; Dror Levin <spatz@gentoo.org> -curl-7.19.6.ebuild:
+ Remove vulnerable version, bug 308645.
03 Jul 2010; Raúl Porcel <armin76@gentoo.org> curl-7.20.0-r2.ebuild:
alpha/arm/ia64/s390/sh/sparc stable wrt #308645
diff --git a/net-misc/curl/curl-7.19.6.ebuild b/net-misc/curl/curl-7.19.6.ebuild
deleted file mode 100644
index aa4aab12954d..000000000000
--- a/net-misc/curl/curl-7.19.6.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.19.6.ebuild,v 1.9 2010/02/11 17:08:45 ulm Exp $
-
-# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-
-inherit multilib eutils
-
-#MY_P=${P/_pre/-}
-DESCRIPTION="A Client that groks URLs"
-HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
-#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
-#SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
-SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-#IUSE="ssl ipv6 ldap ares gnutls nss idn kerberos test"
-IUSE="ssl ipv6 ldap ares gnutls libssh2 nss idn kerberos test"
-
-# TODO - change to openssl USE flag in the not too distant future
-# https://bugs.gentoo.org/show_bug.cgi?id=207653#c3 (April 2008)
-
-RDEPEND="gnutls? ( net-libs/gnutls app-misc/ca-certificates )
- nss? ( !gnutls? ( dev-libs/nss app-misc/ca-certificates ) )
- ssl? ( !gnutls? ( !nss? ( dev-libs/openssl app-misc/ca-certificates ) ) )
- ldap? ( net-nds/openldap )
- idn? ( net-dns/libidn )
- ares? ( >=net-dns/c-ares-1.4.0 )
- kerberos? ( virtual/krb5 )
- libssh2? ( >=net-libs/libssh2-0.16 )"
-
-# fbopenssl (not in gentoo) --with-spnego
-# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
-
-DEPEND="${RDEPEND}
- test? (
- sys-apps/diffutils
- dev-lang/perl
- )"
-# used - but can do without in self test: net-misc/stunnel
-#S="${WORKDIR}"/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/curl-7.17.0-strip-ldflags.patch
-}
-
-src_compile() {
-
- myconf="$(use_enable ldap)
- $(use_enable ldap ldaps)
- $(use_with idn libidn)
- $(use_with kerberos gssapi /usr)
- $(use_with libssh2)
- $(use_enable ipv6)
- --enable-http
- --enable-ftp
- --enable-gopher
- --enable-file
- --enable-dict
- --enable-manual
- --enable-telnet
- --enable-nonblocking
- --enable-largefile
- --enable-maintainer-mode
- --disable-sspi
- --without-krb4
- --without-spnego"
-
- if use ipv6 && use ares; then
- elog "c-ares support disabled because it is incompatible with ipv6."
- myconf="${myconf} --disable-ares"
- else
- myconf="${myconf} $(use_enable ares)"
- fi
-
- if use gnutls; then
- myconf="${myconf} --without-ssl --with-gnutls --without-nss"
- myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
- elif use nss; then
- myconf="${myconf} --without-ssl --without-gnutls --with-nss"
- myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
- elif use ssl; then
- myconf="${myconf} --without-gnutls --without-nss --with-ssl"
- myconf="${myconf} --without-ca-bundle --with-ca-path=/etc/ssl/certs"
- else
- myconf="${myconf} --without-gnutls --without-nss --without-ssl"
- fi
-
- econf ${myconf} || die 'configure failed'
-
- emake || die "install failed for current version"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "installed failed for current version"
- rm -rf "${D}"/etc/
-
- # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
- insinto /usr/share/aclocal
- doins docs/libcurl/libcurl.m4
-
- dodoc CHANGES README
- dodoc docs/FEATURES docs/INTERNALS
- dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
-}