summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-08-30 18:10:29 +0000
committerDror Levin <spatz@gentoo.org>2010-08-30 18:10:29 +0000
commit590f7c4cd943f0336895bfa3a12723058b9ae874 (patch)
tree34b5117b8218ee9339fb74b0b341e5fedf662857 /net-misc/curl
parentAdd test fix from upstream. (diff)
downloadgentoo-2-590f7c4cd943f0336895bfa3a12723058b9ae874.tar.gz
gentoo-2-590f7c4cd943f0336895bfa3a12723058b9ae874.tar.bz2
gentoo-2-590f7c4cd943f0336895bfa3a12723058b9ae874.zip
Version bump.
(Portage version: 2.2_rc72/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/ChangeLog7
-rw-r--r--net-misc/curl/curl-7.21.1.ebuild122
2 files changed, 128 insertions, 1 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index ccccfa63a4e9..990247b61e9b 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/curl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.167 2010/07/18 09:35:29 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.168 2010/08/30 18:10:29 spatz Exp $
+
+*curl-7.21.1 (30 Aug 2010)
+
+ 30 Aug 2010; Dror Levin <spatz@gentoo.org> +curl-7.21.1.ebuild:
+ Version bump.
18 Jul 2010; Daniel Black <dragonheart@gentoo.org> curl-7.21.0.ebuild:
prevent autodependency as per bug #326549. Thanks to Zeev for the bug
diff --git a/net-misc/curl/curl-7.21.1.ebuild b/net-misc/curl/curl-7.21.1.ebuild
new file mode 100644
index 000000000000..6f7cfc799dc3
--- /dev/null
+++ b/net-misc/curl/curl-7.21.1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.21.1.ebuild,v 1.1 2010/08/30 18:10:29 spatz Exp $
+
+# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
+
+EAPI=3
+
+inherit multilib eutils libtool prefix
+
+#MY_P=${P/_pre/-}
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/"
+#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ares gnutls idn ipv6 kerberos ldap libssh2 nss ssl test threads"
+
+RDEPEND="ldap? ( net-nds/openldap )
+ ssl? (
+ gnutls? ( net-libs/gnutls app-misc/ca-certificates )
+ nss? ( !gnutls? ( dev-libs/nss app-misc/ca-certificates ) )
+ !gnutls? ( !nss? ( dev-libs/openssl ) )
+ )
+ idn? ( net-dns/libidn )
+ !threads? ( ares? ( >=net-dns/c-ares-1.4.0 ) )
+ kerberos? ( virtual/krb5 )
+ libssh2? ( >=net-libs/libssh2-0.16 )"
+
+# rtmpdump ( media-video/rtmpdump ) / --with-librtmp
+# fbopenssl (not in gentoo) --with-spnego
+# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
+
+DEPEND="${RDEPEND}
+ test? (
+ sys-apps/diffutils
+ dev-lang/perl
+ )"
+# used - but can do without in self test: net-misc/stunnel
+
+pkg_setup() {
+ if ! use ssl && ( use gnutls || use nss ) ; then
+ ewarn "USE='gnutls nss' are ignored without USE='ssl'."
+ ewarn "Please review the local USE flags for this package."
+ fi
+ if use ares && use threads; then
+ ewarn "USE flags 'ares' and 'threads' are mutually exclusive,"
+ ewarn "disabling 'ares', please review and re-emerge if needed."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-7.20.0-strip-ldflags.patch \
+ "${FILESDIR}"/${PN}-7.19.7-test241.patch \
+ "${FILESDIR}"/${PN}-7.18.2-prefix.patch
+
+ eprefixify curl-config.in
+ # for FreeMiNT
+ elibtoolize
+}
+
+src_configure() {
+ myconf="$(use_enable ldap)
+ $(use_enable ldap ldaps)
+ $(use_with idn libidn)
+ $(use_with kerberos gssapi "${EPREFIX}"/usr)
+ $(use_with libssh2)
+ $(use_enable ipv6)
+ $(use_enable threads threaded-resolver)
+ $(use threads && echo --disable-ares || use_enable ares)
+ --enable-http
+ --enable-ftp
+ --enable-gopher
+ --enable-file
+ --enable-dict
+ --enable-manual
+ --enable-telnet
+ --enable-smtp
+ --enable-pop3
+ --enable-imap
+ --enable-rtsp
+ --enable-nonblocking
+ --enable-largefile
+ --enable-maintainer-mode
+ --disable-sspi
+ --without-krb4
+ --without-librtmp
+ --without-spnego"
+
+ if use ssl ; then
+ if use gnutls; then
+ myconf="${myconf} --without-ssl --with-gnutls --without-nss"
+ myconf="${myconf} --with-ca-bundle=${EPREFIX}/etc/ssl/certs/ca-certificates.crt"
+ elif use nss; then
+ myconf="${myconf} --without-ssl --without-gnutls --with-nss"
+ myconf="${myconf} --with-ca-bundle=${EPREFIX}/etc/ssl/certs/ca-certificates.crt"
+ else
+ myconf="${myconf} --without-gnutls --without-nss --with-ssl"
+ myconf="${myconf} --without-ca-bundle --with-ca-path=${EPREFIX}/etc/ssl/certs"
+ fi
+ else
+ myconf="${myconf} --without-gnutls --without-nss --without-ssl"
+ fi
+
+ econf ${myconf} || die 'configure failed'
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installed failed for current version"
+ rm -rf "${ED}"/etc/
+
+ # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4 || die
+
+ dodoc CHANGES README || die
+ dodoc docs/FEATURES docs/INTERNALS || die
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE || die
+}