summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2013-01-01 15:33:12 +0000
committerWilliam Hubbs <williamh@gentoo.org>2013-01-01 15:33:12 +0000
commitebc35977e742230a783221b3f9145ac4cee01a13 (patch)
tree62544fd5647bfdbba705509329cfe7710242d328 /net-misc/dhcpcd/dhcpcd-5.5.6.ebuild
parentMigrate to distutils-r1. (diff)
downloadgentoo-2-ebc35977e742230a783221b3f9145ac4cee01a13.tar.gz
gentoo-2-ebc35977e742230a783221b3f9145ac4cee01a13.tar.bz2
gentoo-2-ebc35977e742230a783221b3f9145ac4cee01a13.zip
remove all old versions
(Portage version: 2.2.0_alpha149/cvs/Linux i686, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'net-misc/dhcpcd/dhcpcd-5.5.6.ebuild')
-rw-r--r--net-misc/dhcpcd/dhcpcd-5.5.6.ebuild99
1 files changed, 0 insertions, 99 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-5.5.6.ebuild b/net-misc/dhcpcd/dhcpcd-5.5.6.ebuild
deleted file mode 100644
index d9611253add1..000000000000
--- a/net-misc/dhcpcd/dhcpcd-5.5.6.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-5.5.6.ebuild,v 1.3 2012/05/05 22:49:57 aballier Exp $
-
-EAPI=4
-
-inherit eutils systemd
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
-SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-
-SLOT="0"
-IUSE="+zeroconf elibc_glibc"
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-}
-
-src_configure() {
- local hooks="--with-hook=ntp.conf"
- use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
- econf \
- --prefix="${EPREFIX}" \
- --libexecdir="${EPREFIX}/lib/dhcpcd" \
- --dbdir="${EPREFIX}/var/lib/dhcpcd" \
- --localstatedir="${EPREFIX}/var" \
- ${hooks}
-}
-
-src_install() {
- default
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
-
- elog
- elog "Users upgrading from 4.0 series should pay attention to removal"
- elog "of compat useflag. This changes behavior of dhcp in wide manner:"
- elog "dhcpcd no longer sends a default ClientID for ethernet interfaces."
- elog "This is so we can re-use the address the kernel DHCP client found."
- elog "To retain the old behaviour of sending a default ClientID based on the"
- elog "hardware address for interface, simply add the keyword clientid"
- elog "to dhcpcd.conf or use commandline parameter -I ''"
- elog
- elog "Also, users upgrading from 4.0 series should be aware that"
- elog "the -N, -R and -Y command line options no longer exist."
- elog "These are controled now by nohook options in dhcpcd.conf."
-
- # Mea culpa, feel free to remove that after some time --mgorny.
- if [[ -e "${ROOT}"/etc/systemd/system/network.target.wants/${PN}.service ]]
- then
- ebegin "Moving ${PN}.service to multi-user.target"
- mv "${ROOT}"/etc/systemd/system/network.target.wants/${PN}.service \
- "${ROOT}"/etc/systemd/system/multi-user.target.wants/
- eend ${?} \
- "Please try to re-enable dhcpcd.service"
- fi
-}