summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2013-08-22 21:47:14 +0000
committerWilliam Hubbs <williamh@gentoo.org>2013-08-22 21:47:14 +0000
commitabaabea44a4309ae6257d91692f0f6102b603764 (patch)
treecaa012ba1041dbc3269d46c2006115ac7b17e3bf /net-misc/dhcpcd
parentNew snapshot. Adds ffmpeg-2.0 support, bug #480672. (diff)
downloadgentoo-2-abaabea44a4309ae6257d91692f0f6102b603764.tar.gz
gentoo-2-abaabea44a4309ae6257d91692f0f6102b603764.tar.bz2
gentoo-2-abaabea44a4309ae6257d91692f0f6102b603764.zip
apply upstream patch to fix seg fault reported in bug #479922
(Portage version: 2.2.1/cvs/Linux i686, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog8
-rw-r--r--net-misc/dhcpcd/dhcpcd-6.0.5-r1.ebuild90
-rw-r--r--net-misc/dhcpcd/files/dhcpcd-6.0.5-fix-segfault.patch19
3 files changed, 116 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index e338a4b9e782..c5c9d407bd68 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.368 2013/08/17 19:55:14 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.369 2013/08/22 21:47:14 williamh Exp $
+
+*dhcpcd-6.0.5-r1 (22 Aug 2013)
+
+ 22 Aug 2013; William Hubbs <williamh@gentoo.org> +dhcpcd-6.0.5-r1.ebuild,
+ +files/dhcpcd-6.0.5-fix-segfault.patch:
+ apply upstream patch to fix seg fault reported in bug #479922
17 Aug 2013; William Hubbs <williamh@gentoo.org>
+files/dhcpcd-6.0.5-fix-build-without-ipv6.patch, dhcpcd-6.0.5.ebuild:
diff --git a/net-misc/dhcpcd/dhcpcd-6.0.5-r1.ebuild b/net-misc/dhcpcd/dhcpcd-6.0.5-r1.ebuild
new file mode 100644
index 000000000000..278e1bdc0eb9
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-6.0.5-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-6.0.5-r1.ebuild,v 1.1 2013/08/22 21:47:14 williamh Exp $
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://roy.marples.name/${PN}.git"
+ inherit git-2
+else
+ MY_P="${P/_alpha/-alpha}"
+ MY_P="${MY_P/_beta/-beta}"
+ MY_P="${MY_P/_rc/-rc}"
+ SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+inherit eutils systemd
+
+DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="elibc_glibc ipv6"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare()
+{
+ epatch "${FILESDIR}"/${P}-fix-build-without-ipv6.patch
+ epatch "${FILESDIR}"/${P}-fix-segfault.patch
+ epatch_user
+}
+
+src_configure()
+{
+ local hooks="--with-hook=ntp.conf"
+ use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
+ econf \
+ --prefix="${EPREFIX}" \
+ --libexecdir="${EPREFIX}/lib/dhcpcd" \
+ --dbdir="${EPREFIX}/var/lib/dhcpcd" \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable ipv6) \
+ ${hooks}
+}
+
+src_install()
+{
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst()
+{
+ # Upgrade the duid file to the new format if needed
+ local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ local new_duid="${ROOT}"/etc/dhcpcd.duid
+ if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+
+ elog
+ elog "dhcpcd has zeroconf support active by default."
+ elog "This means it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the noipv4ll configuration"
+ elog "file option or the -L command line switch."
+ elog "See the dhcpcd and dhcpcd.conf man pages for more details."
+
+ elog
+ elog "Dhcpcd has duid enabled by default, and this may cause issues"
+ elog "with some dhcp servers. For more information, see"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=477356"
+
+ if ! has_version net-dns/bind-tools; then
+ elog
+ elog "If you activate the lookup-hostname hook to look up your hostname"
+ elog "using the dns, you need to install net-dns/bind-tools."
+ fi
+}
diff --git a/net-misc/dhcpcd/files/dhcpcd-6.0.5-fix-segfault.patch b/net-misc/dhcpcd/files/dhcpcd-6.0.5-fix-segfault.patch
new file mode 100644
index 000000000000..120920844ae4
--- /dev/null
+++ b/net-misc/dhcpcd/files/dhcpcd-6.0.5-fix-segfault.patch
@@ -0,0 +1,19 @@
+commit d995aa130fcdadc3a99f948c89447d9960b8753e
+Author: Roy Marples <roy@marples.name>
+Date: Mon Aug 19 10:09:32 2013 +0100
+
+ Add the cloned static route, not the original
+
+diff --git a/ipv4.c b/ipv4.c
+index c2be11d..845f386 100644
+--- a/ipv4.c
++++ b/ipv4.c
+@@ -390,7 +390,7 @@ get_routes(struct interface *ifp)
+ return NULL;
+ }
+ memcpy(r, rt, sizeof(*r));
+- TAILQ_INSERT_TAIL(nrt, rt, next);
++ TAILQ_INSERT_TAIL(nrt, r, next);
+ }
+ return nrt;
+ }