summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-07-31 10:05:22 +0000
committerRoy Marples <uberlord@gentoo.org>2007-07-31 10:05:22 +0000
commite97f59d70f0dfc1e3dbb2459191c764c8ae89df1 (patch)
treed7c3cb76e973d5f953737304248b0ca1e15ce541 /net-misc/dhcpcd
parentx86 stable wrt #186889 (diff)
downloadgentoo-2-e97f59d70f0dfc1e3dbb2459191c764c8ae89df1.tar.gz
gentoo-2-e97f59d70f0dfc1e3dbb2459191c764c8ae89df1.tar.bz2
gentoo-2-e97f59d70f0dfc1e3dbb2459191c764c8ae89df1.zip
New version, fixes #158867, #186386 and #186801.
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog7
-rw-r--r--net-misc/dhcpcd/dhcpcd-3.1.2.ebuild39
-rw-r--r--net-misc/dhcpcd/files/digest-dhcpcd-3.1.23
3 files changed, 48 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index cae5f9ba88b3..28e171052dde 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.149 2007/07/26 09:45:36 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.150 2007/07/31 10:05:22 uberlord Exp $
+
+*dhcpcd-3.1.2 (31 Jul 2007)
+
+ 31 Jul 2007; Roy Marples <uberlord@gentoo.org> +dhcpcd-3.1.2.ebuild:
+ New version, fixes #158867, #186386 and #186801.
*dhcpcd-3.1.1 (26 Jul 2007)
diff --git a/net-misc/dhcpcd/dhcpcd-3.1.2.ebuild b/net-misc/dhcpcd/dhcpcd-3.1.2.ebuild
new file mode 100644
index 000000000000..b8a9b17579f1
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-3.1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-3.1.2.ebuild,v 1.1 2007/07/31 10:05:22 uberlord Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A DHCP client"
+HOMEPAGE="http://dhcpcd.berlios.de"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="vram"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Redefine the location of ntp.drift
+ sed -i -e 's,#define NTPDRIFTFILE[:space:]*,#define NTPDRIFTFILE\t\"/var/lib/ntp/ntp.drift\",' \
+ config.h || die "sed failed"
+
+ # Disable DUID support if we have volatile storage.
+ # LiveCD's *should* enable this USE flag
+ use vram && echo "#undef ENABLE_DUID" >> config.h
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog
+}
diff --git a/net-misc/dhcpcd/files/digest-dhcpcd-3.1.2 b/net-misc/dhcpcd/files/digest-dhcpcd-3.1.2
new file mode 100644
index 000000000000..907d217927da
--- /dev/null
+++ b/net-misc/dhcpcd/files/digest-dhcpcd-3.1.2
@@ -0,0 +1,3 @@
+MD5 c0b7e90d79ac147debbc557f812fbcb9 dhcpcd-3.1.2.tar.bz2 40377
+RMD160 cacdf4c263abec29fd88b3242c24063bdbf1fc50 dhcpcd-3.1.2.tar.bz2 40377
+SHA256 1d7c1df8dd2e44e0e05cd6c9eb663d94abecfaf2d92f7c9e7c73d474d70e6251 dhcpcd-3.1.2.tar.bz2 40377