summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-08-22 13:38:45 +0000
committerEray Aslan <eras@gentoo.org>2012-08-22 13:38:45 +0000
commit3c6250a3f13739184a69a315f3233f4258595cf4 (patch)
tree7851c53e239e483471c3b278169f1ce21c1af2b2 /net-misc/gsasl/gsasl-1.8.0-r1.ebuild
parentStable for amd64, wrt bug #432002 (diff)
downloadgentoo-2-3c6250a3f13739184a69a315f3233f4258595cf4.tar.gz
gentoo-2-3c6250a3f13739184a69a315f3233f4258595cf4.tar.bz2
gentoo-2-3c6250a3f13739184a69a315f3233f4258595cf4.zip
Add kerberos implementation info to configure - bug #432220
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/gsasl/gsasl-1.8.0-r1.ebuild')
-rw-r--r--net-misc/gsasl/gsasl-1.8.0-r1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/net-misc/gsasl/gsasl-1.8.0-r1.ebuild b/net-misc/gsasl/gsasl-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..0dc14c0a6c15
--- /dev/null
+++ b/net-misc/gsasl/gsasl-1.8.0-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsasl/gsasl-1.8.0-r1.ebuild,v 1.1 2012/08/22 13:38:45 eras Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="The GNU SASL client, server, and library"
+HOMEPAGE="http://www.gnu.org/software/gsasl/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc gcrypt idn kerberos nls ntlm static-libs +threads"
+
+DEPEND="
+ gcrypt? ( dev-libs/libgcrypt )
+ idn? ( net-dns/libidn )
+ kerberos? ( virtual/krb5 )
+ nls? ( >=sys-devel/gettext-0.18.1 )
+ ntlm? ( net-libs/libntlm )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-gss-extra.patch"
+ sed -i -e '/gl_WARN_ADD(\[-Werror/d' \
+ -e 's/ -Werror//' configure.ac || die
+ sed -i -e 's/ -Werror//' lib/configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local krb5_impl
+ if use kerberos; then
+ krb5_impl="--with-gssapi-impl="
+ krb5_impl+=$(has_version app-crypt/mit-krb5 && echo "mit" || echo "heimdal")
+ fi
+ econf \
+ --enable-client \
+ --enable-server \
+ --disable-valgrind-tests \
+ --disable-rpath \
+ --without-libshishi \
+ --without-libgss \
+ --disable-kerberos_v5 \
+ $(use_enable kerberos gssapi) \
+ ${krb5_impl} \
+ $(use_enable kerberos gs2) \
+ $(use_with gcrypt libgcrypt) \
+ $(use_enable nls) \
+ $(use_with idn stringprep) \
+ $(use_enable ntlm) \
+ $(use_with ntlm libntlm) \
+ $(use_enable static-libs static) \
+ $(use_enable threads)
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ rm -f "${D}"/usr/lib*/lib*.la
+ fi
+ doman doc/gsasl.1 doc/man/*.3
+
+ if use doc; then
+ dodoc doc/*.{eps,ps,pdf}
+ dohtml doc/*.html
+ docinto examples
+ dodoc examples/*.c
+ fi
+}