summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-12-31 01:55:27 +0000
committerMike Frysinger <vapier@gentoo.org>2014-12-31 01:55:27 +0000
commit5ebd2099f863e5f895044841e0572d408f04447c (patch)
treebee6ea615217c75683676f721435b2c39b8444fc /net-misc/gsutil
parentrevbump; conversion -> distutils-r1 (diff)
downloadgentoo-2-5ebd2099f863e5f895044841e0572d408f04447c.tar.gz
gentoo-2-5ebd2099f863e5f895044841e0572d408f04447c.tar.bz2
gentoo-2-5ebd2099f863e5f895044841e0572d408f04447c.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-misc/gsutil')
-rw-r--r--net-misc/gsutil/ChangeLog9
-rw-r--r--net-misc/gsutil/files/gsutil-4.7-drop-http_proxy-clearing.patch36
-rw-r--r--net-misc/gsutil/files/gsutil-4.7-use-friendy-version-checks.patch22
-rw-r--r--net-misc/gsutil/gsutil-4.7.ebuild45
4 files changed, 111 insertions, 1 deletions
diff --git a/net-misc/gsutil/ChangeLog b/net-misc/gsutil/ChangeLog
index da4db0ef890a..ab9a10660c37 100644
--- a/net-misc/gsutil/ChangeLog
+++ b/net-misc/gsutil/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/gsutil
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gsutil/ChangeLog,v 1.19 2014/11/30 16:39:18 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsutil/ChangeLog,v 1.20 2014/12/31 01:55:27 vapier Exp $
+
+*gsutil-4.7 (31 Dec 2014)
+
+ 31 Dec 2014; Mike Frysinger <vapier@gentoo.org>
+ +files/gsutil-4.7-drop-http_proxy-clearing.patch,
+ +files/gsutil-4.7-use-friendy-version-checks.patch, +gsutil-4.7.ebuild:
+ Version bump.
30 Nov 2014; Michał Górny <mgorny@gentoo.org> gsutil-4.4.ebuild,
gsutil-4.5.ebuild, gsutil-4.6.ebuild:
diff --git a/net-misc/gsutil/files/gsutil-4.7-drop-http_proxy-clearing.patch b/net-misc/gsutil/files/gsutil-4.7-drop-http_proxy-clearing.patch
new file mode 100644
index 000000000000..67c07f03c48d
--- /dev/null
+++ b/net-misc/gsutil/files/gsutil-4.7-drop-http_proxy-clearing.patch
@@ -0,0 +1,36 @@
+http://crbug.com/318478
+https://github.com/GoogleCloudPlatform/gsutil/pull/171
+
+From 0067df5b08ebab29b88bbb7e6c1cd79dc4d96100 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Wed, 27 Nov 2013 14:57:05 -0500
+Subject: [PATCH] drop http_proxy clearing
+
+The boto logic takes care of merging the env vars and the settings in its
+boto config file, so there shouldn't be a need to clear things.
+---
+ gslib/__main__.py | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/gslib/__main__.py b/gslib/__main__.py
+index 82a69c1..a18db42 100644
+--- a/gslib/__main__.py
++++ b/gslib/__main__.py
+@@ -247,14 +247,6 @@ def main():
+ else:
+ command_name = args[0]
+
+- # Unset http_proxy environment variable if it's set, because it confuses
+- # boto. (Proxies should instead be configured via the boto config file.)
+- if 'http_proxy' in os.environ:
+- if debug > 1:
+- sys.stderr.write(
+- 'Unsetting http_proxy environment variable within gsutil run.\n')
+- del os.environ['http_proxy']
+-
+ if os.environ.get('_ARGCOMPLETE', '0') == '1':
+ return _PerformTabCompletion(command_runner)
+
+--
+1.8.4.3
+
diff --git a/net-misc/gsutil/files/gsutil-4.7-use-friendy-version-checks.patch b/net-misc/gsutil/files/gsutil-4.7-use-friendy-version-checks.patch
new file mode 100644
index 000000000000..9d9eb65a3643
--- /dev/null
+++ b/net-misc/gsutil/files/gsutil-4.7-use-friendy-version-checks.patch
@@ -0,0 +1,22 @@
+--- a/setup.py
++++ b/setup.py
+@@ -35,7 +35,7 @@ management tasks, including:
+ """
+
+ requires = [
+- 'boto==2.30.0',
++ 'boto>=2.30.0',
+ 'crcmod>=1.7',
+ 'gcs-oauth2-boto-plugin>=1.8',
+ 'httplib2>=0.8',
+@@ -44,9 +44,7 @@ requires = [
+ 'python-gflags>=2.0',
+ 'retry_decorator>=1.0.0',
+ 'six>=1.8.0',
+- # Not using 1.02 because of:
+- # https://code.google.com/p/socksipy-branch/issues/detail?id=3
+- 'SocksiPy-branch==1.01',
++ 'SocksiPy-branch>=1.01',
+ ]
+
+ dependency_links = [
diff --git a/net-misc/gsutil/gsutil-4.7.ebuild b/net-misc/gsutil/gsutil-4.7.ebuild
new file mode 100644
index 000000000000..02e777085442
--- /dev/null
+++ b/net-misc/gsutil/gsutil-4.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsutil/gsutil-4.7.ebuild,v 1.1 2014/12/31 01:55:27 vapier Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="command line tool for interacting with cloud storage services"
+HOMEPAGE="https://github.com/GoogleCloudPlatform/gsutil"
+SRC_URI="http://commondatastorage.googleapis.com/pub/${PN}_${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=dev-python/boto-2.30.0[${PYTHON_USEDEP}]
+ >=dev-python/crcmod-1.7[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/gcs-oauth2-boto-plugin-1.8[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/python-gflags-2.0[${PYTHON_USEDEP}]
+ >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/socksipy-1.01[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( README.md CHANGES.md )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.7-use-friendy-version-checks.patch"
+ "${FILESDIR}/${PN}-4.7-drop-http_proxy-clearing.patch"
+)
+
+python_test() {
+ export BOTO_CONFIG=${FILESDIR}/dummy.boto
+ ${PYTHON} gslib/__main__.py test -u || die "tests failed"
+}