summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-10-01 05:26:00 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-10-01 05:26:00 +0000
commit4bfc05b2fad7463e0a2e612df2e201e21ca743b5 (patch)
tree988ecae231c11857f09c10b31a1a8aedd24de0f2 /net-misc/gyach
parentFixes for #4104 (diff)
downloadgentoo-2-4bfc05b2fad7463e0a2e612df2e201e21ca743b5.tar.gz
gentoo-2-4bfc05b2fad7463e0a2e612df2e201e21ca743b5.tar.bz2
gentoo-2-4bfc05b2fad7463e0a2e612df2e201e21ca743b5.zip
version bump
Diffstat (limited to 'net-misc/gyach')
-rw-r--r--net-misc/gyach/ChangeLog9
-rw-r--r--net-misc/gyach/files/digest-gyach-0.8.51
-rw-r--r--net-misc/gyach/gyach-0.8.5.ebuild36
3 files changed, 45 insertions, 1 deletions
diff --git a/net-misc/gyach/ChangeLog b/net-misc/gyach/ChangeLog
index 05502d4c0ae7..b0c9e3011d21 100644
--- a/net-misc/gyach/ChangeLog
+++ b/net-misc/gyach/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for net-misc/gyach
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gyach/ChangeLog,v 1.5 2002/09/22 05:54:51 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gyach/ChangeLog,v 1.6 2002/10/01 05:26:00 bcowan Exp $
+*gyach-0.8.5 (01 Oct 2002)
+
+ 01 Oct 2002; Brad Cowan <bcowan@gentoo.org> gyach=0.8.5.ebuild,
+ CangeLog, files/digest-gyach-0.8.5 :
+
+ Version bump. Small bugfixes and some code cleanup.
+
*gyach-0.8.4 (22 Sep 2002)
22 Sep 2002; Matthew Kennedy <mkennedy@gentoo.org> gyach-0.8.4.ebuild,
diff --git a/net-misc/gyach/files/digest-gyach-0.8.5 b/net-misc/gyach/files/digest-gyach-0.8.5
new file mode 100644
index 000000000000..5f74f1e6a500
--- /dev/null
+++ b/net-misc/gyach/files/digest-gyach-0.8.5
@@ -0,0 +1 @@
+MD5 503d200d8ea5f82abf6545aa886f9032 gyach-0.8.5.tar.gz 216366
diff --git a/net-misc/gyach/gyach-0.8.5.ebuild b/net-misc/gyach/gyach-0.8.5.ebuild
new file mode 100644
index 000000000000..abc9b83fce39
--- /dev/null
+++ b/net-misc/gyach/gyach-0.8.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gyach/gyach-0.8.5.ebuild,v 1.1 2002/10/01 05:26:00 bcowan Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+-based Yahoo! chat client"
+SRC_URI="http://www4.infi.net/~cpinkham/gyach/code/${P}.tar.gz"
+HOMEPAGE="http://www4.infi.net/~cpinkham/gyach/"
+KEYWORDS="x86 sparc sparc64"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ =x11-libs/gtk+-1.2*"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README* TODO
+ dodoc sample.*
+
+ # install icon and desktop entry for gnome
+ if [ "`use gnome`" ] ; then
+ insinto /usr/share/pixmaps
+ doins ${D}/usr/share/gyach/pixmaps/gyach-icon.xpm
+ insinto /usr/share/gnome/apps/Internet
+ doins ${FILESDIR}/gyach.desktop
+ fi
+
+}