summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-09 17:19:34 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-09 17:19:34 +0000
commitc4d00e279103752c904af7a38d24fd8d5767817e (patch)
tree94d0b38dcd3053d58becb2a15e5be5a0ab086e55 /net-misc/hsc
parentRemove hdump from tree. (diff)
downloadgentoo-2-c4d00e279103752c904af7a38d24fd8d5767817e.tar.gz
gentoo-2-c4d00e279103752c904af7a38d24fd8d5767817e.tar.bz2
gentoo-2-c4d00e279103752c904af7a38d24fd8d5767817e.zip
Fix building with GLIBC 2.10+ wrt #279083.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/hsc')
-rw-r--r--net-misc/hsc/ChangeLog6
-rw-r--r--net-misc/hsc/files/hsc-1.0b-glibc-2.10.patch12
-rw-r--r--net-misc/hsc/hsc-1.0b.ebuild5
3 files changed, 20 insertions, 3 deletions
diff --git a/net-misc/hsc/ChangeLog b/net-misc/hsc/ChangeLog
index 6391f33d3969..00ffbf7060d1 100644
--- a/net-misc/hsc/ChangeLog
+++ b/net-misc/hsc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/hsc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hsc/ChangeLog,v 1.14 2009/06/20 22:44:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hsc/ChangeLog,v 1.15 2009/08/09 17:19:34 ssuominen Exp $
+
+ 09 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> hsc-1.0b.ebuild,
+ +files/hsc-1.0b-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #279083.
20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org> -hsc-0.929.ebuild,
-files/Makefile.hsc-0.929.patch.gz, -files/Makefile.hsc-0.931.patch.bz2:
diff --git a/net-misc/hsc/files/hsc-1.0b-glibc-2.10.patch b/net-misc/hsc/files/hsc-1.0b-glibc-2.10.patch
new file mode 100644
index 000000000000..5c10efc0f9a2
--- /dev/null
+++ b/net-misc/hsc/files/hsc-1.0b-glibc-2.10.patch
@@ -0,0 +1,12 @@
+diff -ur hsc-1.0.orig/src/hsclib/css.c hsc-1.0/src/hsclib/css.c
+--- hsc-1.0.orig/src/hsclib/css.c 2006-04-03 17:18:37.000000000 +0300
++++ hsc-1.0/src/hsclib/css.c 2009-08-09 20:19:51.000000000 +0300
+@@ -129,7 +129,7 @@
+ #ifdef isblank
+ #undef isblank
+ #endif
+-static int isblank(int c)
++int isblank(int c)
+ {
+ return ((c == ' ') || (c == '\t'));
+ }
diff --git a/net-misc/hsc/hsc-1.0b.ebuild b/net-misc/hsc/hsc-1.0b.ebuild
index 08910a6451f0..0c45f50a6698 100644
--- a/net-misc/hsc/hsc-1.0b.ebuild
+++ b/net-misc/hsc/hsc-1.0b.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hsc/hsc-1.0b.ebuild,v 1.2 2008/10/28 07:21:43 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hsc/hsc-1.0b.ebuild,v 1.3 2009/08/09 17:19:34 ssuominen Exp $
inherit autotools eutils
@@ -24,6 +24,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-cflags.patch"
epatch "${FILESDIR}/${P}-nostrip.patch"
epatch "${FILESDIR}/${P}-parmake.patch"
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
eautoreconf
}